aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/ctwm
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-10 04:48:21 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-10 04:48:21 +0000
commit8f5f7d801731efe9794dc3afc6033c212bf35cd9 (patch)
treecc9f787b3e5b001b95e664de5ad4e4a084ad8624 /x11-wm/ctwm
parentc18738cf374ba9eb57656c4c38dea9678eeed6e7 (diff)
downloadports-8f5f7d801731efe9794dc3afc6033c212bf35cd9.tar.gz
ports-8f5f7d801731efe9794dc3afc6033c212bf35cd9.zip
- patch potential amd64 problem with assuming long is 32bits
PR: ports/163939 Submitted by: maintainer Approved by: gabor (mentor, implicit)
Notes
Notes: svn path=/head/; revision=288862
Diffstat (limited to 'x11-wm/ctwm')
-rw-r--r--x11-wm/ctwm/Makefile1
-rw-r--r--x11-wm/ctwm/files/patch-util.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11-wm/ctwm/Makefile b/x11-wm/ctwm/Makefile
index e263f61827bb..e84c349e8fd8 100644
--- a/x11-wm/ctwm/Makefile
+++ b/x11-wm/ctwm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ctwm
PORTVERSION= 3.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-wm
MASTER_SITES= http://ctwm.free.lp.se/dist/ \
diff --git a/x11-wm/ctwm/files/patch-util.c b/x11-wm/ctwm/files/patch-util.c
new file mode 100644
index 000000000000..f460a7e0bdf7
--- /dev/null
+++ b/x11-wm/ctwm/files/patch-util.c
@@ -0,0 +1,11 @@
+--- util.c.orig 2012-01-08 16:51:48.245308175 -0600
++++ util.c 2012-01-08 16:51:52.168309618 -0600
+@@ -3941,7 +3941,7 @@
+ #ifdef JPEG
+
+ unsigned short int *buffer_16bpp;
+-long *buffer_32bpp;
++uint32_t *buffer_32bpp;
+
+ static void convert_for_16 (int w, int x, int y, int r, int g, int b) {
+ buffer_16bpp [y * w + x] = ((r >> 3) << 11) + ((g >> 2) << 5) + (b >> 3);