aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/devilspie/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-14 20:46:14 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-14 20:46:14 +0000
commita74496a12ff6cc87c19aa5474b6f76f70e8f9893 (patch)
tree3d4e66698e2efe4d0a099b30b919030df804f623 /x11-wm/devilspie/Makefile
parent3d3dea2adb0f21c503649cd118128ff6f492670c (diff)
downloadports-a74496a12ff6cc87c19aa5474b6f76f70e8f9893.tar.gz
ports-a74496a12ff6cc87c19aa5474b6f76f70e8f9893.zip
Notes
Diffstat (limited to 'x11-wm/devilspie/Makefile')
-rw-r--r--x11-wm/devilspie/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/devilspie/Makefile b/x11-wm/devilspie/Makefile
new file mode 100644
index 000000000000..f68abe4695b0
--- /dev/null
+++ b/x11-wm/devilspie/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Devil's Pie
+# Date created: 08 Jun 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= devilspie
+PORTVERSION= 0.4
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.burtonini.com/computing/
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A window manipulation tool
+
+USE_X_PREFIX= yes
+USE_GNOME= libwnck libglade2
+GNU_CONFIGURE= yes
+
+MAN1= devilspie.1
+
+post-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/devilspie.dtd ${DATADIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample-config.xml ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} \
+ ${WRKSRC}/AUTHORS \
+ ${WRKSRC}/NEWS \
+ ${WRKSRC}/README \
+ ${WRKSRC}/TODO \
+ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>