aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/dwm
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-05 10:11:11 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-05 10:11:11 +0000
commit4cebccd3f7dcc0638f7f9c034ab1cebdae91e199 (patch)
treeace98e2e14bdebfcf756a0fa3036035ef131e529 /x11-wm/dwm
parent0aa12df0e025297f99d91f31d2160cb399a25e44 (diff)
downloadports-4cebccd3f7dcc0638f7f9c034ab1cebdae91e199.tar.gz
ports-4cebccd3f7dcc0638f7f9c034ab1cebdae91e199.zip
Notes
Diffstat (limited to 'x11-wm/dwm')
-rw-r--r--x11-wm/dwm/Makefile5
-rw-r--r--x11-wm/dwm/distinfo6
-rw-r--r--x11-wm/dwm/files/patch-config.mk30
3 files changed, 20 insertions, 21 deletions
diff --git a/x11-wm/dwm/Makefile b/x11-wm/dwm/Makefile
index a647da509e69..838f09188de7 100644
--- a/x11-wm/dwm/Makefile
+++ b/x11-wm/dwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dwm
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= x11-wm
MASTER_SITES= http://10kloc.org/download/ \
http://schot.a-eskwadraat.nl/files/
@@ -19,4 +19,7 @@ USE_XLIB= yes
MAN1= dwm.1
PLIST_FILES= bin/dwm
+post-patch:
+ ${CP} ${WRKSRC}/config.default.h ${WRKSRC}/config.h
+
.include <bsd.port.mk>
diff --git a/x11-wm/dwm/distinfo b/x11-wm/dwm/distinfo
index c7c35e6a6621..bab21121d606 100644
--- a/x11-wm/dwm/distinfo
+++ b/x11-wm/dwm/distinfo
@@ -1,3 +1,3 @@
-MD5 (dwm-0.5.tar.gz) = e8dfa2d3502d6bc9aeb9f0f21ab2dec5
-SHA256 (dwm-0.5.tar.gz) = d025d5a43dc09fa81985ea41363cd2dbc967a8923d6b62a930a7238a56ca1473
-SIZE (dwm-0.5.tar.gz) = 13795
+MD5 (dwm-0.6.tar.gz) = be86556b42a6aef84c99a5774a5acd46
+SHA256 (dwm-0.6.tar.gz) = 3e460f2f736a56972da800d5e96d63bc164de087f984cc516055abdb5e547563
+SIZE (dwm-0.6.tar.gz) = 13998
diff --git a/x11-wm/dwm/files/patch-config.mk b/x11-wm/dwm/files/patch-config.mk
index 625098511cb9..d44b408bb3cd 100644
--- a/x11-wm/dwm/files/patch-config.mk
+++ b/x11-wm/dwm/files/patch-config.mk
@@ -1,7 +1,7 @@
---- config.mk.orig Fri Jul 21 21:14:42 2006
-+++ config.mk Sat Jul 29 21:01:26 2006
-@@ -1,11 +1,11 @@
- # Customize to fit your system
+--- config.mk.orig Wed Aug 2 18:59:04 2006
++++ config.mk Wed Aug 2 19:00:14 2006
+@@ -4,21 +4,21 @@
+ # Customize below to fit your system
# paths
-PREFIX = /usr/local
@@ -14,21 +14,17 @@
+X11INC = $(X11BASE)/include
+X11LIB = $(X11BASE)/lib
- VERSION = 0.5
+ # includes and libs
+ INCS = -I/usr/lib -I${X11INC}
+ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
-@@ -13,7 +13,7 @@
- LIBS = -L${PREFIX}/lib -L/usr/lib -lc -L${X11LIB} -lX11
-
- # Linux/BSD
--CFLAGS = -O3 -I. -I${PREFIX}/include -I/usr/include -I${X11INC} \
-+CFLAGS+= -I. -I${PREFIX}/include -I/usr/include -I${X11INC} \
- -DVERSION=\"${VERSION}\"
+ # flags
+-CFLAGS = -O3 ${INCS} -DVERSION=\"${VERSION}\"
++CFLAGS+= ${INCS} -DVERSION=\"${VERSION}\"
LDFLAGS = ${LIBS}
- #CFLAGS = -g -Wall -O2 -I. -I${PREFIX}/include -I/usr/include -I${X11INC} \
-@@ -26,5 +26,5 @@
- #LIBS += -lnsl -lsocket
+ #CFLAGS = -g -Wall -O2 ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = -g ${LIBS}
- AR = ar cr
+ # compiler
-CC = cc
+CC?= cc
- RANLIB = ranlib