aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e-module-everything-websearch/Makefile
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2014-11-25 03:07:22 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2014-11-25 03:07:22 +0000
commit273c6e6d76de909e0b97d381d45340af8e91a37e (patch)
treea3ede366da71e5f2c9d8a5565a987a08de3b99d0 /x11-wm/e-module-everything-websearch/Makefile
parente688f6929aa312916047cec14f32a26ac695505a (diff)
downloadports-273c6e6d76de909e0b97d381d45340af8e91a37e.tar.gz
ports-273c6e6d76de909e0b97d381d45340af8e91a37e.zip
Notes
Diffstat (limited to 'x11-wm/e-module-everything-websearch/Makefile')
-rw-r--r--x11-wm/e-module-everything-websearch/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/e-module-everything-websearch/Makefile b/x11-wm/e-module-everything-websearch/Makefile
new file mode 100644
index 000000000000..714df22503c4
--- /dev/null
+++ b/x11-wm/e-module-everything-websearch/Makefile
@@ -0,0 +1,36 @@
+# Created by: Grzegorz Blach <gblach@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= e-module-everything-websearch
+PORTVERSION= 20140818
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= LOCAL/gblach/enlightenment/
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Enlightenment websearch plugin for the "everything" module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
+DIST_SUBDIR= enlightenment
+GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig tar:xz
+INSTALL_TARGET= install-strip
+
+.include "../enlightenment/Makefile.plist"
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>