aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e16/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-10-17 10:07:42 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-10-17 10:07:42 +0000
commit35000cab70e8204292a4a875f25857a2ab95aacf (patch)
treed4ade88f2fab6b9e4f7950ff73cc798e0f184657 /x11-wm/e16/Makefile
parent1d803f71bba5156f57c6f2ec4c16e17431b98aba (diff)
downloadports-35000cab70e8204292a4a875f25857a2ab95aacf.tar.gz
ports-35000cab70e8204292a4a875f25857a2ab95aacf.zip
Notes
Diffstat (limited to 'x11-wm/e16/Makefile')
-rw-r--r--x11-wm/e16/Makefile47
1 files changed, 17 insertions, 30 deletions
diff --git a/x11-wm/e16/Makefile b/x11-wm/e16/Makefile
index 4f208af2980c..446375281531 100644
--- a/x11-wm/e16/Makefile
+++ b/x11-wm/e16/Makefile
@@ -2,21 +2,33 @@
# $FreeBSD$
PORTNAME= e16
-PORTVERSION= 1.0.14
+PORTVERSION= 1.0.14.001
CATEGORIES= x11-wm enlightenment
-MASTER_SITES= SF/enlightenment/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= SF/enlightenment/${PORTNAME}/Snapshots/
MAINTAINER= gahr@FreeBSD.org
COMMENT= Enlightenment DR16 window manager
LICENSE= MIT
-OPTIONS_DEFINE= DOCS NLS SOUND
-SOUND_DESC= Sound support via pulseaudio/libsndfile
+OPTIONS_DEFINE= DOCS NLS SOUND
+OPTIONS_SUB= yes
+SOUND_DESC= Sound support via pulseaudio/libsndfile
+SOUND_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio \
+ libsndfile.so:${PORTSDIR}/audio/libsndfile
+SOUND_CONFIGURE_ON= --enable-sound \
+ --enable-sound-pulse \
+ --with-sndldr=sndfile
+SOUND_CONFIGURE_OFF= --disable-sound \
+ --with-sndldr=none
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
+DOCS_CONFIGURE_ON= --enable-docs=yes
+DOCS_CONFIGURE_OFF= --enable-docs=no
USE_XORG= compositeproto damageproto xextproto x11 xbitmaps xcomposite xdamage \
xext xfixes xft xinerama xrandr xrender xxf86vm
-USES= gettext gmake iconv libtool pkgconfig shebangfix
+USES= gettext gmake iconv libtool perl5 pkgconfig shebangfix
SHEBANG_FILES= scripts/e_gen_menu
USE_EFL= imlib2
CFLAGS+= -Wno-unused-parameter
@@ -26,31 +38,6 @@ CONFIGURE_ARGS= --disable-dependency-tracking \
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSOUND}
-LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio \
- libsndfile.so:${PORTSDIR}/audio/libsndfile
-CONFIGURE_ARGS+=--enable-sound \
- --enable-sound-pulse \
- --with-sndldr=sndfile
-.else
-CONFIGURE_ARGS+=--disable-sound \
- --with-sndldr=none
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+=--enable-docs=yes
-.else
-CONFIGURE_ARGS+=--enable-docs=no
-.endif
-
post-patch:
.if !${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/^SUBDIRS/s|docs ||' \