aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-cpu/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:10:32 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:10:32 +0000
commit0576c8295091ecc58a2fcd73254d10b0dce01c67 (patch)
tree75409b9f87c1c35220da6bfd16d85426d92bd1a9 /x11-wm/e17-module-cpu/Makefile
parente7022df49ceeeffe0494d3d26e73878d0033ebc9 (diff)
Notes
Diffstat (limited to 'x11-wm/e17-module-cpu/Makefile')
-rw-r--r--x11-wm/e17-module-cpu/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/e17-module-cpu/Makefile b/x11-wm/e17-module-cpu/Makefile
new file mode 100644
index 000000000000..187f09dc5588
--- /dev/null
+++ b/x11-wm/e17-module-cpu/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-cpu
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpu
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 module which allows users to monitor cpu load
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>