aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-deskshow/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 12:35:15 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 12:35:15 +0000
commitcefb4c693ba3a287f3e51c08fd8e71f471fbc670 (patch)
treefd8228eeec697acabcd2bdbf55bc033fbed7d3a3 /x11-wm/e17-module-deskshow/Makefile
parent3a8b79ee4086f8bffef70e1ebd211c1b5c291db1 (diff)
Notes
Diffstat (limited to 'x11-wm/e17-module-deskshow/Makefile')
-rw-r--r--x11-wm/e17-module-deskshow/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-wm/e17-module-deskshow/Makefile b/x11-wm/e17-module-deskshow/Makefile
new file mode 100644
index 000000000000..fea4c81f1c7a
--- /dev/null
+++ b/x11-wm/e17-module-deskshow/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: e17-module-deskshow
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= deskshow
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= E17 module that minimizes all windows to show the desktop
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>