aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-efm_path/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /x11-wm/e17-module-efm_path/Makefile
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'x11-wm/e17-module-efm_path/Makefile')
-rw-r--r--x11-wm/e17-module-efm_path/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/e17-module-efm_path/Makefile b/x11-wm/e17-module-efm_path/Makefile
new file mode 100644
index 000000000000..c629e32483ed
--- /dev/null
+++ b/x11-wm/e17-module-efm_path/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-efm_path
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= efm_path
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= An e17 module that allows a user to type a location into the filemanager
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>