aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-engage
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /x11-wm/e17-module-engage
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'x11-wm/e17-module-engage')
-rw-r--r--x11-wm/e17-module-engage/Makefile37
-rw-r--r--x11-wm/e17-module-engage/distinfo2
-rw-r--r--x11-wm/e17-module-engage/pkg-descr12
-rw-r--r--x11-wm/e17-module-engage/pkg-plist19
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-wm/e17-module-engage/Makefile b/x11-wm/e17-module-engage/Makefile
new file mode 100644
index 000000000000..56352536d82b
--- /dev/null
+++ b/x11-wm/e17-module-engage/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-itask-ng
+# Date created: 19 June 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= itask-ng
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= A fast applications switching module for e17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-engage/distinfo b/x11-wm/e17-module-engage/distinfo
new file mode 100644
index 000000000000..dda82d3f5f20
--- /dev/null
+++ b/x11-wm/e17-module-engage/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/itask-ng-20101003.tar.bz2) = 21aa7efaa096f2f29b9e46a0eb95f3b9c5a6e94800d0ef75c1f33a7505ff9fa4
+SIZE (e17/itask-ng-20101003.tar.bz2) = 557309
diff --git a/x11-wm/e17-module-engage/pkg-descr b/x11-wm/e17-module-engage/pkg-descr
new file mode 100644
index 000000000000..4d79d0534227
--- /dev/null
+++ b/x11-wm/e17-module-engage/pkg-descr
@@ -0,0 +1,12 @@
+This is the ITask Application module for Enlightenment.
+
+It will hold all of your open applications for fast switching.
+
+There are three basic functionalities that you don't want to miss:
+1. If you click on an icon it will be shown and raised to the top
+ and if its on another desk, then you will be switched to it.
+2. If you drag an icon out of ITask the App will be shown on the
+ current desktop.
+3. Drag an icon to a pagers desk to send it.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-engage/pkg-plist b/x11-wm/e17-module-engage/pkg-plist
new file mode 100644
index 000000000000..8afe09c88d12
--- /dev/null
+++ b/x11-wm/e17-module-engage/pkg-plist
@@ -0,0 +1,19 @@
+lib/enlightenment/modules/itask-ng/itask-ng.edj
+lib/enlightenment/modules/itask-ng/module_icon.png
+lib/enlightenment/modules/itask-ng/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/itask-ng/module.desktop
+lib/enlightenment/modules/itask-ng/e-module-ng.edj
+%%NLS%%lib/enlightenment/modules/itask-ng/locale/fr/LC_MESSAGES/itask-ng.mo
+%%NLS%%lib/enlightenment/modules/itask-ng/locale/de/LC_MESSAGES/itask-ng.mo
+%%NLS%%lib/enlightenment/modules/itask-ng/locale/it/LC_MESSAGES/itask-ng.mo
+%%NLS%%@dirrm lib/enlightenment/modules/itask-ng/locale/it/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/itask-ng/locale/it
+%%NLS%%@dirrm lib/enlightenment/modules/itask-ng/locale/de/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/itask-ng/locale/de
+%%NLS%%@dirrm lib/enlightenment/modules/itask-ng/locale/fr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/itask-ng/locale/fr
+%%NLS%%@dirrm lib/enlightenment/modules/itask-ng/locale
+@dirrm lib/enlightenment/modules/itask-ng/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/itask-ng
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment