aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-mail/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:01:34 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:01:34 +0000
commit9e0bbe96f718005864d89ba1a185721a035d2085 (patch)
tree69d18ab411b1d918aaf7fb6bfc58a3ed9a4290c7 /x11-wm/e17-module-mail/Makefile
parentf6d8d65eeff5b374fd45e7814e65bfa6f85c92c3 (diff)
downloadports-9e0bbe96f718005864d89ba1a185721a035d2085.tar.gz
ports-9e0bbe96f718005864d89ba1a185721a035d2085.zip
Notes
Diffstat (limited to 'x11-wm/e17-module-mail/Makefile')
-rw-r--r--x11-wm/e17-module-mail/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-wm/e17-module-mail/Makefile b/x11-wm/e17-module-mail/Makefile
new file mode 100644
index 000000000000..5a24c97c9f2d
--- /dev/null
+++ b/x11-wm/e17-module-mail/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: e17-module-mail
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mail
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 module to check your mailboxes (like xbiff does)
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>