aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-tiling
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /x11-wm/e17-module-tiling
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'x11-wm/e17-module-tiling')
-rw-r--r--x11-wm/e17-module-tiling/Makefile37
-rw-r--r--x11-wm/e17-module-tiling/distinfo2
-rw-r--r--x11-wm/e17-module-tiling/pkg-descr4
-rw-r--r--x11-wm/e17-module-tiling/pkg-plist74
4 files changed, 117 insertions, 0 deletions
diff --git a/x11-wm/e17-module-tiling/Makefile b/x11-wm/e17-module-tiling/Makefile
new file mode 100644
index 000000000000..b197d1a50cfb
--- /dev/null
+++ b/x11-wm/e17-module-tiling/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-tiling
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tiling
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= A tiling-like windows control module for e17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-tiling/distinfo b/x11-wm/e17-module-tiling/distinfo
new file mode 100644
index 000000000000..2c05aa7af9f7
--- /dev/null
+++ b/x11-wm/e17-module-tiling/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/tiling-20101003.tar.bz2) = e633a0ba82ac869ecbc9b2fffb8ea8b1d59b68273927f7df7c75cc556211acd6
+SIZE (e17/tiling-20101003.tar.bz2) = 485638
diff --git a/x11-wm/e17-module-tiling/pkg-descr b/x11-wm/e17-module-tiling/pkg-descr
new file mode 100644
index 000000000000..0803ea4d1911
--- /dev/null
+++ b/x11-wm/e17-module-tiling/pkg-descr
@@ -0,0 +1,4 @@
+An e17 module that allows you to control windows like tiling window
+managers do.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-tiling/pkg-plist b/x11-wm/e17-module-tiling/pkg-plist
new file mode 100644
index 000000000000..f71f84fb0fa9
--- /dev/null
+++ b/x11-wm/e17-module-tiling/pkg-plist
@@ -0,0 +1,74 @@
+lib/enlightenment/modules/tiling/module.desktop
+lib/enlightenment/modules/tiling/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/tiling/e-module-tiling.edj
+%%NLS%%lib/enlightenment/modules/tiling/locale/it/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/eo/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/tr/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/sk/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/ja/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/uk/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/pt_BR/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/el/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/sv/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/pt/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/ru/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/cs/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/he/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/ar/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/lt/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/fr/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/nl/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/hr/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/zh_CN/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/pl/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/es/LC_MESSAGES/tiling.mo
+%%NLS%%lib/enlightenment/modules/tiling/locale/hu/LC_MESSAGES/tiling.mo
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/hu/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/hu
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/es/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/es
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/pl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/pl
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/zh_CN/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/zh_CN
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/hr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/hr
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/nl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/nl
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/fr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/fr
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/lt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/lt
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/ar/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/ar
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/he/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/he
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/cs/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/cs
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/ru/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/ru
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/pt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/pt
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/sv/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/sv
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/el/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/el
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/pt_BR/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/pt_BR
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/uk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/uk
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/ja/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/ja
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/sk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/sk
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/tr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/tr
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/eo/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/eo
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/it/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale/it
+%%NLS%%@dirrm lib/enlightenment/modules/tiling/locale
+@dirrm lib/enlightenment/modules/tiling/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/tiling
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment