aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-winselector/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
commitee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442 (patch)
tree1bf12eadb5a7920766bf7a613174c0475b810d0d /x11-wm/e17-module-winselector/Makefile
parent32e98c797bd5b952894ff185e59df8a91844f4ab (diff)
- Move to LOCALBASE
- Use new EFL framework - Update all e17 ports to the lates stable cvs snapshot - Add additional knobs/options to ports makefiles to control the feature set - Add a bunch of new e17 applications/libraries - Minor improvements/modification. Approved by: vanilla (old maintainer), sem (mentor)
Notes
Notes: svn path=/head/; revision=174934
Diffstat (limited to 'x11-wm/e17-module-winselector/Makefile')
-rw-r--r--x11-wm/e17-module-winselector/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-wm/e17-module-winselector/Makefile b/x11-wm/e17-module-winselector/Makefile
new file mode 100644
index 000000000000..553c0ec4c557
--- /dev/null
+++ b/x11-wm/e17-module-winselector/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: winselector
+# Date created: 2006-08-15
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= winselector
+PORTVERSION= 20060926
+CATEGORIES= x11
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
+PKGNAMEPREFIX= e17-module-
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= An e17 module to switch between windows
+
+BUILD_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig gnometarget
+USE_EFL= edje
+
+.include <bsd.port.pre.mk>
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.include <bsd.port.post.mk>