aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-wlan
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /x11-wm/e17-module-wlan
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'x11-wm/e17-module-wlan')
-rw-r--r--x11-wm/e17-module-wlan/Makefile37
-rw-r--r--x11-wm/e17-module-wlan/distinfo2
-rw-r--r--x11-wm/e17-module-wlan/pkg-descr3
-rw-r--r--x11-wm/e17-module-wlan/pkg-plist96
4 files changed, 138 insertions, 0 deletions
diff --git a/x11-wm/e17-module-wlan/Makefile b/x11-wm/e17-module-wlan/Makefile
new file mode 100644
index 000000000000..1ba2a8db7a1e
--- /dev/null
+++ b/x11-wm/e17-module-wlan/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-wlan
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wlan
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= An e17 wlan devices monitoring module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-wlan/distinfo b/x11-wm/e17-module-wlan/distinfo
new file mode 100644
index 000000000000..72ccd7a14872
--- /dev/null
+++ b/x11-wm/e17-module-wlan/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/wlan-20101003.tar.bz2) = f8b41656e0c93c05f4b527105284ec99b1becaf284a45d7f72864312c438149c
+SIZE (e17/wlan-20101003.tar.bz2) = 527490
diff --git a/x11-wm/e17-module-wlan/pkg-descr b/x11-wm/e17-module-wlan/pkg-descr
new file mode 100644
index 000000000000..e395d86603ac
--- /dev/null
+++ b/x11-wm/e17-module-wlan/pkg-descr
@@ -0,0 +1,3 @@
+AN e17 gadget to monitor wlan devices.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-wlan/pkg-plist b/x11-wm/e17-module-wlan/pkg-plist
new file mode 100644
index 000000000000..56e37f058ab4
--- /dev/null
+++ b/x11-wm/e17-module-wlan/pkg-plist
@@ -0,0 +1,96 @@
+lib/enlightenment/modules/wlan/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/wlan/wlan.edj
+lib/enlightenment/modules/wlan/e-module-wlan.edj
+lib/enlightenment/modules/wlan/module.desktop
+%%NLS%%lib/enlightenment/modules/wlan/locale/pt_BR/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/cs/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/lt/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/he/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/ar/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/fr/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/nl/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/nb/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/bg/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/hr/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/hu/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/es/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/pl/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/ms/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/it/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/eo/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/zh_CN/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/tr/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/sk/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/da/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/uk/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/ja/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/de/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/el/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/pt/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/sv/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/fi/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/id/LC_MESSAGES/wlan.mo
+%%NLS%%lib/enlightenment/modules/wlan/locale/ru/LC_MESSAGES/wlan.mo
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ru/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ru
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/id/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/id
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/fi/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/fi
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/sv/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/sv
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/pt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/pt
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/el/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/el
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/de/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/de
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ja/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ja
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/uk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/uk
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/da/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/da
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/sk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/sk
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/tr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/tr
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/zh_CN/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/zh_CN
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/eo/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/eo
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/it/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/it
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ms/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ms
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/pl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/pl
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/es/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/es
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/hu/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/hu
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/hr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/hr
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/bg/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/bg
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/nb/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/nb
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/nl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/nl
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/fr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/fr
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ar/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/ar
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/he/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/he
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/lt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/lt
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/cs/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/cs
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/pt_BR/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale/pt_BR
+%%NLS%%@dirrm lib/enlightenment/modules/wlan/locale
+@dirrm lib/enlightenment/modules/wlan/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/wlan
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment