aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fbcmd
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /x11-wm/fbcmd
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
Notes
Diffstat (limited to 'x11-wm/fbcmd')
-rw-r--r--x11-wm/fbcmd/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-wm/fbcmd/Makefile b/x11-wm/fbcmd/Makefile
index f22875100ad7..6c0fbdfd82fe 100644
--- a/x11-wm/fbcmd/Makefile
+++ b/x11-wm/fbcmd/Makefile
@@ -14,13 +14,16 @@ RUN_DEPENDS= fluxbox:${PORTSDIR}/x11-wm/fluxbox
USES= gmake tar:bzip2
ALL_TARGET= first
-CFLAGS+= "-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ARGS= CXX="${CXX}" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LFLAGS="${LDFLAGS}"
USE_XORG= x11 xmu
PLIST_FILES= bin/fbcmd
-post-extract:
- @${REINPLACE_CMD} -e "s|/usr/X11R6|${LOCALBASE}|g" ${WRKSRC}/Makefile
+post-patch:
+ @${REINPLACE_CMD} 's|?=|=|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fbcmd ${STAGEDIR}${PREFIX}/bin