aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fluxbox
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2018-05-10 20:02:33 +0000
committerAlan Somers <asomers@FreeBSD.org>2018-05-10 20:02:33 +0000
commit6daed9aef6d9d91f0a85b50b04f8fc1879f1cdb1 (patch)
tree84b7d016c21d71df9911a0e0f5d75a5c6a3a0b37 /x11-wm/fluxbox
parent07c0f66f9c91d3268e9621eb98935c663080b097 (diff)
downloadports-6daed9aef6d9d91f0a85b50b04f8fc1879f1cdb1.tar.gz
ports-6daed9aef6d9d91f0a85b50b04f8fc1879f1cdb1.zip
Notes
Diffstat (limited to 'x11-wm/fluxbox')
-rw-r--r--x11-wm/fluxbox/Makefile2
-rw-r--r--x11-wm/fluxbox/files/patch-src_FbRootWindow.cc24
-rw-r--r--x11-wm/fluxbox/files/patch-src_FbRootWindow.hh18
-rw-r--r--x11-wm/fluxbox/files/patch-src_FbWinFrame.cc13
-rw-r--r--x11-wm/fluxbox/files/patch-src_Screen.cc11
5 files changed, 67 insertions, 1 deletions
diff --git a/x11-wm/fluxbox/Makefile b/x11-wm/fluxbox/Makefile
index 4794252177ba..5cc8936e55d9 100644
--- a/x11-wm/fluxbox/Makefile
+++ b/x11-wm/fluxbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fluxbox
PORTVERSION= 1.3.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= SF
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/x11-wm/fluxbox/files/patch-src_FbRootWindow.cc b/x11-wm/fluxbox/files/patch-src_FbRootWindow.cc
new file mode 100644
index 000000000000..3b7403e4faca
--- /dev/null
+++ b/x11-wm/fluxbox/files/patch-src_FbRootWindow.cc
@@ -0,0 +1,24 @@
+--- src/FbRootWindow.cc.orig 2015-02-08 10:44:45 UTC
++++ src/FbRootWindow.cc
+@@ -30,7 +30,8 @@ FbRootWindow::FbRootWindow(int screen_num):
+ m_colormap(0),
+ m_decorationDepth(0),
+ m_decorationVisual(0),
+- m_decorationColormap(0) {
++ m_decorationColormap(0),
++ m_maxDepth(depth()) {
+
+ Display *disp = FbTk::App::instance()->display();
+
+@@ -55,9 +56,9 @@ FbRootWindow::FbRootWindow(int screen_num):
+
+ for (int i = 0; i < vinfo_nitems; i++) {
+ if ((DefaultDepth(disp, screen_num) < vinfo_return[i].depth)
+- && (static_cast<int>(depth()) < vinfo_return[i].depth)){
++ && (m_maxDepth < vinfo_return[i].depth)){
+ m_visual = vinfo_return[i].visual;
+- setDepth(vinfo_return[i].depth);
++ m_maxDepth = vinfo_return[i].depth;
+ }
+
+ if((m_decorationDepth < vinfo_return[i].depth)
diff --git a/x11-wm/fluxbox/files/patch-src_FbRootWindow.hh b/x11-wm/fluxbox/files/patch-src_FbRootWindow.hh
new file mode 100644
index 000000000000..98b8200d5d29
--- /dev/null
+++ b/x11-wm/fluxbox/files/patch-src_FbRootWindow.hh
@@ -0,0 +1,18 @@
+--- src/FbRootWindow.hh.orig 2015-02-08 10:44:45 UTC
++++ src/FbRootWindow.hh
+@@ -41,6 +41,7 @@ class FbRootWindow: public FbTk::FbWindow { (public)
+ int decorationDepth() const { return m_decorationDepth; }
+ Visual *decorationVisual() const { return m_decorationVisual; }
+ Colormap decorationColormap() const { return m_decorationColormap; }
++ int maxDepth() const { return m_maxDepth; }
+
+ private:
+ Visual *m_visual;
+@@ -49,6 +50,7 @@ class FbRootWindow: public FbTk::FbWindow { (public)
+ int m_decorationDepth;
+ Visual *m_decorationVisual;
+ Colormap m_decorationColormap;
++ int m_maxDepth;
+ };
+
+ #endif // FBROOTWINDOW_HH
diff --git a/x11-wm/fluxbox/files/patch-src_FbWinFrame.cc b/x11-wm/fluxbox/files/patch-src_FbWinFrame.cc
new file mode 100644
index 000000000000..70cf3c5b8bb8
--- /dev/null
+++ b/x11-wm/fluxbox/files/patch-src_FbWinFrame.cc
@@ -0,0 +1,13 @@
+--- src/FbWinFrame.cc.orig 2015-02-08 10:44:45 UTC
++++ src/FbWinFrame.cc
+@@ -115,8 +115,8 @@ FbWinFrame::FbWinFrame(BScreen &screen, unsigned int c
+ m_state(state),
+ m_window(theme->screenNum(), state.x, state.y, state.width, state.height, s_mask, true, false,
+ client_depth, InputOutput,
+- ((client_depth == 32) && (screen.rootWindow().depth() == 32) ? screen.rootWindow().visual() : CopyFromParent),
+- ((client_depth == 32) && (screen.rootWindow().depth() == 32) ? screen.rootWindow().colormap() : CopyFromParent)),
++ (client_depth == screen.rootWindow().maxDepth() ? screen.rootWindow().visual() : CopyFromParent),
++ (client_depth == screen.rootWindow().maxDepth() ? screen.rootWindow().colormap() : CopyFromParent)),
+ m_layeritem(window(), *screen.layerManager().getLayer(ResourceLayer::NORMAL)),
+ m_titlebar(m_window, 0, 0, 100, 16, s_mask, false, false,
+ screen.rootWindow().decorationDepth(), InputOutput,
diff --git a/x11-wm/fluxbox/files/patch-src_Screen.cc b/x11-wm/fluxbox/files/patch-src_Screen.cc
new file mode 100644
index 000000000000..092b3952c873
--- /dev/null
+++ b/x11-wm/fluxbox/files/patch-src_Screen.cc
@@ -0,0 +1,11 @@
+--- src/Screen.cc.orig 2015-02-08 10:44:45 UTC
++++ src/Screen.cc
+@@ -297,7 +297,7 @@ BScreen::BScreen(FbTk::ResourceManager &rm,
+ "using visual 0x%lx, depth %d\n",
+ "informational message saying screen number (%d), visual (%lx), and colour depth (%d)").c_str(),
+ screenNumber(), XVisualIDFromVisual(rootWindow().visual()),
+- rootWindow().depth());
++ rootWindow().maxDepth());
+ #endif // DEBUG
+
+ FbTk::EventManager *evm = FbTk::EventManager::instance();