aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fluxbox
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2009-07-07 21:09:20 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2009-07-07 21:09:20 +0000
commitef3138a8d6f5d5e429d678159ab1dfaee2511e73 (patch)
tree0c2579288217cc32cbb39c7a5e04c9f9dd1823e0 /x11-wm/fluxbox
parent7ba9bf2e602716f10a69772d2d03a3de57906de4 (diff)
downloadports-ef3138a8d6f5d5e429d678159ab1dfaee2511e73.tar.gz
ports-ef3138a8d6f5d5e429d678159ab1dfaee2511e73.zip
Notes
Diffstat (limited to 'x11-wm/fluxbox')
-rw-r--r--x11-wm/fluxbox/Makefile3
-rw-r--r--x11-wm/fluxbox/distinfo6
-rw-r--r--x11-wm/fluxbox/files/patch-aaa0010
-rw-r--r--x11-wm/fluxbox/files/patch-aaa01160
-rw-r--r--x11-wm/fluxbox/files/patch-aaa0354
-rw-r--r--x11-wm/fluxbox/files/patch-aaa0710
-rw-r--r--x11-wm/fluxbox/files/patch-disable-remember.patch122
-rw-r--r--x11-wm/fluxbox/files/patch-fix_pixmap_resource_leak102
-rw-r--r--x11-wm/fluxbox/files/patch-fix_unshading_crash25
9 files changed, 135 insertions, 357 deletions
diff --git a/x11-wm/fluxbox/Makefile b/x11-wm/fluxbox/Makefile
index 93f81ad9d20c..9e7d0f27ccf0 100644
--- a/x11-wm/fluxbox/Makefile
+++ b/x11-wm/fluxbox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fluxbox
-PORTVERSION= 1.1.0.1
-PORTREVISION= 5
+PORTVERSION= 1.1.1
CATEGORIES= x11-wm
MASTER_SITES= SF
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
diff --git a/x11-wm/fluxbox/distinfo b/x11-wm/fluxbox/distinfo
index a7bdd53276ad..9ad1c9a02cf6 100644
--- a/x11-wm/fluxbox/distinfo
+++ b/x11-wm/fluxbox/distinfo
@@ -1,6 +1,6 @@
-MD5 (fluxbox-1.1.0.1.tar.gz) = 6f5aa590058a39bc1cfdbe38b092e2b3
-SHA256 (fluxbox-1.1.0.1.tar.gz) = ff292dee6f36ef690df3989480481f679f95daee98a85d5dcdbf0a6fa4223ea4
-SIZE (fluxbox-1.1.0.1.tar.gz) = 1013472
+MD5 (fluxbox-1.1.1.tar.gz) = e0be927617be4ffc1ddc79513f4eb0f9
+SHA256 (fluxbox-1.1.1.tar.gz) = 7306ee55a8e95a4d07bee339ffb3be2d88ef8cc08b86edd6c63d7b28f559ec88
+SIZE (fluxbox-1.1.1.tar.gz) = 1012997
MD5 (fb-doc-mfhtml-20060629.tgz) = 0c100fe1489c22f5b205d87b9a6fa006
SHA256 (fb-doc-mfhtml-20060629.tgz) = 98d37b73dbb1caf1361b098bffc69d1f365f9b324a71f622ba72ed5da5d9b9ec
SIZE (fb-doc-mfhtml-20060629.tgz) = 115560
diff --git a/x11-wm/fluxbox/files/patch-aaa00 b/x11-wm/fluxbox/files/patch-aaa00
deleted file mode 100644
index 1b01d73e6e35..000000000000
--- a/x11-wm/fluxbox/files/patch-aaa00
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/fluxbox.cc.orig
-+++ src/fluxbox.cc
-@@ -825,6 +825,7 @@ void Fluxbox::handleEvent(XEvent * const e) {
- // a grab is something of a pseudo-focus event, so we ignore
- // them, here we ignore some window receiving it
- if (e->xfocus.mode == NotifyGrab ||
-+ e->xfocus.mode == NotifyUngrab ||
- e->xfocus.detail == NotifyPointer ||
- e->xfocus.detail == NotifyInferior)
- break;
diff --git a/x11-wm/fluxbox/files/patch-aaa01 b/x11-wm/fluxbox/files/patch-aaa01
deleted file mode 100644
index a2e5d1bac851..000000000000
--- a/x11-wm/fluxbox/files/patch-aaa01
+++ /dev/null
@@ -1,160 +0,0 @@
-From: Henrik Kinnunen <fluxgen@fluxbox.org>
-Date: Sun, 14 Sep 2008 18:06:28 +0000 (+0200)
-Subject: some minor code cleaning.
-X-Git-Tag: Release-1_1_1~4
-X-Git-Url: http://git.fluxbox.org/?p=fluxbox.git;a=commitdiff_plain;h=9f519ec0fcb7cd0dec61a4c31d246800f9a73cb3
-
-some minor code cleaning.
----
-
-diff --git a/src/FbWinFrame.cc b/src/FbWinFrame.cc
-index 5b91218..fc35ae1 100644
---- a/src/FbWinFrame.cc
-+++ src/FbWinFrame.cc
-@@ -1717,3 +1717,10 @@ void FbWinFrame::displaySize(unsigned int width, unsigned int height) const {
- width, height - titlebarHeight() - handleHeight());
- m_screen.showGeometry(i, j);
- }
-+
-+bool FbWinFrame::insideTitlebar(Window win) const {
-+ return
-+ gripLeft().window() != win &&
-+ gripRight().window() != win &&
-+ window().window() != win;
-+}
-diff --git a/src/FbWinFrame.hh b/src/FbWinFrame.hh
-index fcbe11e..ff9c19e 100644
---- a/src/FbWinFrame.hh
-+++ src/FbWinFrame.hh
-@@ -236,6 +236,9 @@ public:
-
- const FbTk::Subject &frameExtentSig() const { return m_frame_extent_sig; }
- FbTk::Subject &frameExtentSig() { return m_frame_extent_sig; }
-+ /// @returns true if the window is inside titlebar,
-+ /// assuming window is an event window that was generated for this frame.
-+ bool insideTitlebar(Window win) const;
-
- //@}
-
-diff --git a/src/RectangleUtil.hh b/src/RectangleUtil.hh
-new file mode 100644
-index 0000000..88c3a33
---- /dev/null
-+++ src/RectangleUtil.hh
-@@ -0,0 +1,30 @@
-+#ifndef RECTANGLEUTIL_HH
-+#define RECTANGLEUTIL_HH
-+
-+namespace RectangleUtil {
-+
-+
-+/*
-+ * Determines if a point is inside a rectangle-like objects border.
-+ * @param rect A rectangle-like object that has accessors for x, y, width, and
-+ * height.
-+ * @param x
-+ * @param y
-+ * @param border_width The size of the border.
-+ * @returns true if point is inside the rectangle-like object.
-+*/
-+template <typename RectangleLike>
-+bool insideBorder(const RectangleLike& rect,
-+ int x, int y,
-+ int border_width) {
-+ return
-+ x >= rect.x() + border_width &&
-+ x < rect.x() + (int)rect.width() + border_width &&
-+ y >= rect.y() + border_width &&
-+ y < rect.y() + (int)rect.height() + border_width;
-+}
-+
-+} // namespace RectangleUtil
-+
-+
-+#endif // RECTANGLEUTIL_HH
-diff --git a/src/Window.cc b/src/Window.cc
-index 16334c6..5d50fcf 100644
---- a/src/Window.cc
-+++ src/Window.cc
-@@ -41,6 +41,7 @@
- #include "FocusControl.hh"
- #include "IconButton.hh"
- #include "ScreenPlacement.hh"
-+#include "RectangleUtil.hh"
-
- #include "FbTk/StringUtil.hh"
- #include "FbTk/Compose.hh"
-@@ -2362,10 +2363,9 @@ void FluxboxWindow::buttonPressEvent(XButtonEvent &be) {
- m_last_button_x = be.x_root;
- m_last_button_y = be.y_root;
-
-- bool onTitlebar = frame().gripLeft().window() != be.window &&
-- frame().gripRight().window() != be.window &&
-- frame().handle().window() != be.window &&
-- frame().window() != be.window;
-+ bool onTitlebar =
-+ frame().insideTitlebar( be.window ) &&
-+ frame().handle().window() != be.window;
-
- if (onTitlebar && be.button == 1)
- raise();
-@@ -2422,41 +2422,31 @@ void FluxboxWindow::motionNotifyEvent(XMotionEvent &me) {
- me.window = frame().window().window();
- }
-
-- bool inside_titlebar = frame().gripLeft().window() != me.window &&
-- frame().gripRight().window() != me.window &&
-- frame().window() != me.window;
-+ bool inside_titlebar = frame().insideTitlebar( me.window );
-
- if (Fluxbox::instance()->getIgnoreBorder() && m_attaching_tab == 0
- && !(isMoving() || isResizing())) {
-+
-+ using RectangleUtil::insideBorder;
-+
- int borderw = frame().window().borderWidth();
- //!! TODO(tabs): the below test ought to be in FbWinFrame
- // if mouse is currently on the window border, ignore it
-- if ((me.x_root < (frame().x() + borderw) ||
-- me.y_root < (frame().y() + borderw) ||
-- me.x_root >= (frame().x() + (int)frame().width() + borderw) ||
-- me.y_root >= (frame().y() + (int)frame().height() + borderw))
-- && (!frame().externalTabMode() ||
-- (me.x_root < (frame().tabcontainer().x() + borderw) ||
-- me.y_root < (frame().tabcontainer().y() + borderw) ||
-- me.x_root >= (frame().tabcontainer().x() +
-- (int)frame().tabcontainer().width() + borderw) ||
-- me.y_root >= (frame().tabcontainer().y() +
-- (int)frame().tabcontainer().height() + borderw)))
-- // or if mouse was on border when it was last clicked
-- || (m_last_button_x < (frame().x() + borderw) ||
-- m_last_button_y < (frame().y() + borderw) ||
-- m_last_button_x >= (frame().x() +
-- (int)frame().width() + borderw) ||
-- m_last_button_y >= (frame().y() +
-- (int)frame().height() + borderw))
-- && (!frame().externalTabMode() ||
-- (m_last_button_x < (frame().tabcontainer().x() + borderw) ||
-- m_last_button_y < (frame().tabcontainer().y() + borderw) ||
-- m_last_button_x >= (frame().tabcontainer().x() +
-- (int)frame().tabcontainer().width() + borderw) ||
-- m_last_button_y >= (frame().tabcontainer().y() +
-- (int)frame().tabcontainer().height() + borderw))))
-+ if ( ! insideBorder(frame(),
-+ me.x_root, me.y_root, borderw) &&
-+ ( !frame().externalTabMode() ||
-+ ! insideBorder(frame().tabcontainer(),
-+ me.x_root, me.y_root, borderw) )
-+
-+ || // or if mouse was on border when it was last clicked
-+
-+ ! insideBorder(frame(),
-+ m_last_button_x, m_last_button_y, borderw) &&
-+ ( ! frame().externalTabMode() ||
-+ ! insideBorder(frame().tabcontainer(),
-+ m_last_button_x, m_last_button_y, borderw ) ) ) {
- return;
-+ }
- }
-
- if (moving || ((me.state & Button1Mask) && functions.move &&
diff --git a/x11-wm/fluxbox/files/patch-aaa03 b/x11-wm/fluxbox/files/patch-aaa03
deleted file mode 100644
index 636d6eba0b20..000000000000
--- a/x11-wm/fluxbox/files/patch-aaa03
+++ /dev/null
@@ -1,54 +0,0 @@
-From: Henrik Kinnunen <fluxgen@fluxbox.org>
-Date: Sun, 14 Sep 2008 19:46:36 +0000 (+0200)
-Subject: added RectangleUtil.hh to build
-X-Git-Tag: Release-1_1_1~2
-X-Git-Url: http://git.fluxbox.org/?p=fluxbox.git;a=commitdiff_plain;h=a4feddcbd63a4eca37ea3c1641daee25ed9a4c28
-
-added RectangleUtil.hh to build
----
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index ce591d5..cfc06b3 100644
---- a/src/Makefile.am
-+++ src/Makefile.am
-@@ -151,6 +151,7 @@ fluxbox_SOURCES = AtomHandler.hh ArrowButton.hh ArrowButton.cc \
- IconbarTheme.hh IconbarTheme.cc \
- Focusable.hh FocusableList.hh FocusableList.cc FocusableTheme.hh \
- WindowMenuAccessor.hh \
-+ RectangleUtil.hh \
- ${newwmspec_SOURCE} ${gnome_SOURCE} \
- ${REMEMBER_SOURCE} ${TOOLBAR_SOURCE}
-
---- src/Makefile.in 2008-09-03 22:44:02.000000000 +0400
-+++ src/Makefile.in 2008-11-20 03:54:38.000000000 +0300
-@@ -98,10 +98,10 @@
- AttentionNoticeHandler.cc IconButton.hh IconButton.cc \
- IconbarTheme.hh IconbarTheme.cc Focusable.hh FocusableList.hh \
- FocusableList.cc FocusableTheme.hh WindowMenuAccessor.hh \
-- Ewmh.hh Ewmh.cc Gnome.hh Gnome.cc Remember.hh Remember.cc \
-- ClientPattern.hh ClientPattern.cc Toolbar.hh Toolbar.cc \
-- ToolbarTheme.hh ToolbarTheme.cc ToolbarItem.hh ToolbarItem.cc \
-- ClockTool.hh ClockTool.cc WorkspaceNameTool.hh \
-+ RectangleUtil.hh Ewmh.hh Ewmh.cc Gnome.hh Gnome.cc Remember.hh \
-+ Remember.cc ClientPattern.hh ClientPattern.cc Toolbar.hh \
-+ Toolbar.cc ToolbarTheme.hh ToolbarTheme.cc ToolbarItem.hh \
-+ ToolbarItem.cc ClockTool.hh ClockTool.cc WorkspaceNameTool.hh \
- WorkspaceNameTool.cc WorkspaceNameTheme.hh IconbarTool.hh \
- IconbarTool.cc ToolTheme.hh ToolTheme.cc SystemTray.hh \
- SystemTray.cc GenericTool.hh GenericTool.cc ButtonTool.hh \
-@@ -285,6 +285,7 @@
- srcdir = @srcdir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
-+top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- SUBDIRS = FbTk
-@@ -363,6 +364,7 @@
- IconbarTheme.hh IconbarTheme.cc \
- Focusable.hh FocusableList.hh FocusableList.cc FocusableTheme.hh \
- WindowMenuAccessor.hh \
-+ RectangleUtil.hh \
- ${newwmspec_SOURCE} ${gnome_SOURCE} \
- ${REMEMBER_SOURCE} ${TOOLBAR_SOURCE}
-
diff --git a/x11-wm/fluxbox/files/patch-aaa07 b/x11-wm/fluxbox/files/patch-aaa07
index 61d22624bd19..fe415738344a 100644
--- a/x11-wm/fluxbox/files/patch-aaa07
+++ b/x11-wm/fluxbox/files/patch-aaa07
@@ -6,6 +6,14 @@ X-Git-Url: http://git.fluxbox.org/?p=fluxbox.git;a=commitdiff_plain;h=6642792f68
additional fix for the resize bug
---
+From: Peter Hercek <hercek at sf dot net>
+Date: Sun, 11 Jan 2009 13:23:08 +0000 (+0100)
+Subject: fixed resize bug (caused by typo, see #2498507)
+X-Git-Url: http://git.fluxbox.org/?p=fluxbox.git;a=commitdiff_plain;h=4e831484d55398e5c328aeb531060ffaf997f300
+
+fixed resize bug (caused by typo, see #2498507)
+---
+
diff --git a/src/FbWinFrame.cc b/src/FbWinFrame.cc
index ce25004..711e993 100644
--- a/src/FbWinFrame.cc
@@ -23,7 +31,7 @@ index ce25004..711e993 100644
void FbWinFrame::applySizeHints(unsigned int &width, unsigned int &height,
bool maximizing) const {
- height -= titlebarHeight() + handleHeight();
-+ const int h = height - titlebarHeight() + handleHeight();
++ const int h = height - titlebarHeight() - handleHeight();
+ height = max(h, static_cast<int>(titlebarHeight() + handleHeight()));
sizeHints().apply(width, height, maximizing);
height += titlebarHeight() + handleHeight();
diff --git a/x11-wm/fluxbox/files/patch-disable-remember.patch b/x11-wm/fluxbox/files/patch-disable-remember.patch
new file mode 100644
index 000000000000..7c147ded83a3
--- /dev/null
+++ b/x11-wm/fluxbox/files/patch-disable-remember.patch
@@ -0,0 +1,122 @@
+--- src/Makefile.in.orig 2009-03-23 20:37:16.000000000 +0100
++++ src/Makefile.in 2009-03-23 20:37:26.000000000 +0100
+@@ -86,31 +86,30 @@
+ FbMenuParser.hh FbMenuParser.cc StyleMenuItem.hh \
+ StyleMenuItem.cc RootCmdMenuItem.hh RootCmdMenuItem.cc \
+ MenuCreator.hh MenuCreator.cc ClientMenu.hh ClientMenu.cc \
+- WorkspaceMenu.hh WorkspaceMenu.cc FocusModelMenuItem.hh \
+- ToggleMenu.hh HeadArea.hh HeadArea.cc Resources.cc \
+- WindowCmd.hh WindowCmd.cc FocusControl.hh FocusControl.cc \
+- PlacementStrategy.hh CascadePlacement.hh CascadePlacement.cc \
+- ColSmartPlacement.hh ColSmartPlacement.cc \
+- MinOverlapPlacement.hh MinOverlapPlacement.cc \
+- RowSmartPlacement.hh RowSmartPlacement.cc ScreenPlacement.hh \
+- ScreenPlacement.cc UnderMousePlacement.hh \
+- UnderMousePlacement.cc AttentionNoticeHandler.hh \
+- AttentionNoticeHandler.cc IconButton.hh IconButton.cc \
+- IconbarTheme.hh IconbarTheme.cc Focusable.hh FocusableList.hh \
+- FocusableList.cc FocusableTheme.hh WindowMenuAccessor.hh \
+- RectangleUtil.hh Ewmh.hh Ewmh.cc Gnome.hh Gnome.cc Remember.hh \
+- Remember.cc ClientPattern.hh ClientPattern.cc Toolbar.hh \
+- Toolbar.cc ToolbarTheme.hh ToolbarTheme.cc ToolbarItem.hh \
+- ToolbarItem.cc ClockTool.hh ClockTool.cc WorkspaceNameTool.hh \
+- WorkspaceNameTool.cc WorkspaceNameTheme.hh IconbarTool.hh \
+- IconbarTool.cc ToolTheme.hh ToolTheme.cc SystemTray.hh \
+- SystemTray.cc GenericTool.hh GenericTool.cc ButtonTool.hh \
+- ButtonTool.cc ButtonTheme.hh ButtonTheme.cc ToolFactory.hh \
+- ToolFactory.cc
++ ClientPattern.hh ClientPattern.cc WorkspaceMenu.hh \
++ WorkspaceMenu.cc FocusModelMenuItem.hh ToggleMenu.hh \
++ HeadArea.hh HeadArea.cc Resources.cc WindowCmd.hh WindowCmd.cc \
++ FocusControl.hh FocusControl.cc PlacementStrategy.hh \
++ CascadePlacement.hh CascadePlacement.cc ColSmartPlacement.hh \
++ ColSmartPlacement.cc MinOverlapPlacement.hh \
++ MinOverlapPlacement.cc RowSmartPlacement.hh \
++ RowSmartPlacement.cc ScreenPlacement.hh ScreenPlacement.cc \
++ UnderMousePlacement.hh UnderMousePlacement.cc \
++ AttentionNoticeHandler.hh AttentionNoticeHandler.cc \
++ IconButton.hh IconButton.cc IconbarTheme.hh IconbarTheme.cc \
++ Focusable.hh FocusableList.hh FocusableList.cc \
++ FocusableTheme.hh WindowMenuAccessor.hh RectangleUtil.hh \
++ Ewmh.hh Ewmh.cc Gnome.hh Gnome.cc Remember.hh Remember.cc \
++ Toolbar.hh Toolbar.cc ToolbarTheme.hh ToolbarTheme.cc \
++ ToolbarItem.hh ToolbarItem.cc ClockTool.hh ClockTool.cc \
++ WorkspaceNameTool.hh WorkspaceNameTool.cc \
++ WorkspaceNameTheme.hh IconbarTool.hh IconbarTool.cc \
++ ToolTheme.hh ToolTheme.cc SystemTray.hh SystemTray.cc \
++ GenericTool.hh GenericTool.cc ButtonTool.hh ButtonTool.cc \
++ ButtonTheme.hh ButtonTheme.cc ToolFactory.hh ToolFactory.cc
+ @NEWWMSPEC_TRUE@am__objects_1 = Ewmh.$(OBJEXT)
+ @GNOME_TRUE@am__objects_2 = Gnome.$(OBJEXT)
+-@REMEMBER_SRC_TRUE@am__objects_3 = Remember.$(OBJEXT) \
+-@REMEMBER_SRC_TRUE@ ClientPattern.$(OBJEXT)
++@REMEMBER_SRC_TRUE@am__objects_3 = Remember.$(OBJEXT)
+ @TOOLBAR_SRC_TRUE@am__objects_4 = Toolbar.$(OBJEXT) \
+ @TOOLBAR_SRC_TRUE@ ToolbarTheme.$(OBJEXT) ToolbarItem.$(OBJEXT) \
+ @TOOLBAR_SRC_TRUE@ ClockTool.$(OBJEXT) \
+@@ -135,15 +134,15 @@
+ AlphaMenu.$(OBJEXT) FbMenuParser.$(OBJEXT) \
+ StyleMenuItem.$(OBJEXT) RootCmdMenuItem.$(OBJEXT) \
+ MenuCreator.$(OBJEXT) ClientMenu.$(OBJEXT) \
+- WorkspaceMenu.$(OBJEXT) HeadArea.$(OBJEXT) Resources.$(OBJEXT) \
+- WindowCmd.$(OBJEXT) FocusControl.$(OBJEXT) \
+- CascadePlacement.$(OBJEXT) ColSmartPlacement.$(OBJEXT) \
+- MinOverlapPlacement.$(OBJEXT) RowSmartPlacement.$(OBJEXT) \
+- ScreenPlacement.$(OBJEXT) UnderMousePlacement.$(OBJEXT) \
+- AttentionNoticeHandler.$(OBJEXT) IconButton.$(OBJEXT) \
+- IconbarTheme.$(OBJEXT) FocusableList.$(OBJEXT) \
+- $(am__objects_1) $(am__objects_2) $(am__objects_3) \
+- $(am__objects_4)
++ ClientPattern.$(OBJEXT) WorkspaceMenu.$(OBJEXT) \
++ HeadArea.$(OBJEXT) Resources.$(OBJEXT) WindowCmd.$(OBJEXT) \
++ FocusControl.$(OBJEXT) CascadePlacement.$(OBJEXT) \
++ ColSmartPlacement.$(OBJEXT) MinOverlapPlacement.$(OBJEXT) \
++ RowSmartPlacement.$(OBJEXT) ScreenPlacement.$(OBJEXT) \
++ UnderMousePlacement.$(OBJEXT) AttentionNoticeHandler.$(OBJEXT) \
++ IconButton.$(OBJEXT) IconbarTheme.$(OBJEXT) \
++ FocusableList.$(OBJEXT) $(am__objects_1) $(am__objects_2) \
++ $(am__objects_3) $(am__objects_4)
+ fluxbox_OBJECTS = $(am_fluxbox_OBJECTS)
+ fluxbox_LDADD = $(LDADD)
+ fluxbox_DEPENDENCIES = FbTk/libFbTk.a FbTk/LogicCommands.o \
+@@ -285,6 +284,7 @@
+ srcdir = @srcdir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
++top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = FbTk
+@@ -298,9 +298,7 @@
+ CONFIG_CLEAN_FILES = defaults.hh
+ @NEWWMSPEC_TRUE@newwmspec_SOURCE = Ewmh.hh Ewmh.cc
+ @GNOME_TRUE@gnome_SOURCE = Gnome.hh Gnome.cc
+-@REMEMBER_SRC_TRUE@REMEMBER_SOURCE = Remember.hh Remember.cc \
+-@REMEMBER_SRC_TRUE@ ClientPattern.hh ClientPattern.cc
+-
++@REMEMBER_SRC_TRUE@REMEMBER_SOURCE = Remember.hh Remember.cc
+ @TOOLBAR_SRC_TRUE@TOOLBAR_SOURCE = Toolbar.hh Toolbar.cc \
+ @TOOLBAR_SRC_TRUE@ ToolbarTheme.hh ToolbarTheme.cc ToolbarItem.hh ToolbarItem.cc \
+ @TOOLBAR_SRC_TRUE@ ClockTool.hh ClockTool.cc \
+@@ -344,6 +342,7 @@
+ RootCmdMenuItem.hh RootCmdMenuItem.cc\
+ MenuCreator.hh MenuCreator.cc \
+ ClientMenu.hh ClientMenu.cc \
++ ClientPattern.hh ClientPattern.cc \
+ WorkspaceMenu.hh WorkspaceMenu.cc \
+ FocusModelMenuItem.hh \
+ ToggleMenu.hh \
+--- src/Window.cc.orig 2009-03-25 00:05:17.000000000 +0100
++++ src/Window.cc 2009-03-25 00:05:42.000000000 +0100
+@@ -2189,9 +2189,11 @@
+ } else if (atom == fbatoms->getMWMHintsAtom()) {
+ client.updateMWMHints();
+ updateMWMHintsFromClient(client);
++#ifdef REMEMBER
+ if (!m_toggled_decos) {
+ Remember::instance().updateDecoStateFromClient(client);
+ }
++#endif
+ applyDecorations(); // update decorations (if they changed)
+ }
+ break;
diff --git a/x11-wm/fluxbox/files/patch-fix_pixmap_resource_leak b/x11-wm/fluxbox/files/patch-fix_pixmap_resource_leak
deleted file mode 100644
index 9ccef938b86e..000000000000
--- a/x11-wm/fluxbox/files/patch-fix_pixmap_resource_leak
+++ /dev/null
@@ -1,102 +0,0 @@
-From 91408776f0b04dbc5a5da99f555b33f9abc5a905 Mon Sep 17 00:00:00 2001
-From: Henrik Kinnunen <fluxgen@fluxbox.org>
-Date: Sun, 14 Sep 2008 21:36:16 +0200
-Subject: [PATCH] Fixed a pixmap resource leak with selected pixmap in menus.
-
-menu.hilite.selected.pixmap and menu.selected.pixmap was not
-deleted while switching between non-pixmap styles and pixmap styles.
----
- ChangeLog | 3 +++
- src/FbTk/ImageControl.cc | 9 ++++++++-
- src/FbTk/ImageControl.hh | 5 ++++-
- src/FbTk/Menu.cc | 18 +++++++++++++++---
- 4 files changed, 30 insertions(+), 5 deletions(-)
-
-diff --git a/ChangeLog b/ChangeLog
---- a/ChangeLog
-+++ ChangeLog
-@@ -1,5 +1,8 @@
- (Format: Year/Month/Day)
- Changes for 1.1
-+*08/09/14:
-+ * Fixed a minor pixmap resource leak (Henrik)
-+ FbTk/Menu.cc, FbTk/ImageControl.cc/hh
- *08/09/01:
- * When the current menu item gets disabled, highlight its nearest neighbor
- and add separators to the focus model menu (Mark)
-diff --git a/src/FbTk/ImageControl.cc b/src/FbTk/ImageControl.cc
---- a/src/FbTk/ImageControl.cc
-+++ src/FbTk/ImageControl.cc
-@@ -227,11 +227,18 @@ Pixmap ImageControl::searchCache(unsigned int width, unsigned int height,
-
- Pixmap ImageControl::renderImage(unsigned int width, unsigned int height,
- const FbTk::Texture &texture,
-- FbTk::Orientation orient) {
-+ FbTk::Orientation orient,
-+ bool use_cache ) {
-
- if (texture.type() & FbTk::Texture::PARENTRELATIVE)
- return ParentRelative;
-
-+ // If we are not suppose to cache this pixmap, just render and return it
-+ if ( ! use_cache) {
-+ TextureRender image(*this, width, height, orient, m_colors, m_num_colors);
-+ return image.render(texture);
-+ }
-+
- // search cache first
- Pixmap pixmap = searchCache(width, height, texture, orient);
- if (pixmap) {
-diff --git a/src/FbTk/ImageControl.hh b/src/FbTk/ImageControl.hh
---- a/src/FbTk/ImageControl.hh
-+++ src/FbTk/ImageControl.hh
-@@ -54,11 +54,14 @@ public:
- @param width width of pixmap
- @param height height of pixmap
- @param src_texture texture type to render
-+ @param orient Orientation of the texture.
-+ @param use_cache whether or not to use cache
- @return pixmap of the rendered image, on failure None
- */
- Pixmap renderImage(unsigned int width, unsigned int height,
- const FbTk::Texture &src_texture,
-- Orientation orient = ROT0);
-+ Orientation orient = ROT0,
-+ bool use_cache = true);
-
- void installRootColormap();
- void removeImage(Pixmap thepix);
-diff --git a/src/FbTk/Menu.cc b/src/FbTk/Menu.cc
---- a/src/FbTk/Menu.cc
-+++ src/FbTk/Menu.cc
-@@ -460,12 +460,24 @@ void Menu::updateMenu(int active_index) {
-
- if (!theme()->selectedPixmap().pixmap().drawable()) {
- int hw = theme()->itemHeight() / 2;
-- theme()->setSelectedPixmap(m_image_ctrl.renderImage(hw, hw, theme()->hiliteTexture()), true);
-+ // render image, disable cache and let the theme remove the pixmap
-+ theme()->setSelectedPixmap(m_image_ctrl.
-+ renderImage(hw, hw,
-+ theme()->hiliteTexture(), ROT0,
-+ false // no cache
-+ ),
-+ false); // the theme takes care of this pixmap
-
- if (!theme()->highlightSelectedPixmap().pixmap().drawable()) {
- int hw = theme()->itemHeight() / 2;
-- theme()->setHighlightSelectedPixmap(m_image_ctrl.renderImage(hw, hw, theme()->frameTexture()), true);
-- }
-+ // render image, disable cache and let the theme remove the pixmap
-+ theme()->setHighlightSelectedPixmap(m_image_ctrl.
-+ renderImage(hw, hw,
-+ theme()->frameTexture(), ROT0,
-+ false // no cache
-+ ),
-+ false); // theme takes care of this pixmap
-+ }
- }
-
- if (m_title_vis) {
---
-1.6.0.1
-
diff --git a/x11-wm/fluxbox/files/patch-fix_unshading_crash b/x11-wm/fluxbox/files/patch-fix_unshading_crash
deleted file mode 100644
index 3a4d5ee442c3..000000000000
--- a/x11-wm/fluxbox/files/patch-fix_unshading_crash
+++ /dev/null
@@ -1,25 +0,0 @@
-From bf620f96df0942db356255f8af7f522ae46af82e Mon Sep 17 00:00:00 2001
-From: Mark Tiefenbruck <mark@fluxbox.org>
-Date: Thu, 11 Sep 2008 13:01:11 -0700
-Subject: [PATCH] fix program crashes caused by unshading
-
----
- src/FbWinFrame.cc | 3 ++-
- 1 files changed, 2 insertions(+), 1 deletions(-)
-
-diff --git a/src/FbWinFrame.cc b/src/FbWinFrame.cc
---- a/src/FbWinFrame.cc
-+++ src/FbWinFrame.cc
-@@ -1489,7 +1489,8 @@ void FbWinFrame::applyDecorations(bool do_move) {
- client_move = true;
- }
-
-- reconfigure();
-+ if (do_move)
-+ reconfigure();
- if (client_move)
- frameExtentSig().notify();
- }
---
-1.6.0.1
-