aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fluxbox
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-12 21:57:59 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-12 21:57:59 +0000
commit03dade55878c9d452eb485ee63ce89001d739829 (patch)
treebd97814eef4f3e37c302a04a82157bcf2f8b51dd /x11-wm/fluxbox
parent9929ffb6707e03927b36f0db8371793c1cf5ab72 (diff)
downloadports-03dade55878c9d452eb485ee63ce89001d739829.tar.gz
ports-03dade55878c9d452eb485ee63ce89001d739829.zip
Notes
Diffstat (limited to 'x11-wm/fluxbox')
-rw-r--r--x11-wm/fluxbox/Makefile1
-rw-r--r--x11-wm/fluxbox/files/patch-src::Screen.cc13
2 files changed, 14 insertions, 0 deletions
diff --git a/x11-wm/fluxbox/Makefile b/x11-wm/fluxbox/Makefile
index 1d63a3af66c2..b7c24880fdb4 100644
--- a/x11-wm/fluxbox/Makefile
+++ b/x11-wm/fluxbox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fluxbox
PORTVERSION= 0.1.7
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/x11-wm/fluxbox/files/patch-src::Screen.cc b/x11-wm/fluxbox/files/patch-src::Screen.cc
new file mode 100644
index 000000000000..7aca6efd1f86
--- /dev/null
+++ b/x11-wm/fluxbox/files/patch-src::Screen.cc
@@ -0,0 +1,13 @@
+--- src/Screen.cc.orig Thu Feb 28 10:46:01 2002
++++ src/Screen.cc Tue Mar 12 16:48:03 2002
+@@ -877,8 +877,9 @@
+ Netizens::iterator it_end = netizenList.end();
+ for (; it != it_end; ++it) {
+ if ((*it)->getWindowID() == w) {
+- Netizen *n = *netizenList.erase(it);
++ Netizen *n = *it;
+ delete n;
++ netizenList.erase(it);
+ break;
+ }
+ }