aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/flwm
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-04-16 06:21:02 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-04-16 06:21:02 +0000
commit2e7d0bd39f7aaf9fb956f44902bcc53c1a9ed99d (patch)
tree5754ab2de82bb489e903b3ed32731b9a13d33ce9 /x11-wm/flwm
parent2cc9fa0c9ffca4aca3b0254b9bbb020de3df5cb9 (diff)
downloadports-2e7d0bd39f7aaf9fb956f44902bcc53c1a9ed99d.tar.gz
ports-2e7d0bd39f7aaf9fb956f44902bcc53c1a9ed99d.zip
Notes
Diffstat (limited to 'x11-wm/flwm')
-rw-r--r--x11-wm/flwm/Makefile8
-rw-r--r--x11-wm/flwm/distinfo2
-rw-r--r--x11-wm/flwm/files/patch-aa11
-rw-r--r--x11-wm/flwm/files/patch-ab26
4 files changed, 42 insertions, 5 deletions
diff --git a/x11-wm/flwm/Makefile b/x11-wm/flwm/Makefile
index ac76704b8c55..9af7c5aff89c 100644
--- a/x11-wm/flwm/Makefile
+++ b/x11-wm/flwm/Makefile
@@ -1,16 +1,15 @@
# New ports collection makefile for: flwm
-# Version required: 0.19
+# Version required: 0.22
# Date created: 12 February 1999
# Whom: Dima Sivachenko <dima@chg.ru>
#
-# $Id: Makefile,v 1.1.1.1 1999/03/15 01:14:36 billf Exp $
+# $Id: Makefile,v 1.2 1999/03/17 05:09:02 nectar Exp $
#
-DISTNAME= flwm-0.19
+DISTNAME= flwm-0.22
CATEGORIES= x11-wm
MASTER_SITES= http://www.cinenet.net/users/spitzak/flwm/ \
ftp://ftp.sai.msu.su/pub/X11/win_man/
-# ftp://ftp.gpad.ac.ru/pub/FreeBSD/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= dima@chg.ru
@@ -19,6 +18,7 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CXXFLAGS="${CFLAGS}"
MAN1= flwm.1
.include <bsd.port.mk>
diff --git a/x11-wm/flwm/distinfo b/x11-wm/flwm/distinfo
index 33151a60430e..791fb96d5106 100644
--- a/x11-wm/flwm/distinfo
+++ b/x11-wm/flwm/distinfo
@@ -1 +1 @@
-MD5 (flwm-0.19.tgz) = 7d8f7abaa1e135e25df6358dedcd7394
+MD5 (flwm-0.22.tgz) = b1cf229d6e7b8907b153a04e47a14c0d
diff --git a/x11-wm/flwm/files/patch-aa b/x11-wm/flwm/files/patch-aa
new file mode 100644
index 000000000000..de2fb4c18e02
--- /dev/null
+++ b/x11-wm/flwm/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.orig Wed Apr 14 18:50:44 1999
++++ Makefile Wed Apr 14 18:50:51 1999
+@@ -5,7 +5,7 @@
+
+ CXXFILES = main.C Frame.C Rotated.C Menu.C FrameWindow.C Desktop.C Hotkeys.C
+
+-LIBS = -lfltk
++LIBS = -lfltk -lGL
+
+ MANPAGE = 1
+
diff --git a/x11-wm/flwm/files/patch-ab b/x11-wm/flwm/files/patch-ab
new file mode 100644
index 000000000000..c37220f87a24
--- /dev/null
+++ b/x11-wm/flwm/files/patch-ab
@@ -0,0 +1,26 @@
+--- configure.orig Wed Apr 14 18:54:10 1999
++++ configure Wed Apr 14 18:56:19 1999
+@@ -813,9 +813,9 @@
+ if test "$ac_test_CXXFLAGS" = set; then
+ CXXFLAGS="$ac_save_CXXFLAGS"
+ elif test $ac_cv_prog_cxx_g = yes; then
+- CXXFLAGS="-g -O2"
++ CXXFLAGS="$CXXFLAGS"
+ else
+- CXXFLAGS="-O2"
++ CXXFLAGS="$CXXFLAGS"
+ fi
+ else
+ GXX=
+@@ -1805,9 +1805,9 @@
+ if test -n "$GXX"; then
+ # GNU C compiler
+ # -Wno-return-type is necessary for Xlib header files on many systems:
+- CFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS"
++ CFLAGS="-Wall -Wno-return-type $CFLAGS $X_CFLAGS"
+ CFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
+- CXXFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS"
++ CXXFLAGS="-Wall -Wno-return-type $CXXFLAGS $X_CFLAGS"
+ CXXFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
+ else
+ if test "`(uname) 2>/dev/null`" = IRIX; then