aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fvwm2-devel
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2005-11-09 16:50:18 +0000
committerCy Schubert <cy@FreeBSD.org>2005-11-09 16:50:18 +0000
commita8c128492afbdcbb1675592d0646945576060e07 (patch)
treee402705df13ce14891016db37dce83806574b4d2 /x11-wm/fvwm2-devel
parent3d3ddd94ad86e1abcbc8df669ec97ba1421c8fc2 (diff)
downloadports-a8c128492afbdcbb1675592d0646945576060e07.tar.gz
ports-a8c128492afbdcbb1675592d0646945576060e07.zip
Notes
Diffstat (limited to 'x11-wm/fvwm2-devel')
-rw-r--r--x11-wm/fvwm2-devel/Makefile6
-rw-r--r--x11-wm/fvwm2-devel/files/patch-modules-FvwmProxy-FvwmProxy.c20
2 files changed, 21 insertions, 5 deletions
diff --git a/x11-wm/fvwm2-devel/Makefile b/x11-wm/fvwm2-devel/Makefile
index 589c9024e895..a3cf2c3674b0 100644
--- a/x11-wm/fvwm2-devel/Makefile
+++ b/x11-wm/fvwm2-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fvwm
PORTVERSION= 2.5.14
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.fvwm.org/pub/fvwm/version-2/ \
http://www.fvwm.org/generated/icon_download/
@@ -46,10 +46,6 @@ OPTIONS= ICONS "Install default icon set" on \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 501000
-BROKEN= Does not build
-.endif
-
.if !defined(WITHOUT_ICONS)
DISTFILES+= fvwm_icons.tgz
.endif
diff --git a/x11-wm/fvwm2-devel/files/patch-modules-FvwmProxy-FvwmProxy.c b/x11-wm/fvwm2-devel/files/patch-modules-FvwmProxy-FvwmProxy.c
new file mode 100644
index 000000000000..d206f800bc9e
--- /dev/null
+++ b/x11-wm/fvwm2-devel/files/patch-modules-FvwmProxy-FvwmProxy.c
@@ -0,0 +1,20 @@
+--- modules/FvwmProxy/FvwmProxy.c.orig Fri Aug 12 08:25:45 2005
++++ modules/FvwmProxy/FvwmProxy.c Wed Nov 9 07:29:08 2005
+@@ -719,14 +719,15 @@
+ {
+ Bool rc = False;
+ ProxyWindow *other=proxy->next;
++ int dx, dy;
+
+ for (other=proxy->next; other; other=other->next)
+ {
+ if(other->desk != deskNumber)
+ continue;
+
+- int dx=abs(proxy->proxyx-other->proxyx);
+- int dy=abs(proxy->proxyy-other->proxyy);
++ dx=abs(proxy->proxyx-other->proxyx);
++ dy=abs(proxy->proxyy-other->proxyy);
+ if (dx<(proxyWidth+proxySeparation) &&
+ dy<proxyHeight+proxySeparation )
+ {