aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/genmenu/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-10 03:17:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-10 03:17:13 +0000
commitf6ff7bd3ad3b364385c483476d1c0e4a9bea234b (patch)
treed63981c6db4f426f73047cce709fb17f3f1b26c7 /x11-wm/genmenu/Makefile
parentb66ffccfd7bee0ca9c9eb192ec61c212da61bb1c (diff)
downloadports-f6ff7bd3ad3b364385c483476d1c0e4a9bea234b.tar.gz
ports-f6ff7bd3ad3b364385c483476d1c0e4a9bea234b.zip
Notes
Diffstat (limited to 'x11-wm/genmenu/Makefile')
-rw-r--r--x11-wm/genmenu/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-wm/genmenu/Makefile b/x11-wm/genmenu/Makefile
new file mode 100644
index 000000000000..a5d7a4fca60a
--- /dev/null
+++ b/x11-wm/genmenu/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: genmenu
+# Date created: Nov 10, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= genmenu
+PORTVERSION= 1.0.4
+CATEGORIES= x11-wm
+MASTER_SITES= http://projects.gtk.mine.nu/archive/genmenu/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Generating menus for Bbox, Fbox, Obox, WM and E
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^#!/bin/bash|#!${LOCALBASE}/bin/bash|" ${WRKSRC}/genmenu
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/genmenu ${PREFIX}/bin
+
+.include <bsd.port.mk>