aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hackedbox
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-05-10 21:06:41 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-05-10 21:06:41 +0000
commitfa5a13fab2b2ed3690ac19ddce611f8b2983953e (patch)
tree1588f5ca5dccfbb1515a8adb55ba974badfbcdef /x11-wm/hackedbox
parentbefea0889a41ef6a764051f0cff650ea8e6b3b52 (diff)
downloadports-fa5a13fab2b2ed3690ac19ddce611f8b2983953e.tar.gz
ports-fa5a13fab2b2ed3690ac19ddce611f8b2983953e.zip
Notes
Diffstat (limited to 'x11-wm/hackedbox')
-rw-r--r--x11-wm/hackedbox/Makefile86
-rw-r--r--x11-wm/hackedbox/distinfo3
-rw-r--r--x11-wm/hackedbox/files/patch-util::bsetbg11
-rw-r--r--x11-wm/hackedbox/pkg-comment2
-rw-r--r--x11-wm/hackedbox/pkg-descr9
-rw-r--r--x11-wm/hackedbox/pkg-plist69
6 files changed, 81 insertions, 99 deletions
diff --git a/x11-wm/hackedbox/Makefile b/x11-wm/hackedbox/Makefile
index e6001baa96c3..93e70105db60 100644
--- a/x11-wm/hackedbox/Makefile
+++ b/x11-wm/hackedbox/Makefile
@@ -1,25 +1,87 @@
-# New ports collection makefile for: Blackbox
-# Date created: June 15, 1998
-# Whom: Brian Handy <handy@physics.montana.edu>
+# New ports collection makefile for: openbox
+# Date created: 2002-04-28
+# Whom: trevor
+# based on the blackbox port
#
# $FreeBSD$
#
-PORTNAME= blackbox
-PORTVERSION= 0.62.1
+PORTNAME= openbox
+PORTVERSION= 1.0.1
CATEGORIES= x11-wm
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= blackboxwm
+MASTER_SITES= ftp://sunsite.dk/projects/openbox/
-MAINTAINER= stijn@win.tue.nl
+MAINTAINER= trevor@FreeBSD.org
-MAN1= blackbox.1 bsetroot.1
+MAN1= openbox.1 osetroot.1 osetbg.1
+DOCS= AUTHORS BUGS CHANGELOG CHANGELOG.Blackbox CHANGELOG.bsetbg \
+ CodingStyle INSTALL LICENSE README README.bbtools \
+ README.bsetbg TODO
+I10L= C da_DK de_DE es_ES et_EE fr_FR it_IT ja_JP nl_NL pt_BR ru_RU \
+ sl_SI sv_SE tr_TR zh_CN
+STYLES= artwiz bluebox cthulhain deep flux frobozz frobust nyz \
+ nyzclone operation outcomes shade steelblue steelblue2 \
+ the_orange trisb twice
+PLIST= ${WRKDIR}/pkg-plist
+USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-pre-patch:
- @${PERL} -ni.orig -e '/^SUBDIRS/ || print' \
- ${WRKSRC}/doc/Makefile.in
+do-patch:
+ ${PERL} -pi -e "s:bsetbg:osetbg:g; s:bsetroot:osetroot:g" \
+ ${WRKSRC}/data/styles/* ${WRKSRC}/doc/*.1
+
+pre-install:
+ ${RM} -f ${PLIST}
+.for ii in osetbg osetroot openbox
+ ${ECHO_CMD} bin/${ii} >> ${PLIST}
+.endfor
+ ${ECHO_CMD} share/openbox/menu >> ${PLIST}
+.for ii in ${I10L}
+ ${ECHO_CMD} share/openbox/nls/${ii}/openbox.cat >> ${PLIST}
+ ${ECHO_CMD} @dirrm share/openbox/nls/${ii} >> ${PLIST}
+.endfor
+.for ii in ${STYLES}
+ ${ECHO_CMD} share/openbox/styles/${ii} >> ${PLIST}
+.endfor
+.for ii in /styles /nls /
+ ${ECHO_CMD} @dirrm share/openbox${ii} >> ${PLIST}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for ii in ${DOCS}
+ ${ECHO_CMD} share/doc/openbox/${ii} >> ${PLIST}
+.endfor
+ ${ECHO_CMD} @dirrm share/doc/openbox >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/util/bsetbg ${PREFIX}/bin/osetbg
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/bsetroot ${PREFIX}/bin/osetroot
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/openbox ${PREFIX}/bin/
+ ${MKDIR} ${DATADIR}/styles
+ ${INSTALL_DATA} ${WRKSRC}/data/menu ${DATADIR}
+.for ii in ${I10L}
+ ${MKDIR} ${PREFIX}/share/openbox/nls/${ii}/
+ ${INSTALL_DATA} ${WRKSRC}/nls/${ii}/openbox.cat \
+ ${PREFIX}/share/openbox/nls/${ii}/
+.endfor
+.for ii in ${STYLES}
+ ${INSTALL_DATA} ${WRKSRC}/data/styles/${ii} \
+ ${PREFIX}/share/openbox/styles/
+.endfor
+.for ii in setroot setbg
+ ${CP} -p ${WRKSRC}/doc/b${ii}.1 ${WRKSRC}/doc/o${ii}.1
+.endfor
+.for ii in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${ii} ${PREFIX}/man/man1/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for ii in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/x11-wm/hackedbox/distinfo b/x11-wm/hackedbox/distinfo
index 24471404a58a..196102b82808 100644
--- a/x11-wm/hackedbox/distinfo
+++ b/x11-wm/hackedbox/distinfo
@@ -1 +1,2 @@
-MD5 (blackbox-0.62.1.tar.gz) = a188b0bb144eb239bac98e781f1611d9
+$FreeBSD$
+MD5 (openbox-1.0.1.tar.gz) = a21027beaa7b1402e25d675f7e16d151
diff --git a/x11-wm/hackedbox/files/patch-util::bsetbg b/x11-wm/hackedbox/files/patch-util::bsetbg
deleted file mode 100644
index a7183a26b232..000000000000
--- a/x11-wm/hackedbox/files/patch-util::bsetbg
+++ /dev/null
@@ -1,11 +0,0 @@
---- util/bsetbg.orig Mon Jan 28 16:53:53 2002
-+++ util/bsetbg Mon Jan 28 16:54:10 2002
-@@ -602,7 +602,7 @@
- VERSION=1.12
- MORE="(C) 2000 by lordzork industries (http://lordzork.com/)"
- PATH=$PATH:/usr/bin:/usr/local/bin:/usr/X11R6/bin:/usr/X11/bin
--TMPFILE=`tempfile --prefix=bsetbg`
-+TMPFILE=`mktemp -t bsetbg`
- ARGUMENT=$1
-
-
diff --git a/x11-wm/hackedbox/pkg-comment b/x11-wm/hackedbox/pkg-comment
index f19dc0187f91..82785e082e82 100644
--- a/x11-wm/hackedbox/pkg-comment
+++ b/x11-wm/hackedbox/pkg-comment
@@ -1 +1 @@
-A small and fast window manager for X11R6
+Derived from, and similar to, Blackbox
diff --git a/x11-wm/hackedbox/pkg-descr b/x11-wm/hackedbox/pkg-descr
index ebde7e80156f..9913c8ae854b 100644
--- a/x11-wm/hackedbox/pkg-descr
+++ b/x11-wm/hackedbox/pkg-descr
@@ -1,6 +1,5 @@
-Blackbox is Yet Another Window Manager for X11R6 that arose primarily
-out of the curiosity of the authors. It's small, fast, has built-in
-rendering code, does image dithering at 8, 15 and 16 bits per pixel
-and colour icon support. Blackbox is [mostly] ICCCM compliant.
+Openbox is based on, and similar to, blackbox. In this port/package,
+bsetbg and bsetroot are renamed to osetbg and osetroot in order to
+avoid conflict with blackbox.
-WWW: http://blackbox.alug.org/
+WWW: http://openbox.sunsite.dk/
diff --git a/x11-wm/hackedbox/pkg-plist b/x11-wm/hackedbox/pkg-plist
deleted file mode 100644
index 44d310271383..000000000000
--- a/x11-wm/hackedbox/pkg-plist
+++ /dev/null
@@ -1,69 +0,0 @@
-bin/blackbox
-bin/bsetroot
-bin/bsetbg
-share/blackbox/menu
-share/blackbox/nls/C/blackbox.cat
-share/blackbox/nls/da_DK/blackbox.cat
-share/blackbox/nls/de_DE/blackbox.cat
-share/blackbox/nls/es_ES/blackbox.cat
-share/blackbox/nls/et_EE/blackbox.cat
-share/blackbox/nls/fr_FR/blackbox.cat
-share/blackbox/nls/it_IT/blackbox.cat
-share/blackbox/nls/ja_JP/blackbox.cat
-share/blackbox/nls/nl_NL/blackbox.cat
-share/blackbox/nls/pt_BR/blackbox.cat
-share/blackbox/nls/ru_RU/blackbox.cat
-share/blackbox/nls/sl_SI/blackbox.cat
-share/blackbox/nls/sv_SE/blackbox.cat
-share/blackbox/nls/tr_TR/blackbox.cat
-share/blackbox/nls/zh_CN/blackbox.cat
-share/blackbox/styles/Artwiz
-share/blackbox/styles/Cthulhain
-share/blackbox/styles/Flux
-share/blackbox/styles/Minimal
-share/blackbox/styles/Nyz
-share/blackbox/styles/Operation
-share/blackbox/styles/Outcomes
-share/blackbox/styles/Rampage
-share/blackbox/styles/Rancor
-share/blackbox/styles/Results
-share/blackbox/styles/Shade
-share/blackbox/styles/Spiff
-share/blackbox/styles/TDF
-share/blackbox/styles/Twice
-@dirrm share/blackbox/nls/C
-@dirrm share/blackbox/nls/da_DK
-@dirrm share/blackbox/nls/de_DE
-@dirrm share/blackbox/nls/es_ES
-@dirrm share/blackbox/nls/et_EE
-@dirrm share/blackbox/nls/fr_FR
-@dirrm share/blackbox/nls/it_IT
-@dirrm share/blackbox/nls/ja_JP
-@dirrm share/blackbox/nls/nl_NL
-@dirrm share/blackbox/nls/pt_BR
-@dirrm share/blackbox/nls/ru_RU
-@dirrm share/blackbox/nls/sl_SI
-@dirrm share/blackbox/nls/sv_SE
-@dirrm share/blackbox/nls/tr_TR
-@dirrm share/blackbox/nls/zh_CN
-@exec ln -s C %D/share/blackbox/nls/POSIX
-@unexec rm %D/share/blackbox/nls/POSIX
-@exec ln -s C %D/share/blackbox/nls/US_ASCII
-@unexec rm %D/share/blackbox/nls/US_ASCII
-@exec ln -s de_DE %D/share/blackbox/nls/de
-@unexec rm %D/share/blackbox/nls/de
-@exec ln -s C %D/share/blackbox/nls/en
-@unexec rm %D/share/blackbox/nls/en
-@exec ln -s C %D/share/blackbox/nls/en_US
-@unexec rm %D/share/blackbox/nls/en_US
-@exec ln -s es_ES %D/share/blackbox/nls/es
-@unexec rm %D/share/blackbox/nls/es
-@exec ln -s fr_FR %D/share/blackbox/nls/fr
-@unexec rm %D/share/blackbox/nls/fr
-@exec ln -s it_IT %D/share/blackbox/nls/it
-@unexec rm %D/share/blackbox/nls/it
-@exec ln -s nl_NL %D/share/blackbox/nls/nl
-@unexec rm %D/share/blackbox/nls/nl
-@dirrm share/blackbox/nls
-@dirrm share/blackbox/styles
-@dirrm share/blackbox