aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hs-xmonad-contrib/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-01-13 14:11:34 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-01-13 14:11:34 +0000
commitf4fb3d948c3d4f3a706df484978d3e41329732d2 (patch)
treef43465d95d5d024efdad6cabf749b636f8680e03 /x11-wm/hs-xmonad-contrib/Makefile
parent325edc71a6ebdff4998d779ad3c261cddbe6eb1b (diff)
Notes
Diffstat (limited to 'x11-wm/hs-xmonad-contrib/Makefile')
-rw-r--r--x11-wm/hs-xmonad-contrib/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/x11-wm/hs-xmonad-contrib/Makefile b/x11-wm/hs-xmonad-contrib/Makefile
index 53c6191ff1e6..77a42c6c9f50 100644
--- a/x11-wm/hs-xmonad-contrib/Makefile
+++ b/x11-wm/hs-xmonad-contrib/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmonad-contrib
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= x11-wm haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/xmonad-contrib/${PORTVERSION}/
@@ -15,17 +14,19 @@ MAINTAINER= matt.guegan@free.fr
COMMENT= Third party tiling algorithms, configurations and scripts to xmonad
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
- xmonad:${PORTSDIR}/x11-wm/xmonad
+ xmonad:${PORTSDIR}/x11-wm/xmonad \
+ hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
- xmonad:${PORTSDIR}/x11-wm/xmonad
+ xmonad:${PORTSDIR}/x11-wm/xmonad \
+ hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
USE_XORG= x11
GHC_VERSION= 6.10.4
XMONADC_VERSION= ${PORTVERSION}
-UTF8STR_VERSION= 0.3.5
-HSX11XFT_VERSION= 0.3
+UTF8STR_VERSION= 0.3.6
+HSX11XFT_VERSION= 0.7
GHC_CMD= ${LOCALBASE}/bin/ghc
SETUP_CMD= ./setup
@@ -38,8 +39,7 @@ PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
XMONADC_LIBDIR_REL=${XMONADC_LIBDIR_REL}
# See (1)
-OPTIONS= XFT "Enable Xft support for fonts" On \
- UTF8 "Enable UTF-8 support" Off
+OPTIONS= XFT "Enable Xft support for fonts" On
.include <bsd.port.pre.mk>
@@ -48,17 +48,12 @@ CONFIGURE_ARGS= --haddock-options=-w --prefix=${PREFIX}
# (1)
.if exists(${LOCALBASE}/lib/X11-xft-${HSX11XFT_VERSION}/register.sh)
WITH_XFT=
-.elif exists(${LOCALBASE}/lib/utf8-string-${UTF8STR_VERSION}/register.sh)
-WITH_UTF8=
.endif
.if defined(WITH_XFT)
-CONFIGURE_ARGS+= --flags="with_xft"
-BUILD_DEPENDS+= hs-x11-xft-ghc>=0.2:${PORTSDIR}/x11/hs-x11-xft-ghc \
- hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
-.elif defined(WITH_UTF8)
-CONFIGURE_ARGS+= --flags="with_utf8"
-BUILD_DEPENDS+= hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+CONFIGURE_ARGS+= --flags="use_xft"
+BUILD_DEPENDS+= hs-x11-xft-ghc>=0.2:${PORTSDIR}/x11/hs-x11-xft-ghc
+RUN_DEPENDS+= hs-x11-xft-ghc>=0.2:${PORTSDIR}/x11/hs-x11-xft-ghc
.endif
.if defined(NOPORTDOCS)