aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hs-xmonad-contrib
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-07-10 07:29:13 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-07-10 07:29:13 +0000
commit93c5c5fe4c64dcc4afc1940abf02144aa0fd16c7 (patch)
treec6cfda2aa63b3f256cfb0687e1bc1e0e63e78744 /x11-wm/hs-xmonad-contrib
parent1f896eeb29bb67303a5e0afdf21b5b91184a697a (diff)
downloadports-93c5c5fe4c64dcc4afc1940abf02144aa0fd16c7.tar.gz
ports-93c5c5fe4c64dcc4afc1940abf02144aa0fd16c7.zip
Notes
Diffstat (limited to 'x11-wm/hs-xmonad-contrib')
-rw-r--r--x11-wm/hs-xmonad-contrib/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/x11-wm/hs-xmonad-contrib/Makefile b/x11-wm/hs-xmonad-contrib/Makefile
index fd6354aa18aa..74840f0ff9e2 100644
--- a/x11-wm/hs-xmonad-contrib/Makefile
+++ b/x11-wm/hs-xmonad-contrib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmonad-contrib
PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/xmonad-contrib/${PORTVERSION}/
@@ -31,6 +31,22 @@ PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
PORTVERSION=${PORTVERSION} \
SUBDIR=${SUBDIR}
+OPTIONS= XFT "Enable Xft support for fonts" Off \
+ UTF8 "Enable UTF-8 support" Off
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX}
+
+.if defined(WITH_XFT)
+CONFIGURE_ARGS+= --flags="with_xft"
+BUILD_DEPENDS+= hs-x11-xft-ghc>=0.2:${PORTSDIR}/x11/hs-x11-xft-ghc \
+ hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+.elif defined(WITH_UTF8)
+CONFIGURE_ARGS+= --flags="with_utf8"
+BUILD_DEPENDS+= hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+.endif
+
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
.else
@@ -39,7 +55,7 @@ PLIST_FILES+= %%DOCSDIR%%/LICENSE
.endif
do-configure:
- cd ${WRKSRC} && ${CABALCMD} configure --ghc --prefix=${PREFIX}
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
do-build:
cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} register --gen-script
@@ -51,4 +67,4 @@ do-install:
cd ${WRKSRC} && ${CABALCMD} install
${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>