aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hs-xmonad-contrib
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-09-07 19:24:01 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-09-07 19:24:01 +0000
commit1231d464c5a557551425b977bf16e3616ed0a434 (patch)
tree91c7e1d77657fc8d35fc47e88f2d235e01f9009d /x11-wm/hs-xmonad-contrib
parent1ab653e10166ef67954f005aa268b16841890893 (diff)
downloadports-1231d464c5a557551425b977bf16e3616ed0a434.tar.gz
ports-1231d464c5a557551425b977bf16e3616ed0a434.zip
Notes
Diffstat (limited to 'x11-wm/hs-xmonad-contrib')
-rw-r--r--x11-wm/hs-xmonad-contrib/Makefile4
-rw-r--r--x11-wm/hs-xmonad-contrib/files/patch-XMonad__Prompt__Directory.hs11
2 files changed, 14 insertions, 1 deletions
diff --git a/x11-wm/hs-xmonad-contrib/Makefile b/x11-wm/hs-xmonad-contrib/Makefile
index 657e3ba44283..dd33b0af77c1 100644
--- a/x11-wm/hs-xmonad-contrib/Makefile
+++ b/x11-wm/hs-xmonad-contrib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmonad-contrib
PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm haskell
MAINTAINER= haskell@FreeBSD.org
@@ -18,6 +18,8 @@ LICENSE= BSD
USE_CABAL= mtl xmonad>=0.9.1 X11>=1.5 utf8-string
USE_XORG= x11
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
+
OPTIONS= XFT "Enable Xft support for fonts" On
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
diff --git a/x11-wm/hs-xmonad-contrib/files/patch-XMonad__Prompt__Directory.hs b/x11-wm/hs-xmonad-contrib/files/patch-XMonad__Prompt__Directory.hs
new file mode 100644
index 000000000000..5a4e24560dba
--- /dev/null
+++ b/x11-wm/hs-xmonad-contrib/files/patch-XMonad__Prompt__Directory.hs
@@ -0,0 +1,11 @@
+--- ./XMonad/Prompt/Directory.hs.orig 2011-08-21 14:07:27.601179305 +0300
++++ ./XMonad/Prompt/Directory.hs 2011-08-21 14:08:20.213520774 +0300
+@@ -35,7 +35,7 @@
+
+ getDirCompl :: String -> IO [String]
+ getDirCompl s = (filter notboring . lines) `fmap`
+- runProcessWithInput "/bin/bash" [] ("compgen -A directory " ++ s ++ "\n")
++ runProcessWithInput "bash" [] ("compgen -A directory " ++ s ++ "\n")
+
+ notboring :: String -> Bool
+ notboring ('.':'.':_) = True