aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2012-05-26 15:25:31 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2012-05-26 15:25:31 +0000
commit71fa5214d09f09f54bfbd9405f0935a6e2ebdc02 (patch)
tree499c86512998d7ef5be5692f06e6196369f06396 /x11-wm/i3
parent64a5a7d035d20b12f57887d295d547f0dd9a6982 (diff)
downloadports-71fa5214d09f09f54bfbd9405f0935a6e2ebdc02.tar.gz
ports-71fa5214d09f09f54bfbd9405f0935a6e2ebdc02.zip
Notes
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/Makefile26
-rw-r--r--x11-wm/i3/distinfo4
-rw-r--r--x11-wm/i3/files/patch-i3-config-wizard__main.c25
-rw-r--r--x11-wm/i3/files/patch-src__cfgparse.y8
-rw-r--r--x11-wm/i3/files/patch-src__cmdparse.y11
5 files changed, 24 insertions, 50 deletions
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index bff93021b1ba..01741f4b6743 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= i3
-DISTVERSION= 4.1.2
+DISTVERSION= 4.2
CATEGORIES= x11-wm
MASTER_SITES= http://i3wm.org/downloads/ \
${MASTER_SITE_LOCAL}
@@ -24,8 +24,11 @@ LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
xcb-icccm.4:${PORTSDIR}/x11/xcb-util-wm \
ev.4:${PORTSDIR}/devel/libev \
yajl.2:${PORTSDIR}/devel/yajl
-RUN_DEPENDS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+RUN_DEPENDS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-AnyEvent-I3>=0:${PORTSDIR}/devel/p5-AnyEvent-I3
+USE_PERL5= yes
USE_XORG= x11 xcursor
USE_BISON= build
USE_BZIP2= yes
@@ -45,24 +48,30 @@ PLIST_FILES= bin/i3 \
bin/i3-sensible-terminal \
bin/i3-wsbar \
etc/i3/config.sample \
+ etc/i3/config.keycodes \
etc/i3/welcome
PLIST_DIRS= etc/i3
-MANUALS= i3-config-wizard.1 i3-input.1 i3-migrate-config-to-v4.1 i3-msg.1 i3-nagbar.1 i3-wsbar.1 i3.1
+MANUALS= i3-config-wizard.1 i3-input.1 \
+ i3-migrate-config-to-v4.1 i3-msg.1 \
+ i3-nagbar.1 i3-wsbar.1 \
+ i3.1 i3-sensible-terminal.1
MAN1= ${MANUALS}
.include <bsd.port.pre.mk>
post-extract:
- @cd ${WRKSRC} && ${CP} i3.config config.sample
@cd ${WRKSRC} && ${CP} i3.welcome welcome
+ @cd ${WRKSRC} && ${CP} i3.config config.sample
+ @cd ${WRKSRC} && ${CP} i3.config.keycodes config.keycodes
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/src/config.c
- @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/config.sample
@${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/welcome
+ @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/config.sample
+ @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/config.keycodes
@${REINPLACE_CMD} -e 's|PREFIX|${PREFIX}/|g' ${WRKSRC}/man/Makefile
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/common.mk
@${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/man/i3.1
@@ -81,16 +90,17 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/$i ${PREFIX}/bin/
.endfor
@${MKDIR} ${PREFIX}/etc/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/config.sample ${PREFIX}/etc/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/welcome ${PREFIX}/etc/${PORTNAME}/welcome
+ ${INSTALL_DATA} ${WRKSRC}/config.sample ${PREFIX}/etc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/config.keycodes ${PREFIX}/etc/${PORTNAME}
.for i in ${MANUALS}
${INSTALL_MAN} ${WRKSRC}/man/${i} ${MANPREFIX}/man/man1/
.endfor
@${ECHO_MSG} "======================================================================================"
@${ECHO_MSG} ""
- @${ECHO_MSG} " ${PORTNAME} need a config file! A example do you found on ${PREFIX}/etc/${PORTNAME}"
- @${ECHO_MSG} " Please rename it in ${PREFIX}/etc/${PORTNAME}/config"
+ @${ECHO_MSG} " ${PORTNAME} needs a config file! You can find an example in ${PREFIX}/etc/${PORTNAME}"
+ @${ECHO_MSG} " Please rename it to ${PREFIX}/etc/${PORTNAME}/config"
@${ECHO_MSG} " For more information read the manpage :)"
@${ECHO_MSG} ""
@${ECHO_MSG} "======================================================================================"
diff --git a/x11-wm/i3/distinfo b/x11-wm/i3/distinfo
index 97f161b06749..abfdd14ec02c 100644
--- a/x11-wm/i3/distinfo
+++ b/x11-wm/i3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (i3-4.1.2.tar.bz2) = 12e51bf34cbfaae00fb54c98d75d6d7b182b08883cd515bff04d544d141d4c40
-SIZE (i3-4.1.2.tar.bz2) = 562976
+SHA256 (i3-4.2.tar.bz2) = e02c832820e8922a44e744e555294f8580c2f8e218c5c1029e52f1bde048732b
+SIZE (i3-4.2.tar.bz2) = 758109
diff --git a/x11-wm/i3/files/patch-i3-config-wizard__main.c b/x11-wm/i3/files/patch-i3-config-wizard__main.c
deleted file mode 100644
index 738af4e7858c..000000000000
--- a/x11-wm/i3/files/patch-i3-config-wizard__main.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- ./i3-config-wizard/main.c.orig 2011-12-24 16:25:08.000000000 +0100
-+++ ./i3-config-wizard/main.c 2011-12-28 09:38:11.000000000 +0100
-@@ -283,10 +283,11 @@
-
- char *line = NULL;
- size_t len = 0;
--#if !defined(__APPLE__)
-+#if defined(__APPLE__) || (defined(__FreeBSD__) && __FreeBSD_version < 800000)
-+ bool head_of_file = true;
-+#else
- ssize_t read;
- #endif
-- bool head_of_file = true;
-
- /* write a header about auto-generation to the output file */
- fputs("# This file has been auto-generated by i3-config-wizard(1).\n", ks_config);
-@@ -296,7 +297,7 @@
- fputs("# this file and re-run i3-config-wizard(1).\n", ks_config);
- fputs("#\n", ks_config);
-
--#if defined(__APPLE__)
-+#if defined(__APPLE__) || (defined(__FreeBSD__) && __FreeBSD_version < 800000)
- while ((line = fgetln(kc_config, &len)) != NULL) {
- #else
- while ((read = getline(&line, &len, kc_config)) != -1) {
diff --git a/x11-wm/i3/files/patch-src__cfgparse.y b/x11-wm/i3/files/patch-src__cfgparse.y
index cccf21967aff..bb0774f83f69 100644
--- a/x11-wm/i3/files/patch-src__cfgparse.y
+++ b/x11-wm/i3/files/patch-src__cfgparse.y
@@ -1,6 +1,6 @@
---- ./src/cfgparse.y.orig 2011-08-01 23:24:22.000000000 +0200
-+++ ./src/cfgparse.y 2011-08-07 13:35:02.000000000 +0200
-@@ -468,7 +468,7 @@
+--- ./src/cfgparse.y.orig 2012-04-28 00:14:46.000000000 +0200
++++ ./src/cfgparse.y 2012-04-28 00:15:01.000000000 +0200
+@@ -619,7 +619,7 @@
start_configerror_nagbar(f);
}
@@ -8,4 +8,4 @@
+ // yylex_destroy();
FREE(context->line_copy);
free(context);
- free(new);
+ FREE(font_pattern);
diff --git a/x11-wm/i3/files/patch-src__cmdparse.y b/x11-wm/i3/files/patch-src__cmdparse.y
deleted file mode 100644
index c64ed4c4eb5b..000000000000
--- a/x11-wm/i3/files/patch-src__cmdparse.y
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/cmdparse.y.orig 2011-08-07 13:35:55.000000000 +0200
-+++ ./src/cmdparse.y 2011-08-07 13:35:24.000000000 +0200
-@@ -99,7 +99,7 @@
- }
- printf("done, json output = %s\n", json_output);
-
-- cmdyylex_destroy();
-+ // cmdyylex_destroy();
- FREE(context->line_copy);
- FREE(context->compact_error);
- free(context);