aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-23 16:04:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-23 16:04:51 +0000
commit60880dc81ea1f497ad1c55285f752c2fc988fa12 (patch)
tree947b714701f203a11bd91bb968e8cabe9cc8c30b /x11-wm/icewm/Makefile
parent3c0ba34945b49d59f9fdb8aff80fd63d50764e02 (diff)
downloadports-60880dc81ea1f497ad1c55285f752c2fc988fa12.tar.gz
ports-60880dc81ea1f497ad1c55285f752c2fc988fa12.zip
Notes
Diffstat (limited to 'x11-wm/icewm/Makefile')
-rw-r--r--x11-wm/icewm/Makefile112
1 files changed, 50 insertions, 62 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 7e92cfa1716a..1ae2615256ae 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -2,66 +2,58 @@
# $FreeBSD$
PORTNAME= icewm
-PORTVERSION= 1.3.7
-PORTREVISION= 3
+PORTVERSION= 1.3.8
CATEGORIES= x11-wm
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Window Manager designed for speed, usability and consistency
LICENSE= GPLv2
-WANT_GNOME= yes
-USE_XORG= x11 ice xinerama xext xrandr sm
-USE_GNOME= gtk20 # gdkpixbuf really :-)
+USES= gmake iconv pkgconfig
+USE_XORG= ice sm x11 xext
+USE_GNOME= gdkpixbuf2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USES= gmake pkgconfig
-CONFIGURE_ARGS= --enable-shaped-decorations \
- --enable-guievents \
+CONFIGURE_ARGS= --enable-guievents \
--with-cfgdir=${DATADIR} \
--with-libdir=${DATADIR} \
--with-kdedatadir=${LOCALBASE}/share \
--with-docdir=${PREFIX}/share/doc \
--with-mkfontdir=${NONEXISTENT}
-OPTIONS_DEFINE= GNOME ESOUND XFT XINERAMA ASM BEASTIE NLS LITE MENUFIX
-OPTIONS_DEFAULT= XFT XINERAMA ASM BEASTIE NLS MENUFIX
-BEASTIE_DESC= Use Beastie'fied startup button
-MENUFIX_DESC= MenuIconSize fix
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MGNOME}
-USE_GNOME+= gnomedesktop libgnomeui
-CONFIGURE_ARGS+=--enable-menus-gnome2
-INSTALL_TARGET= install
-PLIST_SUB+= GNOMEDESKTOP=""
-.else
-PLIST_SUB+= GNOMEDESKTOP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MESOUND}
-USE_GNOME+= esound
-CONFIGURE_ARGS+=--with-icesound=esound
-.else
-CONFIGURE_ARGS+=--with-icesound=oss
-.endif
-
-.if ${PORT_OPTIONS:MXFT}
-LIB_DEPENDS+= Xft:${PORTSDIR}/x11-fonts/libXft
-CONFIGURE_ARGS+=--enable-gradients
-.else
-CONFIGURE_ARGS+=--enable-corefonts --disable-xfreetype
-.endif
-
-.if empty(PORT_OPTIONS:MXINERAMA)
-CONFIGURE_ARGS+=--disable-xinerama
-.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.if ${ARCH} == "i386" && ${PORT_OPTIONS:MASM}
+OPTIONS_DEFINE= BEASTIE ESOUND GNOME LITE MENUFIX NLS XFT XINERAMA \
+ XRANDR
+OPTIONS_DEFINE_i386= ASM
+OPTIONS_DEFAULT= BEASTIE MENUFIX NLS XFT XINERAMA XRANDR
+OPTIONS_DEFAULT_i386= ASM
+OPTIONS_SUB= yes
+
+BEASTIE_DESC= Use Beastie'fied startup button
+ESOUND_USE= GNOME=esound
+ESOUND_CONFIGURE_ON= --with-icesound=esound
+ESOUND_CONFIGURE_OFF= --with-icesound=oss
+GNOME_DESC= Display GNOME 2 menus
+GNOME_USE= GNOME=gnomedesktop,libgnomeui
+GNOME_CONFIGURE_ENABLE= menus-gnome2
+LITE_CONFIGURE_ENABLE= lite
+MENUFIX_DESC= MenuIconSize fix
+MENUFIX_EXTRA_PATCHES= ${FILESDIR}/extra-menu-icon-fix.patch
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+XFT_LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft
+XFT_CONFIGURE_OFF= --enable-corefonts --disable-xfreetype
+XINERAMA_USE= XORG=xinerama
+XINERAMA_CONFIGURE_ENABLE= xinerama
+XRANDR_USE= XORG=xrandr
+XRANDR_CONFIGURE_ENABLE= xrandr
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MASM}
CONFIGURE_ARGS+=--enable-x86-asm
.else
CONFIGURE_ARGS+=--disable-x86-asm
@@ -73,20 +65,10 @@ STARTUP_PIXMAP= ${DATADIR}/taskbar/bsd-daemon.xpm
STARTUP_PIXMAP= icewm-logo.xpm
.endif
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls --disable-i18n
-PLIST_SUB+= NLS="@comment "
-.endif
-
.if ${PORT_OPTIONS:MLITE}
-MAKE_ENV+= LITE=1
-.endif
-
-.if ${PORT_OPTIONS:MMENUFIX}
-EXTRA_PATCHES+= ${FILESDIR}/extra-menu-icon-fix.patch
+PLIST_SUB+= NOLITE="@comment "
+.else
+PLIST_SUB+= NOLITE=""
.endif
post-extract:
@@ -102,9 +84,15 @@ post-patch:
s|/usr/share/app|${LOCALBASE}/share/app|g ; \
s|/usr/share/gnome|${LOCALBASE}/share/gnome|g' \
${WRKSRC}/src/gnome2.cc
-
-post-configure:
- ${REINPLACE_CMD} -e 's|icewm-set-gnomewm||g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|SHELL=.*|SHELL=@SHELL@| ; \
+ s|icewm-set-gnomewm||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|icewm-$$(VERSION)|icewm| ; \
+ s|`pkg-config fontconfig --cflags`|| ; \
+ s|`pkg-config fontconfig --libs`|| ; \
+ /@echo/s|^|#| ; \
+ s|@$$(|$$(|' ${WRKSRC}/src/Makefile.in
post-install:
.for dir in taskbar themes/Infadel2/taskbar
@@ -116,4 +104,4 @@ post-install:
. endfor
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>