aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:45:17 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:45:17 +0000
commitf0e428c448cb5220cbb62c6a8a789806f2770e57 (patch)
tree78a8286ed81d61a1833dddcc4cf941747805ae3f /x11-wm/icewm/Makefile
parentd4fdb44e8981b0b9b6b7fb7a41a334396196f88f (diff)
downloadports-f0e428c448cb5220cbb62c6a8a789806f2770e57.tar.gz
ports-f0e428c448cb5220cbb62c6a8a789806f2770e57.zip
Notes
Diffstat (limited to 'x11-wm/icewm/Makefile')
-rw-r--r--x11-wm/icewm/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 92ab54c48d69..8c8b448a1a8d 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -6,27 +6,26 @@
#
PORTNAME= icewm
-PORTVERSION= 1.2.7
-PORTREVISION= 1
+PORTVERSION= 1.2.8
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= nakai@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Window Manager designed for speed, usability and consistency
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
WANT_GNOME= yes
+USE_GNOME= gnometarget
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --disable-xfreetype \
- --with-cfgdir=${PREFIX}/share/icewm \
- --with-libdir=${PREFIX}/share/icewm \
+ --with-cfgdir=${DATADIR} \
+ --with-libdir=${DATADIR} \
--with-kdedatadir=${LOCALBASE}/share \
--with-docdir=${PREFIX}/share/doc \
--with-mkfontdir=${NONEXISTENT}
@@ -36,14 +35,14 @@ CONFIGURE_ARGS= --disable-xfreetype \
.if ${HAVE_GNOME:Mgnomelibs}!=""
.undef HAVE_ESOUND
USE_GNOME+= gnomelibs
-CONFIGURE_ARGS+= --with-imlib --without-xpm --with-gnome-menus \
+CONFIGURE_ARGS+= --with-imlib --without-xpm --enable-menus-gnome1 \
--enable-guievents --with-icesound=esound
INSTALL_TARGET= install install-gnome
PLIST_SUB+= ESOUND=""
PKGNAMESUFFIX= -gnome
.else
USE_XPM= yes
-CONFIGURE_ARGS+= --without-imlib --with-xpm --without-gnome-menus
+CONFIGURE_ARGS+= --without-imlib --with-xpm
.if ${HAVE_GNOME:Mesound}!=""
USE_GNOME+= esound
CONFIGURE_ARGS+= --enable-guievents --with-icesound=esound