aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2002-07-26 10:10:02 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2002-07-26 10:10:02 +0000
commit62a6a60c26b293656a2bf9c3e20de8b11dfe642b (patch)
treeeaad932760cb7fb1a0ebf1ebb3b4b41b3f75df8d /x11-wm/icewm/Makefile
parent7ed30444a868e0ec81b283a1d5b9d837f7bbba39 (diff)
downloadports-62a6a60c26b293656a2bf9c3e20de8b11dfe642b.tar.gz
ports-62a6a60c26b293656a2bf9c3e20de8b11dfe642b.zip
Notes
Diffstat (limited to 'x11-wm/icewm/Makefile')
-rw-r--r--x11-wm/icewm/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index eaf2a0085870..704ce1772570 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -6,22 +6,19 @@
#
PORTNAME= icewm
-PORTVERSION= 1.0.9.2
+PORTVERSION= 1.2.0
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= nakai@FreeBSD.org
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
-WANT_GNOME= yes
-WANT_ESOUND= yes
-USE_BZIP2= yes
USE_X_PREFIX= yes
+WANT_ESOUND= yes
+WANT_GNOME= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -37,14 +34,15 @@ CONFIGURE_ARGS= --enable-i18n --enable-nls \
.include <bsd.port.pre.mk>
.if defined(HAVE_GNOME)
+.undef HAVE_ESOUND
USE_GNOME= yes
-CONFIGURE_ARGS+= --with-imlib --without-xpm --with-gnome-menus
+CONFIGURE_ARGS+= --with-imlib --without-xpm --with-gnome-menus \
+ --enable-guievents --with-icesound=esound
INSTALL_TARGET= install install-gnome
+PLIST_SUB+= ESOUND=""
.else
USE_XPM= yes
CONFIGURE_ARGS+= --without-imlib --with-xpm --without-gnome-menus
-.endif
-
.if defined(HAVE_ESOUND)
USE_ESOUND= yes
CONFIGURE_ARGS+= --enable-guievents --with-icesound=esound
@@ -52,8 +50,9 @@ PLIST_SUB+= ESOUND=""
.else
PLIST_SUB+= ESOUND="@comment "
.endif
+.endif
-post-patch:
+pre-configure:
@cd ${CONFIGURE_WRKSRC} && ${LOCALBASE}/bin/autoconf
post-install: