aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-07 19:20:07 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-07 19:20:07 +0000
commit700a5ab3c08f827001d7e6677998ed5a4934f304 (patch)
tree8f116b0b082577fcc39144922f6b8d884ff8cec8 /x11-wm/icewm
parente9ecf73769a83303266196e23552ce633f796847 (diff)
Notes
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Makefile1
-rw-r--r--x11-wm/icewm/files/patch-src_icesound.cc48
-rw-r--r--x11-wm/icewm/files/patch-src_ycmdline.cc11
-rw-r--r--x11-wm/icewm/pkg-plist7
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 67293f5f0a2e..64b101d9d02d 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icewm
PORTVERSION= 1.2.14
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/x11-wm/icewm/files/patch-src_icesound.cc b/x11-wm/icewm/files/patch-src_icesound.cc
new file mode 100644
index 000000000000..09ce7bb6bcbe
--- /dev/null
+++ b/x11-wm/icewm/files/patch-src_icesound.cc
@@ -0,0 +1,48 @@
+--- src/icesound.cc.orig Sun May 23 15:18:19 2004
++++ src/icesound.cc Wed Aug 4 23:45:45 2004
+@@ -190,7 +190,8 @@
+ virtual int init(int & argc, char **& argv);
+
+ private:
+- friend class CommandLine : public YCommandLine {
++ friend class CommandLine;
++ class CommandLine : public YCommandLine {
+ public:
+ CommandLine(int & argc, char **& argv, YOSSAudio & oss):
+ YCommandLine(argc, argv), oss(oss) {}
+@@ -226,6 +227,7 @@
+ YOSSAudio & oss;
+ };
+
++ friend class CommandLine;
+ char const * device;
+ };
+
+@@ -326,7 +328,8 @@
+ virtual int init(int & argc, char **& argv);
+
+ private:
+- friend class CommandLine : public YCommandLine {
++ friend class CommandLine;
++ class CommandLine : public YCommandLine {
+ public:
+ CommandLine(int & argc, char **& argv, YESDAudio & esd):
+ YCommandLine(argc, argv), esd(esd) {}
+@@ -364,6 +367,7 @@
+ };
+
+ protected:
++ friend class CommandLine;
+ char const * speaker;
+ int sample[ACOUNT(gui_events)]; // cache sample ids
+ int socket; // socket to ESound Daemon
+@@ -502,7 +506,8 @@
+ Coefficient lVol = 1.0, Coefficient rVol = 1.0);
+
+ private:
+- friend class CommandLine : public YCommandLine {
++ friend class CommandLine;
++ class CommandLine : public YCommandLine {
+ public:
+ CommandLine(int & argc, char **& argv, YY2Audio & yiff):
+ YCommandLine(argc, argv), yiff(yiff) {}
diff --git a/x11-wm/icewm/files/patch-src_ycmdline.cc b/x11-wm/icewm/files/patch-src_ycmdline.cc
new file mode 100644
index 000000000000..6e22f0892ad4
--- /dev/null
+++ b/x11-wm/icewm/files/patch-src_ycmdline.cc
@@ -0,0 +1,11 @@
+--- src/ycmdline.cc.orig Sun May 23 15:18:19 2004
++++ src/ycmdline.cc Wed Aug 4 23:25:42 2004
+@@ -55,7 +55,7 @@
+ if (*vptr == '=') ++vptr;
+ while (ASCII::isSpaceOrTab(*vptr)) ++vptr;
+ } else { // ------------------------- value assumed in the next argument ---
+- int idx(&arg - argv + 1);
++ int idx = &arg - static_cast<char const* const*>(argv) + 1;
+
+ if (idx < argc) {
+ vptr = argv[idx];
diff --git a/x11-wm/icewm/pkg-plist b/x11-wm/icewm/pkg-plist
index 628b131b45ec..a354410aa314 100644
--- a/x11-wm/icewm/pkg-plist
+++ b/x11-wm/icewm/pkg-plist
@@ -322,6 +322,12 @@ bin/icewmtray
%%DATADIR%%/themes/win95/maximize.xpm
%%DATADIR%%/themes/win95/minimize.xpm
%%DATADIR%%/themes/win95/restore.xpm
+%%DATADIR%%/themes/yellowmotif/close.xpm
+%%DATADIR%%/themes/yellowmotif/default.theme
+%%DATADIR%%/themes/yellowmotif/maximize.xpm
+%%DATADIR%%/themes/yellowmotif/menu.xpm
+%%DATADIR%%/themes/yellowmotif/minimize.xpm
+%%DATADIR%%/themes/yellowmotif/restore.xpm
%%DATADIR%%/toolbar
%%DATADIR%%/winoptions
%%NLS%%share/locale/be/LC_MESSAGES/icewm.mo
@@ -352,6 +358,7 @@ bin/icewmtray
%%NLS%%share/locale/uk/LC_MESSAGES/icewm.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/icewm.mo
%%NLS%%share/locale/zh_TW.Big5/LC_MESSAGES/icewm.mo
+@dirrm %%DATADIR%%/themes/yellowmotif
@dirrm %%DATADIR%%/themes/win95
@dirrm %%DATADIR%%/themes/warp4
@dirrm %%DATADIR%%/themes/warp3