aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/ion-2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-30 07:06:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-30 07:06:29 +0000
commit20647ee8ea400f5ed68739b2baeaa105aa2a4a53 (patch)
treec9ecb4779fd47d1afdd51eb7a35cdabf56bca256 /x11-wm/ion-2
parent283777ab5ab46c79bfb7e9deb42c34333590cede (diff)
downloadports-20647ee8ea400f5ed68739b2baeaa105aa2a4a53.tar.gz
ports-20647ee8ea400f5ed68739b2baeaa105aa2a4a53.zip
Notes
Diffstat (limited to 'x11-wm/ion-2')
-rw-r--r--x11-wm/ion-2/Makefile30
-rw-r--r--x11-wm/ion-2/distinfo4
-rw-r--r--x11-wm/ion-2/files/patch-disable_border162
-rw-r--r--x11-wm/ion-2/files/patch-ion-edit9
-rw-r--r--x11-wm/ion-2/files/patch-ion-view18
-rw-r--r--x11-wm/ion-2/files/patch-rules.mk10
-rw-r--r--x11-wm/ion-2/files/patch-system.mk104
-rw-r--r--x11-wm/ion-2/files/patch-winprop_frame74
-rw-r--r--x11-wm/ion-2/pkg-descr19
-rw-r--r--x11-wm/ion-2/pkg-plist83
10 files changed, 167 insertions, 346 deletions
diff --git a/x11-wm/ion-2/Makefile b/x11-wm/ion-2/Makefile
index 768162d88ea3..3f62526cc571 100644
--- a/x11-wm/ion-2/Makefile
+++ b/x11-wm/ion-2/Makefile
@@ -1,22 +1,32 @@
-# New ports collection makefile for: ion
-# Date created: 20 January 2001
-# Whom: ricci@cs.utah.edu
+# New ports collection makefile for: ion-devel
+# Date created: 20 August 2003
+# Whom: anthony.ginepro@laposte.net
+# Original ion port: ricci@cs.utah.edu
#
# $FreeBSD$
#
-PORTNAME= ion
-PORTVERSION= 20020207
-PORTREVISION= 1
+PORTNAME= ion-2
+PORTVERSION= 20040407
CATEGORIES= x11-wm
-MASTER_SITES= http://modeemi.cs.tut.fi/~tuomov/dl/
+MASTER_SITES= http://modeemi.fi/~tuomov/ion/dl/
-MAINTAINER= ricci@cs.utah.edu
-COMMENT= A window manager with a text-editorish, keyboard friendly interface
+MAINTAINER= anthony.ginepro@laposte.net
+COMMENT= Ion is a tiling tabbed window manager
-MAN1= ion.1x
+LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl \
+ lua.5:${PORTSDIR}/lang/lua
+CONFLICTS= ion-2002* ion-devel-*
+
+USE_LIBTOOL_VER=15
USE_X_PREFIX= yes
USE_GMAKE= yes
+MAN1= ion.1 pwm.1
+DOCSDIR= share/doc/ion
+
+# NO, I don't want to use configure but ion's author system.mk
+do-configure:
+
.include <bsd.port.mk>
diff --git a/x11-wm/ion-2/distinfo b/x11-wm/ion-2/distinfo
index e392250e5982..366111724e45 100644
--- a/x11-wm/ion-2/distinfo
+++ b/x11-wm/ion-2/distinfo
@@ -1,2 +1,2 @@
-MD5 (ion-20020207.tar.gz) = 2e909abb45efefb08b1ceb886bf34cfe
-SIZE (ion-20020207.tar.gz) = 157649
+MD5 (ion-2-20040407.tar.gz) = f27efbd06ab1c8ac26918bef6ed029e7
+SIZE (ion-2-20040407.tar.gz) = 389518
diff --git a/x11-wm/ion-2/files/patch-disable_border b/x11-wm/ion-2/files/patch-disable_border
deleted file mode 100644
index 9afd88b74f34..000000000000
--- a/x11-wm/ion-2/files/patch-disable_border
+++ /dev/null
@@ -1,162 +0,0 @@
-# This patch was originally sent to the ION mailing list by:
-# Christian Mauduit <ufoot@ufoot.org>
-
-diff -r -u doc.orig/functions.txt doc/functions.txt
---- doc.orig/functions.txt Fri Feb 8 22:23:17 2002
-+++ doc/functions.txt Fri Mar 8 23:57:46 2002
-@@ -59,6 +59,13 @@
- enabled
-
-
-+Border control
-+--------------
-+
-+disable_border Disables the border and the bar
-+enable_border Enables the border and the bar
-+
-+
- Close and destroy
- -----------------
-
-diff -r -u src.orig/draw.c src/draw.c
---- src.orig/draw.c Fri Feb 8 22:23:17 2002
-+++ src/draw.c Fri Mar 8 23:53:34 2002
-@@ -136,6 +136,13 @@
- DrawInfo _dinfo, *dinfo=&_dinfo;
- WGRData *grdata=GRDATA_OF(frame);
-
-+ if(complete)
-+ XClearWindow(wglobal.dpy, FRAME_WIN(frame));
-+
-+ /* if the border is not active, we draw nothing here */
-+ if (frame->flags & WFRAME_NO_BORDER)
-+ return;
-+
- dinfo->win=FRAME_WIN(frame);
- dinfo->grdata=grdata;
- dinfo->gc=grdata->gc;
-@@ -143,15 +150,12 @@
- dinfo->geom.w+=FRAME_W(frame);
- dinfo->geom.h+=FRAME_H(frame);
- dinfo->border=&(grdata->frame_border);
--
-+
- if(IS_ACTIVE_FRAME(frame))
- dinfo->colors=&(grdata->act_frame_colors);
- else
- dinfo->colors=&(grdata->frame_colors);
-
-- if(complete)
-- XClearWindow(wglobal.dpy, FRAME_WIN(frame));
--
- /*#if 1*/
- draw_box(dinfo, FALSE);
- /*#else
-@@ -191,6 +195,10 @@
- WGRData *grdata=&(scr->grdata);
- WRectangle bg;
-
-+ /* if the border is not active, we draw nothing here */
-+ if (frame->flags & WFRAME_NO_BORDER)
-+ return;
-+
- frame_bar_geom(frame, &bg);
-
- dinfo->win=FRAME_WIN(frame);
-diff -r -u src.orig/frame.c src/frame.c
---- src.orig/frame.c Fri Feb 8 22:23:17 2002
-+++ src/frame.c Fri Mar 8 23:53:37 2002
-@@ -41,15 +41,28 @@
- #define BAR_W(FRAME, GRDATA) ((FRAME)->win.geom.w+(GRDATA)->bar_off.w)
- #define BAR_H(FRAME, GRDATA) ((GRDATA)->bar_h)
-
--#define FRAME_TO_CLIENT_W(W, GRDATA) ((W)+(GRDATA)->client_off.w)
--#define FRAME_TO_CLIENT_H(H, GRDATA) ((H)+(GRDATA)->client_off.h)
--#define CLIENT_TO_FRAME_W(W, GRDATA) ((W)-(GRDATA)->client_off.w)
--#define CLIENT_TO_FRAME_H(H, GRDATA) ((H)-(GRDATA)->client_off.h)
--
--#define CLIENT_X(FRAME, GRDATA) ((GRDATA)->client_off.x)
--#define CLIENT_Y(FRAME, GRDATA) ((GRDATA)->client_off.y)
--#define CLIENT_W(FRAME, GRDATA) FRAME_TO_CLIENT_W(FRAME_W(FRAME), GRDATA)
--#define CLIENT_H(FRAME, GRDATA) FRAME_TO_CLIENT_H(FRAME_H(FRAME), GRDATA)
-+#define FRAME_TO_CLIENT_W(W, FRAME, GRDATA) \
-+ (((FRAME)->flags & WFRAME_NO_BORDER) ? \
-+ (W) : (W)+(GRDATA)->client_off.w)
-+#define FRAME_TO_CLIENT_H(H, FRAME, GRDATA) \
-+ (((FRAME)->flags & WFRAME_NO_BORDER) ? \
-+ (H) : (H)+(GRDATA)->client_off.h)
-+#define CLIENT_TO_FRAME_W(W, FRAME, GRDATA) \
-+ (((FRAME)->flags & WFRAME_NO_BORDER) ? \
-+ (W) : (W)-(GRDATA)->client_off.w)
-+#define CLIENT_TO_FRAME_H(H, FRAME, GRDATA) \
-+ (((FRAME)->flags & WFRAME_NO_BORDER) ? \
-+ (H) : (H)-(GRDATA)->client_off.h)
-+
-+#define CLIENT_X(FRAME, GRDATA) \
-+ ((FRAME)->flags & WFRAME_NO_BORDER ? \
-+ 0 : (GRDATA)->client_off.x)
-+#define CLIENT_Y(FRAME, GRDATA) \
-+ ((FRAME)->flags & WFRAME_NO_BORDER ? \
-+ 0 : (GRDATA)->client_off.y)
-+
-+#define CLIENT_W(FRAME, GRDATA) FRAME_TO_CLIENT_W(FRAME_W(FRAME), FRAME, GRDATA)
-+#define CLIENT_H(FRAME, GRDATA) FRAME_TO_CLIENT_H(FRAME_H(FRAME), FRAME, GRDATA)
-
-
- WThingFuntab frame_funtab={deinit_frame, frame_remove_child};
-@@ -658,6 +671,22 @@
- geom->y=CLIENT_Y(frame, grdata);
- geom->w=CLIENT_W(frame, grdata);
- geom->h=CLIENT_H(frame, grdata);
-+}
-+
-+void enable_border(WFrame *frame)
-+{
-+ frame->flags = frame->flags & (~WFRAME_NO_BORDER);
-+
-+ frame_fit_clients(frame);
-+ draw_frame(frame,TRUE);
-+}
-+
-+void disable_border(WFrame *frame)
-+{
-+ frame->flags = frame->flags | WFRAME_NO_BORDER;
-+
-+ frame_fit_clients(frame);
-+ draw_frame(frame,TRUE);
- }
-
-
-diff -r -u src.orig/frame.h src/frame.h
---- src.orig/frame.h Fri Feb 8 22:23:17 2002
-+++ src/frame.h Fri Mar 8 23:05:54 2002
-@@ -23,6 +23,7 @@
- #define WFRAME_SHADE 0x0004
- #define WFRAME_NO_BAR 0x0008
- #define WFRAME_MAX_BOTH (WFRAME_MAX_VERT|WFRAME_MAX_HORIZ)
-+#define WFRAME_NO_BORDER 0x0010
-
- #define FRAME_SHORTCUT_W 23
-
-@@ -96,5 +97,8 @@
- extern void split_top(WWorkspace *ws, char *str);
-
- extern WFrame *find_frame_of(Window win);
-+
-+extern void enable_border(WFrame *frame);
-+extern void disable_border(WFrame *frame);
-
- #endif /* INCLUDED_FRAME_H */
-diff -r -u src.orig/function.c src/function.c
---- src.orig/function.c Fri Feb 8 22:23:17 2002
-+++ src/function.c Fri Mar 8 23:05:54 2002
-@@ -90,6 +90,9 @@
- FN(d, generic, WFrame, "set_widthq", set_widthq),
- FN(d, generic, WFrame, "set_heightq", set_heightq),
-
-+ FN_VOID(generic, WFrame, "enable_border", enable_border),
-+ FN_VOID(generic, WFrame, "disable_border", disable_border),
-+
- FN(s, generic, WWorkspace,"split_top", split_top),
-
- /* client */
diff --git a/x11-wm/ion-2/files/patch-ion-edit b/x11-wm/ion-2/files/patch-ion-edit
deleted file mode 100644
index b1313ff1a951..000000000000
--- a/x11-wm/ion-2/files/patch-ion-edit
+++ /dev/null
@@ -1,9 +0,0 @@
-*** scripts/ion-edit.orig Sat Jan 20 01:43:39 2001
---- scripts/ion-edit Sat Jan 20 01:51:17 2001
-***************
-*** 1,2 ****
- #!/bin/sh
-! exec run-mailcap --action=edit "$1" > /dev/null
---- 1,2 ----
- #!/bin/sh
-! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
diff --git a/x11-wm/ion-2/files/patch-ion-view b/x11-wm/ion-2/files/patch-ion-view
deleted file mode 100644
index 689e8a514757..000000000000
--- a/x11-wm/ion-2/files/patch-ion-view
+++ /dev/null
@@ -1,18 +0,0 @@
-*** scripts/ion-view.orig Sat Jan 20 01:44:05 2001
---- scripts/ion-view Sat Jan 20 01:55:39 2001
-***************
-*** 1,7 ****
- #!/bin/sh
- if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
-! exec netscape-remote "$1"
- else
-! exec run-mailcap --action=view "$1" > /dev/null
- fi
-
---- 1,7 ----
- #!/bin/sh
- if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
-! exec netscape "$1"
- else
-! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
- fi
diff --git a/x11-wm/ion-2/files/patch-rules.mk b/x11-wm/ion-2/files/patch-rules.mk
new file mode 100644
index 000000000000..0dbc8606502d
--- /dev/null
+++ b/x11-wm/ion-2/files/patch-rules.mk
@@ -0,0 +1,10 @@
+--- rules.mk Wed Apr 7 09:15:54 2004
++++ rules.mk.bsd Sun Apr 11 12:55:10 2004
+@@ -91,6 +91,7 @@
+ module_install:
+ $(INSTALLDIR) $(MODULEDIR)
+ $(LIBTOOL) --mode=install $(INSTALL) -s -m $(BIN_MODE) $(MODULE).la $(MODULEDIR)
++ $(INSTALL) -m $(BIN_MODE) $(MODULE).la $(MODULEDIR)
+
+ clean_objs:
+ $(RM) -f $(OBJS)
diff --git a/x11-wm/ion-2/files/patch-system.mk b/x11-wm/ion-2/files/patch-system.mk
index e08a035fd705..d7fb284debd6 100644
--- a/x11-wm/ion-2/files/patch-system.mk
+++ b/x11-wm/ion-2/files/patch-system.mk
@@ -1,46 +1,71 @@
---- system.mk.orig Sat Jan 19 15:15:13 2002
-+++ system.mk Mon Mar 15 03:19:42 2004
-@@ -7,13 +7,13 @@
+--- system.mk.orig Wed Apr 7 09:15:54 2004
++++ system.mk Tue May 25 16:54:31 2004
+@@ -7,7 +7,7 @@
## Installation paths
##
-PREFIX=/usr/local
+#PREFIX=/usr/local
- # No need to modify these usually
- BINDIR=$(PREFIX)/bin
- ETCDIR=$(PREFIX)/etc
- MANDIR=$(PREFIX)/man
--DOCDIR=$(PREFIX)/doc
-+DOCDIR=$(PREFIX)/share/doc
- # Not used
- INCDIR=$(PREFIX)/include
- LIBDIR=$(PREFIX)/lib
-@@ -24,14 +24,14 @@
- ##
-
- #MODULE_SUPPORT=-DCF_NO_MODULE_SUPPORT
--MODULE_SUPPORT_LDFLAGS=-export-dynamic -ldl
-+MODULE_SUPPORT_LDFLAGS=-export-dynamic
-
-
- ##
+ # Unless you are creating a package conforming to some OS's standards, you
+ # probably do not want to modify the following directories:
+@@ -19,7 +19,7 @@
+ # Some .lua files and ion-* shell scripts
+ SHAREDIR=$(PREFIX)/share/ion
+ # Manual pages
+-MANDIR=$(PREFIX)/share/man
++MANDIR=$(PREFIX)/man
+ # Some documents
+ DOCDIR=$(PREFIX)/share/doc/ion
+ # Nothing at the moment
+@@ -42,11 +42,11 @@
+ # libtool because even more-recent-than-libtool-1.4.3 releases of those
+ # OSes only have an _ancient_ 1.3.x libtool that _will_ _not_ _work even
+ # though a lot of libltdl-using apps require 1.4.3.
+-LIBTOOL=libtool
++LIBTOOL=$(LOCALBASE)/bin/libtool15 --tag=CC
+
+ # Settings for compiling and linking to ltdl
+-LTDL_INCLUDES=
+-LTDL_LIBS=-lltdl
++LTDL_INCLUDES=-I$(LOCALBASE)/include
++LTDL_LIBS=-L$(LOCALBASE)/lib -lltdl
+
+ # The following should do it if you have manually installed libtool 1.5 in
+ # $(LIBTOOLDIR).
+@@ -72,7 +72,7 @@
+
+ # If you have installed Lua 5.0 from the official tarball without changing
+ # paths, this should do it.
+-LUA_DIR=/usr/local
++LUA_DIR=$(LOCALBASE)
+ LUA_LIBS = -L$(LUA_DIR)/lib -R$(LUA_DIR)/lib -llua -llualib
+ LUA_INCLUDES = -I$(LUA_DIR)/include
+ LUA=$(LUA_DIR)/bin/lua
+@@ -90,7 +90,7 @@
## X libraries, includes and options
##
-X11_PREFIX=/usr/X11R6
+X11_PREFIX=$(X11BASE)
-
# SunOS/Solaris
#X11_PREFIX=/usr/openwin
-@@ -52,14 +52,14 @@
+
+@@ -119,29 +119,29 @@
# asprintf and vasprintf in the c library. (gnu libc has.)
# If HAS_SYSTEM_ASPRINTF is not defined, an implementation
- # in libtu/sprintf_2.2/ is used.
+ # in sprintf_2.2/ is used.
-#HAS_SYSTEM_ASPRINTF=1
+HAS_SYSTEM_ASPRINTF=1
+ # If you're on an archaic system (such as relatively recent *BSD releases)
+ # without even dummy multibyte/widechar support, you may have to uncomment
+ # the following line:
+-#DEFINES += -DCF_NO_MB_SUPPORT
++DEFINES += -DCF_NO_MB_SUPPORT
+
+
##
## C compiler
##
@@ -48,24 +73,30 @@
-CC=gcc
+CC?=gcc
- # The POSIX_SOURCE, XOPEN_SOURCE and WARN options should not be necessary,
- # they're mainly for development use. So, if they cause trouble (not
-@@ -83,11 +83,11 @@
+ # Same as '-Wall -pedantic' without '-Wunused' as callbacks often
# have unused variables.
WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
-Wtrigraphs -Wformat -Wchar-subscripts \
-- -Wparentheses -pedantic-errors -Wuninitialized
+- -Wparentheses -pedantic -Wuninitialized
+ -Wparentheses -Wuninitialized
+-CFLAGS=-g -Os $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
+-LDFLAGS=-g -Os $(EXTRA_LIBS) $(LIBS)
++CFLAGS+= $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
++LDFLAGS= $(EXTRA_LIBS) $(LIBS)
--CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
--LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)
-+CFLAGS+= $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
-+LDFLAGS= $(LIBS) $(EXTRA_LIBS)
+ # The following options are mainly for development use and can be used
+ # to check that the code seems to conform to some standards. Depending
+@@ -154,7 +154,7 @@
+ #POSIX_SOURCE=-D_POSIX_SOURCE
+ # Most systems
+-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
++XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
+ # SunOS, (Irix)
+ #XOPEN_SOURCE=-D__EXTENSIONS__
- ##
-@@ -112,13 +112,13 @@
+@@ -190,9 +190,9 @@
##
# Should work almost everywhere
@@ -77,8 +108,3 @@
INSTALLDIR=mkdir -p
- BIN_MODE=755
--DATA_MODE=664
-+DATA_MODE=644
-
- STRIP=strip
diff --git a/x11-wm/ion-2/files/patch-winprop_frame b/x11-wm/ion-2/files/patch-winprop_frame
deleted file mode 100644
index 412d82f36d56..000000000000
--- a/x11-wm/ion-2/files/patch-winprop_frame
+++ /dev/null
@@ -1,74 +0,0 @@
-# This patch was originally sent to the ION mailing list by:
-# Alejandro Forero Cuervo <bachue@bachue.com>
-
-diff -Naur ChangeLog.orig ChangeLog
---- ChangeLog.orig Tue Feb 5 23:46:01 2002
-+++ ChangeLog Sat Feb 9 17:19:06 2002
-@@ -1,3 +1,6 @@
-+2002-02-09:
-+ * Implemented "frame" functionality for winprops (Alejandro Forero
-+ <bachue@bachue.com>).
-
- 2002-02-06:
- * Added 'split_top "dir"' command.
-diff -Naur src.orig/clientwin.c src/clientwin.c
---- src.orig/clientwin.c Wed Feb 6 18:41:22 2002
-+++ src/clientwin.c Sat Feb 9 17:09:22 2002
-@@ -180,7 +180,10 @@
- }
- }
-
-- get_integer_property(win, wglobal.atom_frame_id, &frame_id);
-+ if (props!=NULL && props->frame!=0)
-+ frame_id=props->frame;
-+ else
-+ get_integer_property(win, wglobal.atom_frame_id, &frame_id);
-
- /* Get client to place this window in */
- if(client==NULL){
-diff -Naur src.orig/readconfig.c src/readconfig.c
---- src.orig/readconfig.c Wed Feb 6 18:38:16 2002
-+++ src/readconfig.c Sat Feb 9 17:24:01 2002
-@@ -674,6 +674,14 @@
- return TRUE;
- }
-
-+
-+static bool opt_winprop_frame(Tokenizer *tokz, int n, Token *toks)
-+{
-+ tmp_winprop->frame=TOK_LONG_VAL(&(toks[1]));
-+ return TRUE;
-+}
-+
-+
- static bool opt_winprop_transient_mode(Tokenizer *tokz, int n, Token *toks)
- {
- char *mod=TOK_IDENT_VAL(&(toks[1]));
-@@ -721,6 +729,7 @@
- tmp_winprop->data=wclass=TOK_TAKE_STRING_VAL(&(toks[1]));
- tmp_winprop->switchto=-1;
- tmp_winprop->stubborn=0;
-+ tmp_winprop->frame=0;
- tmp_winprop->transient_mode=TRANSIENT_MODE_NORMAL;
-
- winstance=strchr(wclass, '.');
-@@ -799,6 +808,7 @@
- {"switchto", "b", opt_winprop_switchto, NULL},
- {"stubborn", "b", opt_winprop_stubborn, NULL},
- {"transient_mode", "i", opt_winprop_transient_mode, NULL},
-+ {"frame", "l", opt_winprop_frame, NULL},
-
- {"#end", NULL, end_winprop, NULL},
- /*{"#cancel", NULL, cancel_winprop, NULL},*/
-diff -Naur src.orig/winprops.h src/winprops.h
---- src.orig/winprops.h Mon Mar 5 16:16:06 2001
-+++ src/winprops.h Sat Feb 9 17:09:22 2002
-@@ -30,6 +30,7 @@
- int transient_mode;
- int max_w, max_h;
- int aspect_w, aspect_h;
-+ int frame;
-
- WWinProp *next, *prev;
- };
-
diff --git a/x11-wm/ion-2/pkg-descr b/x11-wm/ion-2/pkg-descr
index 6f03fae26d2b..20d61b9ef91b 100644
--- a/x11-wm/ion-2/pkg-descr
+++ b/x11-wm/ion-2/pkg-descr
@@ -1,23 +1,20 @@
Ion (based on PWM) is a new kind of window manager that brings a
-text-editorish, keyboard friendly user interface to window management.
-
+text-editorish, keyboard friendly user interface to window management.
+
Modern GUIs are unusable. Overlapping windows are hard to manage, especially
from the keyboard, and the user often ends up in a jungle. Not to mention the
application programs, which are even worse. Mouse-based search-and-click
interfaces are slow - keyboard is fast having learnt the commands. Ion (the
last three letters of vision =-) was written as an example and an experiment of
-something presumably better (just the window manager, though).
-
+something presumably better (just the window manager, though).
+
Ion simply divides the screen into frames that take the whole screen. Big
displays have so much space that this is convenient and smaller displays
couldn't show more than one window at a time anyway. The frames can be split
and growing the size of one will shrink others. Alike in PWM, clients can be
-moved between frames and multiple clients can be attached to one frame.
-
+moved between frames and multiple clients can be attached to one frame.
+
With Ion you will hardly ever have to touch the mouse again for navigation
-between windows and the windows are always in order.
-
+between windows and the windows are always in order.
+
WWW: http://modeemi.cs.tut.fi/~tuomov/ion/
-
--- Robert Ricci
- ricci@cs.utah.edu
diff --git a/x11-wm/ion-2/pkg-plist b/x11-wm/ion-2/pkg-plist
index d9650d5ab706..58f9fd660e27 100644
--- a/x11-wm/ion-2/pkg-plist
+++ b/x11-wm/ion-2/pkg-plist
@@ -1,23 +1,64 @@
bin/ion
-bin/ion-edit
-bin/ion-man
-bin/ion-runinxterm
-bin/ion-ssh
-bin/ion-view
-etc/ion/bindings-default.conf
-etc/ion/bindings-sun.conf
-etc/ion/kludges.conf
-etc/ion/look-brownsteel.conf
-etc/ion/look-greyviolet.conf
-etc/ion/look-simpleblue.conf
-etc/ion/look-wheat.conf
-@unexec if cmp -s %D/etc/ion/ion.conf %D/etc/ion/sample.conf; then rm -f %D/etc/ion/ion.conf; fi
-etc/ion/sample.conf
-@exec [ -f %B/ion.conf ] || cp %B/%f %B/ion.conf
-%%PORTDOCS%%share/doc/ion/README
-%%PORTDOCS%%share/doc/ion/LICENSE
-%%PORTDOCS%%share/doc/ion/ChangeLog
-%%PORTDOCS%%share/doc/ion/config.txt
-%%PORTDOCS%%share/doc/ion/functions.txt
-%%PORTDOCS%%@dirrm share/doc/ion
+bin/pwm
+etc/ion/dock-draw.lua
+etc/ion/dock.lua
+etc/ion/draw.lua
+etc/ion/floatws.lua
+etc/ion/ion-bindings.lua
+etc/ion/ion-menus.lua
+etc/ion/ion.lua
+etc/ion/ionws.lua
+etc/ion/kludges.lua
+etc/ion/look-brownsteel.lua
+etc/ion/look-clean.lua
+etc/ion/look-cleanios.lua
+etc/ion/look-cleanviolet.lua
+etc/ion/look-dusky.lua
+etc/ion/look-greyviolet.lua
+etc/ion/look-ios.lua
+etc/ion/look-simpleblue.lua
+etc/ion/look-wheat2.lua
+etc/ion/menu.lua
+etc/ion/pwm-bindings.lua
+etc/ion/pwm-menus.lua
+etc/ion/pwm.lua
+etc/ion/query.lua
+lib/ion/de.la
+lib/ion/de.so
+lib/ion/dock.la
+lib/ion/dock.so
+lib/ion/floatws.la
+lib/ion/floatws.so
+lib/ion/ion-completefile
+lib/ion/ionws.la
+lib/ion/ionws.so
+lib/ion/menu.la
+lib/ion/menu.so
+lib/ion/query.la
+lib/ion/query.so
+lib/ion/lc/ioncore-efbb.lc
+lib/ion/lc/ioncorelib.lc
+lib/ion/lc/ioncorelib-mplexfns.lc
+lib/ion/lc/menulib.lc
+lib/ion/lc/querylib.lc
+share/ion/delib.lc
+share/ion/delib.lua
+share/ion/ion-edit
+share/ion/ion-man
+share/ion/ion-runinxterm
+share/ion/ion-ssh
+share/ion/ion-view
+share/ion/ioncore-efbb.lua
+share/ion/ioncorelib-mplexfns.lua
+share/ion/ioncorelib.lua
+share/ion/menulib.lua
+share/ion/querylib.lua
+share/ion/welcome_message.txt
+share/doc/ion/README
+share/doc/ion/LICENSE
+share/doc/ion/ChangeLog
+@dirrm lib/ion/lc
+@dirrm lib/ion
+@dirrm share/ion
+@dirrm share/doc/ion
@unexec rmdir %D/etc/ion 2>/dev/null || true