aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/ion/files
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-01-20 21:42:25 +0000
committerClive Lin <clive@FreeBSD.org>2001-01-20 21:42:25 +0000
commitef2eabb24aa176f7d25969466d2448c5204fc108 (patch)
tree951e555a0ce8a29dd0ba6326a313f6b95a7f502b /x11-wm/ion/files
parente3d4cd38b1535e2209950563c34093382db81f09 (diff)
Notes
Diffstat (limited to 'x11-wm/ion/files')
-rw-r--r--x11-wm/ion/files/patch-ion-edit9
-rw-r--r--x11-wm/ion/files/patch-ion-view18
-rw-r--r--x11-wm/ion/files/patch-system.mk49
3 files changed, 76 insertions, 0 deletions
diff --git a/x11-wm/ion/files/patch-ion-edit b/x11-wm/ion/files/patch-ion-edit
new file mode 100644
index 000000000000..b1313ff1a951
--- /dev/null
+++ b/x11-wm/ion/files/patch-ion-edit
@@ -0,0 +1,9 @@
+*** scripts/ion-edit.orig Sat Jan 20 01:43:39 2001
+--- scripts/ion-edit Sat Jan 20 01:51:17 2001
+***************
+*** 1,2 ****
+ #!/bin/sh
+! exec run-mailcap --action=edit "$1" > /dev/null
+--- 1,2 ----
+ #!/bin/sh
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
diff --git a/x11-wm/ion/files/patch-ion-view b/x11-wm/ion/files/patch-ion-view
new file mode 100644
index 000000000000..689e8a514757
--- /dev/null
+++ b/x11-wm/ion/files/patch-ion-view
@@ -0,0 +1,18 @@
+*** scripts/ion-view.orig Sat Jan 20 01:44:05 2001
+--- scripts/ion-view Sat Jan 20 01:55:39 2001
+***************
+*** 1,7 ****
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape-remote "$1"
+ else
+! exec run-mailcap --action=view "$1" > /dev/null
+ fi
+
+--- 1,7 ----
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape "$1"
+ else
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
+ fi
diff --git a/x11-wm/ion/files/patch-system.mk b/x11-wm/ion/files/patch-system.mk
new file mode 100644
index 000000000000..b4356a1ab07f
--- /dev/null
+++ b/x11-wm/ion/files/patch-system.mk
@@ -0,0 +1,49 @@
+--- system.mk.orig Thu Dec 28 21:42:07 2000
++++ system.mk Sun Jan 21 05:24:15 2001
+@@ -7,13 +7,13 @@
+ ## Installation paths
+ ##
+
+-PREFIX=/usr/local
++#PREFIX=/usr/local
+
+ # No need to modify these usually
+ BINDIR=$(PREFIX)/bin
+ ETCDIR=$(PREFIX)/etc
+ MANDIR=$(PREFIX)/man
+-DOCDIR=$(PREFIX)/doc
++DOCDIR=$(PREFIX)/share/doc
+ # Not used
+ INCDIR=$(PREFIX)/include
+ LIBDIR=$(PREFIX)/lib
+@@ -23,7 +23,7 @@
+ ## X libraries, includes and options
+ ##
+
+-X11_PREFIX=/usr/X11R6
++X11_PREFIX=$(X11BASE)
+
+ # SunOS/Solaris
+ #X11_PREFIX=/usr/openwin
+@@ -78,8 +78,8 @@
+ -Wparentheses -pedantic-errors -Wuninitialized
+
+
+-CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
+-LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)
++CFLAGS+= $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
++LDFLAGS= $(LIBS) $(EXTRA_LIBS)
+
+
+ ##
+@@ -104,9 +104,9 @@
+ ##
+
+ # Should work almost everywhere
+-INSTALL=install
++#INSTALL=install
+ # On a system with pure BSD install, -c might be preferred
+-#INSTALL=install -c
++INSTALL=install -c
+
+ INSTALLDIR=mkdir -p