aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/jewel
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-05-26 11:33:32 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-05-26 11:33:32 +0000
commitc13c39f312d8f1dfc04de8cb104a27737a5441dd (patch)
treecc236a4d07b679e180c4dd774f517372c384a918 /x11-wm/jewel
parent5edeea482d1578e2f815ae6858046753bd2de64c (diff)
downloadports-c13c39f312d8f1dfc04de8cb104a27737a5441dd.tar.gz
ports-c13c39f312d8f1dfc04de8cb104a27737a5441dd.zip
Notes
Diffstat (limited to 'x11-wm/jewel')
-rw-r--r--x11-wm/jewel/Makefile48
-rw-r--r--x11-wm/jewel/distinfo1
-rw-r--r--x11-wm/jewel/pkg-comment1
-rw-r--r--x11-wm/jewel/pkg-descr4
4 files changed, 54 insertions, 0 deletions
diff --git a/x11-wm/jewel/Makefile b/x11-wm/jewel/Makefile
new file mode 100644
index 000000000000..b4f18c72ab64
--- /dev/null
+++ b/x11-wm/jewel/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: jewel
+# Date created: 2002-05-26
+# Whom: trevor
+# based in part on the aewm++ port by ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jewel
+PORTVERSION= 0.12.26
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.mjr.dsl.pipex.com/comp/
+
+MAINTAINER= trevor@FreeBSD.org
+
+ALL_TARGET= aewm++
+DOCDIR= share/doc/${PORTNAME}
+DOCS= Changelog Changelog.DLR Changelog.jewel INSTALL LICENSE README
+PLIST= ${WRKDIR}/pkg-plist
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+#CXXFLAGS+= -I${X11BASE}/include
+#LIBS+= -L${X11BASE}/lib
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g ; \
+ s,^prefix,#prefix,g ; s,prefix,PREFIX,g ; \
+ s,CC,CXX,g ; s,CFLAGS,CXXFLAGS,g" ${WRKSRC}/Makefile
+
+pre-install:
+ ${ECHO_CMD} bin/jewel > ${PLIST}
+.if !defined(NOPORTDOCS)
+.for ii in ${DOCS}
+ ${ECHO_CMD} ${DOCDIR}/${ii} >> ${PLIST}
+.endfor
+ ${ECHO_CMD} @dirrm ${DOCDIR} >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/aewm++ ${PREFIX}/bin/jewel
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${DOCDIR}
+.for ii in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${ii} ${PREFIX}/${DOCDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/jewel/distinfo b/x11-wm/jewel/distinfo
new file mode 100644
index 000000000000..b203678f16b4
--- /dev/null
+++ b/x11-wm/jewel/distinfo
@@ -0,0 +1 @@
+MD5 (jewel-0.12.26.tar.gz) = 1deb35a25b9e1efa920bd5def653a96f
diff --git a/x11-wm/jewel/pkg-comment b/x11-wm/jewel/pkg-comment
new file mode 100644
index 000000000000..f4301a38cff3
--- /dev/null
+++ b/x11-wm/jewel/pkg-comment
@@ -0,0 +1 @@
+Window manager based on aewm++
diff --git a/x11-wm/jewel/pkg-descr b/x11-wm/jewel/pkg-descr
new file mode 100644
index 000000000000..0950872b608c
--- /dev/null
+++ b/x11-wm/jewel/pkg-descr
@@ -0,0 +1,4 @@
+Jewel is a window manager based upon aewm++. It is meant as a
+platform for more vigorous addition of new features.
+
+WWW: http://www.mjr.dsl.pipex.com/xwinman.html#jewel