aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/labwc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-04 00:08:23 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-04 00:08:23 +0000
commit098a27ba3ab18424137e9ef428bb343eb8d023ba (patch)
tree92059d4d3680a793fcd3a879d3bea58b22142af0 /x11-wm/labwc
parent66de48bd335a5a0a9c1a8627497eb95ff8a18f8f (diff)
downloadports-098a27ba3ab18424137e9ef428bb343eb8d023ba.tar.gz
ports-098a27ba3ab18424137e9ef428bb343eb8d023ba.zip
Notes
Diffstat (limited to 'x11-wm/labwc')
-rw-r--r--x11-wm/labwc/Makefile55
-rw-r--r--x11-wm/labwc/distinfo3
-rw-r--r--x11-wm/labwc/pkg-descr14
3 files changed, 72 insertions, 0 deletions
diff --git a/x11-wm/labwc/Makefile b/x11-wm/labwc/Makefile
new file mode 100644
index 000000000000..6157098ed4ce
--- /dev/null
+++ b/x11-wm/labwc/Makefile
@@ -0,0 +1,55 @@
+# $FreeBSD$
+
+PORTNAME= labwc
+PORTVERSION= s20210303
+CATEGORIES= x11-wm
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Openbox alternative for Wayland
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols \
+ wlroots>=0.11.0:x11-toolkits/wlroots
+LIB_DEPENDS= libwayland-server.so:graphics/wayland \
+ libwlroots.so:x11-toolkits/wlroots \
+ libinput.so:x11/libinput \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gnome meson pkgconfig xorg
+USE_GITHUB= yes
+GH_TAGNAME= 2738ff2
+USE_GNOME= cairo libxml2 pango
+USE_XORG= pixman
+GH_ACCOUNT= johanmalm
+PLIST_FILES= "${MAYBE_SUID}bin/${PORTNAME}"
+
+OPTIONS_DEFINE= MANPAGES SUID X11
+OPTIONS_DEFAULT=MANPAGES SUID X11
+
+MANPAGES_BUILD_DEPENDS= pandoc:textproc/hs-pandoc
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz \
+ man/man5/${PORTNAME}-actions.5.gz \
+ man/man5/${PORTNAME}-config.5.gz \
+ man/man5/${PORTNAME}-theme.5.gz
+
+SUID_DESC= setuid bit on "${PORTNAME}" binary (to claim DRM without seatd/console-kit-daemon)
+SUID_VARS= MAYBE_SUID="@(,,4755) "
+
+X11_MESON_ENABLED= xwayland
+
+post-patch:
+# Respect PREFIX for system-wide config
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
+ ${WRKSRC}/docs/${PORTNAME}-config.5.md \
+ ${WRKSRC}/src/common/dir.c
+
+post-patch-MANPAGES-off:
+ @${REINPLACE_CMD} "s/'pandoc/&-disabled/" ${WRKSRC}/docs/meson.build
+
+post-install-MANPAGES-on:
+ @${MV} ${STAGEDIR}${PREFIX}/man/man*.1/* ${STAGEDIR}${PREFIX}/man/man1
+ @${MV} ${STAGEDIR}${PREFIX}/man/man*.5/* ${STAGEDIR}${PREFIX}/man/man5
+ @${FIND} ${STAGEDIR}${PREFIX}/man -type d -empty -delete
+
+.include <bsd.port.mk>
diff --git a/x11-wm/labwc/distinfo b/x11-wm/labwc/distinfo
new file mode 100644
index 000000000000..3cd8185f9b14
--- /dev/null
+++ b/x11-wm/labwc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614806392
+SHA256 (johanmalm-labwc-s20210303-2738ff2_GH0.tar.gz) = 7b5e89f15134cc60f624b3eb509be7af3a34c3adb8795b5655ce10206af4dac5
+SIZE (johanmalm-labwc-s20210303-2738ff2_GH0.tar.gz) = 59295
diff --git a/x11-wm/labwc/pkg-descr b/x11-wm/labwc/pkg-descr
new file mode 100644
index 000000000000..8a9cd8e902eb
--- /dev/null
+++ b/x11-wm/labwc/pkg-descr
@@ -0,0 +1,14 @@
+Labwc is a WIP free, wlroots-based stacking compositor for Wayland.
+
+It has the following aims:
+
+- Be light-weight, small and fast
+- Have the look and feel of openbox albeit with a smaller feature set
+- Where practicable, use clients to show wall-paper, take screenshots,
+ and so on
+- Stay in keeping with wlroots and sway in terms of approach and
+ coding style
+
+It is in early development, so expect bugs and missing features.
+
+WWW: https://github.com/johanmalm/labwc