aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/libcompizconfig
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2007-09-06 19:33:16 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2007-09-06 19:33:16 +0000
commitc187b6c278a0f7987a7ec5a06737a5c89198fcd0 (patch)
tree5c4bc3778be4af4bfeced8d49ad545c883002091 /x11-wm/libcompizconfig
parentcf6a91264368992a62840bb605a8a77b70ef939b (diff)
downloadports-c187b6c278a0f7987a7ec5a06737a5c89198fcd0.tar.gz
ports-c187b6c278a0f7987a7ec5a06737a5c89198fcd0.zip
Libcompizconfig is an alternative configuration system for
compiz and provides the following features: - Automatic plugin list generation. - Import/Export of the current configuration. - Configuration profiles. - Parsing of Compiz metadata files to provide an easy to use API for configuration managers. - Conflict handling for plugins and actions. - Support for different configuration storage backends. - Desktop environment integration. If a backend provides desktop environment integration, then Compiz will share the keybindings and settings with the default desktop environment window manager like metacity or kwin. - Its own Compiz configuration plugin "ccp" to provide all features of libcompizconfig with compiz. WWW: http://forums.compiz-fusion.org/ PR: ports/116136 Submitted by: Robert Noland <rnoland@2hip.net>
Notes
Notes: svn path=/head/; revision=198924
Diffstat (limited to 'x11-wm/libcompizconfig')
-rw-r--r--x11-wm/libcompizconfig/Makefile41
-rw-r--r--x11-wm/libcompizconfig/distinfo3
-rw-r--r--x11-wm/libcompizconfig/files/patch-src-main.c22
-rw-r--r--x11-wm/libcompizconfig/pkg-descr17
-rw-r--r--x11-wm/libcompizconfig/pkg-plist19
5 files changed, 102 insertions, 0 deletions
diff --git a/x11-wm/libcompizconfig/Makefile b/x11-wm/libcompizconfig/Makefile
new file mode 100644
index 000000000000..240ddd7a740f
--- /dev/null
+++ b/x11-wm/libcompizconfig/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: libcompizconfig
+# Date created: 2007-08-16
+# Whom: Robert Noland <rnoland@2hip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libcompizconfig
+PORTVERSION= 0.5.2
+#PORTREVISION= 0
+CATEGORIES= x11-wm
+MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= An alternative configuration system for Compiz
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
+
+USE_GNOME= gnomehack intltool libxml2
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/src/main.c \
+ ${WRKSRC}/src/lists.c \
+ ${WRKSRC}/src/compiz.c \
+ ${WRKSRC}/src/filewatch.c \
+ ${WRKSRC}/src/ini.c \
+ ${WRKSRC}/backend/ini.c
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/libcompizconfig/distinfo b/x11-wm/libcompizconfig/distinfo
new file mode 100644
index 000000000000..5320949fe470
--- /dev/null
+++ b/x11-wm/libcompizconfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (libcompizconfig-0.5.2.tar.bz2) = 75b523f00b92986b4b6df0544112b141
+SHA256 (libcompizconfig-0.5.2.tar.bz2) = a84382c5486c36e2ab78b9e9b3fcf2fc1919170d200032cf594abe5ca374a103
+SIZE (libcompizconfig-0.5.2.tar.bz2) = 318788
diff --git a/x11-wm/libcompizconfig/files/patch-src-main.c b/x11-wm/libcompizconfig/files/patch-src-main.c
new file mode 100644
index 000000000000..ece14e25a2f4
--- /dev/null
+++ b/x11-wm/libcompizconfig/files/patch-src-main.c
@@ -0,0 +1,22 @@
+--- src/main.c.orig 2007-08-12 15:59:57.000000000 -0400
++++ src/main.c 2007-09-05 11:38:34.000000000 -0400
+@@ -550,7 +550,8 @@
+ asprintf (&dlname, "%s/.compizconfig/backends/lib%s.so",
+ home, backend);
+ dlerror ();
+- dlhand = dlopen (dlname, RTLD_NOW | RTLD_NODELETE | RTLD_GLOBAL);
++ dlhand = dlopen (dlname, RTLD_NOW | RTLD_GLOBAL);
++ dlopen (dlname, RTLD_NOW | RTLD_GLOBAL);
+ err = dlerror ();
+ }
+
+@@ -559,7 +560,8 @@
+ free (dlname);
+ asprintf (&dlname, "%s/compizconfig/backends/lib%s.so",
+ LIBDIR, backend);
+- dlhand = dlopen (dlname, RTLD_NOW | RTLD_NODELETE | RTLD_GLOBAL);
++ dlhand = dlopen (dlname, RTLD_NOW | RTLD_GLOBAL);
++ dlopen (dlname, RTLD_NOW | RTLD_GLOBAL);
+ err = dlerror ();
+ }
+
diff --git a/x11-wm/libcompizconfig/pkg-descr b/x11-wm/libcompizconfig/pkg-descr
new file mode 100644
index 000000000000..96f07fcaa5a7
--- /dev/null
+++ b/x11-wm/libcompizconfig/pkg-descr
@@ -0,0 +1,17 @@
+Libcompizconfig is an alternative configuration system for
+compiz and provides the following features:
+ - Automatic plugin list generation.
+ - Import/Export of the current configuration.
+ - Configuration profiles.
+ - Parsing of Compiz metadata files to provide an easy to use API for
+ configuration managers.
+ - Conflict handling for plugins and actions.
+ - Support for different configuration storage backends.
+ - Desktop environment integration. If a backend provides desktop
+ environment integration, then Compiz will share the keybindings
+ and settings with the default desktop environment window
+ manager like metacity or kwin.
+ - Its own Compiz configuration plugin "ccp" to provide all features
+ of libcompizconfig with compiz.
+
+WWW: http://forums.compiz-fusion.org/
diff --git a/x11-wm/libcompizconfig/pkg-plist b/x11-wm/libcompizconfig/pkg-plist
new file mode 100644
index 000000000000..eb1ce06d9f3c
--- /dev/null
+++ b/x11-wm/libcompizconfig/pkg-plist
@@ -0,0 +1,19 @@
+@comment $FreeBSD$
+include/compizconfig/ccs.h
+include/compizconfig/ccs-backend.h
+lib/libcompizconfig.so.0
+lib/libcompizconfig.so
+lib/libcompizconfig.la
+lib/libcompizconfig.a
+lib/compizconfig/backends/libini.so
+lib/compizconfig/backends/libini.la
+lib/compizconfig/backends/libini.a
+lib/compiz/libccp.so
+lib/compiz/libccp.la
+lib/compiz/libccp.a
+libdata/pkgconfig/libcompizconfig.pc
+share/compizconfig/global.xml
+@dirrmtry share/compizconfig
+@dirrmtry lib/compizconfig/backends
+@dirrmtry lib/compizconfig
+@dirrmtry include/compizconfig