aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/libepplet/Makefile
diff options
context:
space:
mode:
authorKelly Yancey <kbyanc@FreeBSD.org>2000-07-18 05:38:04 +0000
committerKelly Yancey <kbyanc@FreeBSD.org>2000-07-18 05:38:04 +0000
commit682c6fefc935fa795987d027966da46bc015e7c5 (patch)
tree63197687852d1203da194566b38cf4878d3a884b /x11-wm/libepplet/Makefile
parent72efdf36dff00f26695e98af22d594d273284dd4 (diff)
downloadports-682c6fefc935fa795987d027966da46bc015e7c5.tar.gz
ports-682c6fefc935fa795987d027966da46bc015e7c5.zip
Notes
Diffstat (limited to 'x11-wm/libepplet/Makefile')
-rw-r--r--x11-wm/libepplet/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/libepplet/Makefile b/x11-wm/libepplet/Makefile
new file mode 100644
index 000000000000..dcbf26071c84
--- /dev/null
+++ b/x11-wm/libepplet/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libepplet
+# Date created: 18 October 1999
+# Whom: Kelly Yancey <kbyanc@posi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libepplet
+PORTVERSION= 0.5
+CATEGORIES= x11-wm devel
+MASTER_SITES= ftp://ftp.enlightenment.org/e/epplets/
+DISTNAME= epplet-base-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+WRKSRC= ${WRKDIR}/Epplets-0.5
+
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-fsstd
+CONFIGURE_ENV= EROOT=${X11BASE}/share/enlightenment \
+ EBIN=${X11BASE}/bin \
+ LIBS="-L${LOCALBASE}/lib -lintl" \
+ X_LIBS="-lxpg4"
+
+MAKE_ENV= ${ECHO} -n; cd ${WRKSRC}/api;
+
+.include <bsd.port.mk>