aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/mcwm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-10 08:01:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-10 08:01:18 +0000
commit4426a3162c4b1f335f7acbc65f565cbc287792c6 (patch)
tree2aa105f11e6508a193fad35fcd8a12a95ac3e4b1 /x11-wm/mcwm
parent8f348ee109d2f9b0169a595fb1fd7e8fe5a2c47b (diff)
downloadports-4426a3162c4b1f335f7acbc65f565cbc287792c6.tar.gz
ports-4426a3162c4b1f335f7acbc65f565cbc287792c6.zip
Notes
Diffstat (limited to 'x11-wm/mcwm')
-rw-r--r--x11-wm/mcwm/Makefile12
-rw-r--r--x11-wm/mcwm/distinfo4
-rw-r--r--x11-wm/mcwm/files/patch-Makefile26
-rw-r--r--x11-wm/mcwm/files/patch-mcwm.c164
4 files changed, 8 insertions, 198 deletions
diff --git a/x11-wm/mcwm/Makefile b/x11-wm/mcwm/Makefile
index 6d4a8f3417f7..5d86fe6f8152 100644
--- a/x11-wm/mcwm/Makefile
+++ b/x11-wm/mcwm/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mcwm
-PORTVERSION= 20111124
-PORTREVISION= 2
+PORTVERSION= 20130209
CATEGORIES= x11-wm
MASTER_SITES= http://hack.org/mc/hacks/mcwm/
@@ -22,8 +21,8 @@ MAKE_JOBS_SAFE= yes
USE_XORG= x11 xrandr
USE_BZIP2= yes
-MAN1= mcwm.1
-PLIST_FILES= bin/mcwm
+MAN1= mcwm.1 hidden.1
+PLIST_FILES= bin/mcwm bin/hidden
PORTDOCS= README NEWS
pre-everything::
@@ -35,8 +34,6 @@ post-extract:
@${ECHO_MSG} "creating config.h from ${MCWM_CONF}"
@${CP} ${MCWM_CONF} ${WRKSRC}/config.h
.endif
-
-post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
${WRKSRC}/Makefile
@@ -44,6 +41,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/hidden ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/hidden.man \
+ ${MAN1PREFIX}/man/man1/hidden.1
.include <bsd.port.options.mk>
diff --git a/x11-wm/mcwm/distinfo b/x11-wm/mcwm/distinfo
index 083f79554e7f..82ebe2b96e7a 100644
--- a/x11-wm/mcwm/distinfo
+++ b/x11-wm/mcwm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mcwm-20111124.tar.bz2) = 80b52eda2d881c2d0db347e764b8470acaea51c1307504d7836ee7f8de30b836
-SIZE (mcwm-20111124.tar.bz2) = 27982
+SHA256 (mcwm-20130209.tar.bz2) = ad32d729d61537e20fb17fdf1e31097869df844d13ab32de1c3f41cf9bb71fc2
+SIZE (mcwm-20130209.tar.bz2) = 31429
diff --git a/x11-wm/mcwm/files/patch-Makefile b/x11-wm/mcwm/files/patch-Makefile
deleted file mode 100644
index 5b05b01f3a72..000000000000
--- a/x11-wm/mcwm/files/patch-Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-$FreeBSD$
-
-Stops clobbering CC, CFLAGS, LDFLAGS, forcing -O2 and adds
--lxcb-property to LDFLAGS to fix GCC46 build
-
-http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/163667
-
---- Makefile.orig 2011-12-28 14:56:20.865676731 +0000
-+++ Makefile 2011-12-28 14:58:52.600677341 +0000
-@@ -3,13 +3,11 @@
- SRC=mcwm.c list.c config.h events.h list.h
- DISTFILES=LICENSE Makefile NEWS README TODO WISHLIST mcwm.man $(SRC)
-
--CC=gcc
--CFLAGS=-g -std=c99 -Wall -Wextra -O2 -I/usr/local/include #-DDEBUG #-DDMALLOC
--LDFLAGS=-L/usr/local/lib -lxcb -lxcb-randr -lxcb-keysyms -lxcb-icccm \
-- -lxcb-atom #-ldmalloc
-+CFLAGS+=-g -std=c99 -Wall -Wextra -I/usr/local/include #-DDEBUG #-DDMALLOC
-+LDFLAGS+=-L/usr/local/lib -lxcb -lxcb-randr -lxcb-keysyms -lxcb-icccm \
-+ -lxcb-util #-ldmalloc
-
- RM=/bin/rm
--PREFIX=/usr/local
-
- TARGETS=mcwm
- OBJS=mcwm.o list.o
diff --git a/x11-wm/mcwm/files/patch-mcwm.c b/x11-wm/mcwm/files/patch-mcwm.c
deleted file mode 100644
index 4d5936cd3a24..000000000000
--- a/x11-wm/mcwm/files/patch-mcwm.c
+++ /dev/null
@@ -1,164 +0,0 @@
-diff --git a/mcwm.c b/mcwm.c
-index 0613c9f..04a7a41 100644
---- mcwm.c
-+++ mcwm.c
-@@ -45,6 +45,10 @@
-
- #include <X11/keysym.h>
-
-+#include <xcb/xproto.h>
-+#include <xcb/xcb_util.h>
-+#include <xcb/xcb_ewmh.h>
-+
- #ifdef DEBUG
- #include "events.h"
- #endif
-@@ -503,7 +507,7 @@ void setwmdesktop(xcb_drawable_t win, uint32_t ws)
- PDEBUG("Changing _NET_WM_DESKTOP on window %d to %d\n", win, ws);
-
- xcb_change_property(conn, XCB_PROP_MODE_REPLACE, win,
-- atom_desktop, CARDINAL, 32, 1,
-+ atom_desktop, XCB_ATOM_CARDINAL, 32, 1,
- &ws);
- }
-
-@@ -521,7 +525,7 @@ int32_t getwmdesktop(xcb_drawable_t win)
- uint32_t *wsp;
- uint32_t ws;
-
-- cookie = xcb_get_any_property(conn, false, win, atom_desktop,
-+ cookie = xcb_get_property(conn, false, win, atom_desktop,XCB_GET_PROPERTY_TYPE_ANY, 0,
- sizeof (int32_t));
-
- reply = xcb_get_property_reply(conn, cookie, NULL);
-@@ -1136,8 +1140,8 @@ struct client *setupwin(xcb_window_t win)
- /*
- * Get the window's incremental size step, if any.
- */
-- if (!xcb_get_wm_normal_hints_reply(
-- conn, xcb_get_wm_normal_hints_unchecked(
-+ if (!xcb_icccm_get_wm_normal_hints_reply(
-+ conn, xcb_icccm_get_wm_normal_hints_unchecked(
- conn, win), &hints, NULL))
- {
- PDEBUG("Couldn't get size hints.\n");
-@@ -1147,25 +1151,25 @@ struct client *setupwin(xcb_window_t win)
- * The user specified the position coordinates. Remember that so
- * we can use geometry later.
- */
-- if (hints.flags & XCB_SIZE_HINT_US_POSITION)
-+ if (hints.flags & XCB_ICCCM_SIZE_HINT_US_POSITION)
- {
- client->usercoord = true;
- }
-
-- if (hints.flags & XCB_SIZE_HINT_P_MIN_SIZE)
-+ if (hints.flags & XCB_ICCCM_SIZE_HINT_P_MIN_SIZE)
- {
- client->min_width = hints.min_width;
- client->min_height = hints.min_height;
- }
-
-- if (hints.flags & XCB_SIZE_HINT_P_MAX_SIZE)
-+ if (hints.flags & XCB_ICCCM_SIZE_HINT_P_MAX_SIZE)
- {
-
- client->max_width = hints.max_width;
- client->max_height = hints.max_height;
- }
-
-- if (hints.flags & XCB_SIZE_HINT_P_RESIZE_INC)
-+ if (hints.flags & XCB_ICCCM_SIZE_HINT_P_RESIZE_INC)
- {
- client->width_inc = hints.width_inc;
- client->height_inc = hints.height_inc;
-@@ -1174,7 +1178,7 @@ struct client *setupwin(xcb_window_t win)
- client->height_inc);
- }
-
-- if (hints.flags & XCB_SIZE_HINT_BASE_SIZE)
-+ if (hints.flags & XCB_ICCCM_SIZE_HINT_BASE_SIZE)
- {
- client->base_width = hints.base_width;
- client->base_height = hints.base_height;
-@@ -2823,7 +2827,7 @@ void botright(void)
- void deletewin(void)
- {
- xcb_get_property_cookie_t cookie;
-- xcb_get_wm_protocols_reply_t protocols;
-+ xcb_icccm_get_wm_protocols_reply_t protocols;
- bool use_delete = false;
- uint32_t i;
-
-@@ -2833,14 +2837,14 @@ void deletewin(void)
- }
-
- /* Check if WM_DELETE is supported. */
-- cookie = xcb_get_wm_protocols_unchecked(conn, focuswin->id, wm_protocols);
-- if (xcb_get_wm_protocols_reply(conn, cookie, &protocols, NULL) == 1) {
-+ cookie = xcb_icccm_get_wm_protocols_unchecked(conn, focuswin->id, wm_protocols);
-+ if (xcb_icccm_get_wm_protocols_reply(conn, cookie, &protocols, NULL) == 1) {
- for (i = 0; i < protocols.atoms_len; i++)
- if (protocols.atoms[i] == wm_delete_window)
- use_delete = true;
- }
-
-- xcb_get_wm_protocols_reply_wipe(&protocols);
-+ xcb_icccm_get_wm_protocols_reply_wipe(&protocols);
-
- if (use_delete)
- {
-@@ -4082,9 +4086,50 @@ int main(int argc, char **argv)
- conf.fixedcol = getcolor(fixedcol);
-
- /* Get some atoms. */
-- atom_desktop = xcb_atom_get(conn, "_NET_WM_DESKTOP");
-- wm_delete_window = xcb_atom_get(conn, "WM_DELETE_WINDOW");
-- wm_protocols = xcb_atom_get(conn, "WM_PROTOCOLS");
-+// atom_desktop = xcb_atom_get(conn, "_NET_WM_DESKTOP");
-+// wm_delete_window = xcb_atom_get(conn, "WM_DELETE_WINDOW");
-+// wm_protocols = xcb_atom_get(conn, "WM_PROTOCOLS");
-+
-+ char *atom_name;
-+ xcb_intern_atom_cookie_t cookie_desktop;
-+ xcb_intern_atom_cookie_t cookie_delete_window;
-+ xcb_intern_atom_cookie_t cookie_protocols;
-+ xcb_intern_atom_reply_t *rep;
-+
-+ atom_name = "_NET_WM_DESKTOP";
-+ cookie_desktop = xcb_intern_atom (conn,
-+ 0,
-+ strlen (atom_name),
-+ atom_name);
-+ rep = xcb_intern_atom_reply (conn,
-+ cookie_desktop,
-+ NULL);
-+ atom_desktop = rep->atom;
-+ free (rep);
-+
-+
-+ atom_name = "WM_DELETE_WINDOW";
-+ cookie_delete_window = xcb_intern_atom (conn,
-+ 0,
-+ strlen (atom_name),
-+ atom_name);
-+ rep = xcb_intern_atom_reply (conn,
-+ cookie_delete_window,
-+ NULL);
-+ wm_delete_window = rep->atom;
-+ free (rep);
-+
-+ atom_name = "WM_PROTOCOLS";
-+ cookie_protocols = xcb_intern_atom (conn,
-+ 0,
-+ strlen (atom_name),
-+ atom_name);
-+ rep = xcb_intern_atom_reply (conn,
-+ cookie_protocols,
-+ NULL);
-+ wm_protocols = rep->atom;
-+ free (rep);
-+
-
- /* Check for RANDR extension and configure. */
- randrbase = setuprandr();