aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/metacity
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-06 18:12:49 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-06 18:12:49 +0000
commit98e2e208558ab28814cd63fd6ac5ec9f34cb850b (patch)
tree53334d24877cdc581bf7618ba7aea71819b1658b /x11-wm/metacity
parentaa6975c85b1fe4600dd6bf4aa5bf43707d9a2de0 (diff)
downloadports-98e2e208558ab28814cd63fd6ac5ec9f34cb850b.tar.gz
ports-98e2e208558ab28814cd63fd6ac5ec9f34cb850b.zip
Notes
Diffstat (limited to 'x11-wm/metacity')
-rw-r--r--x11-wm/metacity/Makefile1
-rw-r--r--x11-wm/metacity/files/patch-src_screen.c44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 4416f3bb7533..5c7d9794dc9a 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -8,6 +8,7 @@
PORTNAME= metacity
PORTVERSION= 2.14.3
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/x11-wm/metacity/files/patch-src_screen.c b/x11-wm/metacity/files/patch-src_screen.c
new file mode 100644
index 000000000000..70c88332d13e
--- /dev/null
+++ b/x11-wm/metacity/files/patch-src_screen.c
@@ -0,0 +1,44 @@
+--- src/screen.c.orig Sat May 6 19:21:53 2006
++++ src/screen.c Sat May 6 19:22:13 2006
+@@ -187,6 +187,20 @@
+ {
+ MetaDisplay *display;
+
++ {
++ GList *tmp;
++
++ tmp = screen->workspaces;
++ while (tmp != NULL)
++ {
++ MetaWorkspace *space = tmp->data;
++
++ meta_workspace_invalidate_work_area (space);
++
++ tmp = tmp->next;
++ }
++ }
++
+ display = screen->display;
+
+ if (screen->xinerama_infos)
+@@ -348,20 +362,6 @@
+
+ g_assert (screen->n_xinerama_infos > 0);
+ g_assert (screen->xinerama_infos != NULL);
+-
+- {
+- GList *tmp;
+-
+- tmp = screen->workspaces;
+- while (tmp != NULL)
+- {
+- MetaWorkspace *space = tmp->data;
+-
+- meta_workspace_invalidate_work_area (space);
+-
+- tmp = tmp->next;
+- }
+- }
+ }
+
+ MetaScreen*