aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/mutter
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11-wm/mutter
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'x11-wm/mutter')
-rw-r--r--x11-wm/mutter/Makefile66
-rw-r--r--x11-wm/mutter/distinfo4
-rw-r--r--x11-wm/mutter/files/extra-488dd0b245
-rw-r--r--x11-wm/mutter/files/patch-src_Makefile.in11
-rw-r--r--x11-wm/mutter/files/patch-src_core_main.c14
-rw-r--r--x11-wm/mutter/pkg-descr2
-rw-r--r--x11-wm/mutter/pkg-plist176
7 files changed, 393 insertions, 125 deletions
diff --git a/x11-wm/mutter/Makefile b/x11-wm/mutter/Makefile
index cd45868e2b61..ac5418961e15 100644
--- a/x11-wm/mutter/Makefile
+++ b/x11-wm/mutter/Makefile
@@ -1,38 +1,68 @@
# Created by: Pawel Worach <pawel.worach@gmail.com>
# $FreeBSD$
-# $MCom: ports/x11-wm/mutter/Makefile,v 1.14 2010/06/29 21:14:07 kwm Exp $
+# $MCom: ports/trunk/x11-wm/mutter/Makefile 20040 2014-11-03 17:21:59Z kwm $
PORTNAME= mutter
-PORTVERSION= 2.31.2
-PORTREVISION= 5
+PORTVERSION= 3.14.1.5
CATEGORIES= x11-wm
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Window and compositing manager based on Clutter
-BUILD_DEPENDS= zenity:${PORTSDIR}/x11/zenity
+BUILD_DEPENDS= zenity>=3.0.0:${PORTSDIR}/x11/zenity \
+ gsettings-desktop-schemas>=3.4.0:${PORTSDIR}/devel/gsettings-desktop-schemas
LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
- libclutter-glx-1.0.so:${PORTSDIR}/graphics/clutter \
- libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
-RUN_DEPENDS= zenity:${PORTSDIR}/x11/zenity
+ libclutter-1.0.so:${PORTSDIR}/graphics/clutter \
+ libxkbcommon.so:${PORTSDIR}/x11/libxkbcommon \
+ libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
+ libupower-glib.so:${PORTSDIR}/sysutils/upower
+RUN_DEPENDS= zenity>=3.0.0:${PORTSDIR}/x11/zenity \
+ gsettings-desktop-schemas>=3.4.0:${PORTSDIR}/devel/gsettings-desktop-schemas
-USE_XORG= x11 xext xrandr xcomposite xcursor xinerama ice sm
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack \
+ introspection:build
+USE_XORG= x11 xext xrandr xcomposite xcursor xinerama ice sm xfixes \
+ xrender xdamage
+USE_GL= gbm
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_GNOME= gnomeprefix intlhack gtk20 gconf2
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -fno-omit-frame-pointer
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-compile-warnings=maximum
+INSTALL_TARGET= install-strip
+GLIB_SCHEMAS= org.gnome.mutter.gschema.xml \
+ org.gnome.mutter.wayland.gschema.xml
+
+PLIST_SUB= VERSION=${PORTVERSION:R}
+
+.include <bsd.port.options.mk>
+
+# borrowed from graphics/libGL to see where Mesa 10.3 is available.
+# hw context support in the i915kms driver
+.if ${OPSYS} == FreeBSD && \
+ (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100035 || \
+ ${OSVERSION} < 1000717)
+_OLD_MESA=1
+.endif
+
+.if ${OPSYS} == DragonFly && ${DFLYVERSION} >= 300901
+_OLD_MESA=1
+.endif
-GCONF_SCHEMAS= mutter.schemas
+.if defined(_OLD_MESA)
+EXTRA_PATCHES+= ${FILESDIR}/extra-488dd0b
+.endif
+# remove the gbm sed line if gbm < 10.3
post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} '/^mutter_LDADD =/s/$$/ -lgmodule-2.0/' \
- ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-Wcast-align||g' \
+ ${WRKSRC}/configure
+.if defined(_OLD_MESA)
+ @${REINPLACE_CMD} -e 's|gbm >= 10.3|gbm|g' \
+ ${WRKSRC}/configure
+.endif
.include <bsd.port.mk>
diff --git a/x11-wm/mutter/distinfo b/x11-wm/mutter/distinfo
index 5a0680d71ec6..ba4619050c99 100644
--- a/x11-wm/mutter/distinfo
+++ b/x11-wm/mutter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/mutter-2.31.2.tar.bz2) = 7267018c2eb28213748810de7e1ccf6d4f059e8ab593ec335234588d0037578c
-SIZE (gnome2/mutter-2.31.2.tar.bz2) = 1983139
+SHA256 (gnome3/mutter-3.14.1.5.tar.xz) = bfc1e30f94cb7d057b94ac651cbfff24fb25e9d6617c492b68509e5c638f5114
+SIZE (gnome3/mutter-3.14.1.5.tar.xz) = 1607912
diff --git a/x11-wm/mutter/files/extra-488dd0b b/x11-wm/mutter/files/extra-488dd0b
new file mode 100644
index 000000000000..ccf95b149e9d
--- /dev/null
+++ b/x11-wm/mutter/files/extra-488dd0b
@@ -0,0 +1,245 @@
+Revert the following commit, so we can lower the gbm requirements.
+Because it needs gbm 10.3+
+
+This exposes a bug that the cursor isn't rendered correctly on newer
+Radeon cards that support 256x256 cursors. But we don't support those
+really yet.
+
+From 488dd0b402dc8c56a70f995a7456c2ff511a818b Mon Sep 17 00:00:00 2001
+From: "Jasper St. Pierre" <jstpierre@mecheye.net>
+Date: Wed, 24 Sep 2014 15:40:09 -0600
+Subject: Support for hardware cursor sizes other than 64x64 on wayland
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Use the new DRM capabilities to figure out the correct cursor size, and
+make sure that matches instead of hardcoding 64x64. This fixes incorrect
+rendering on some newer AMD cards that support 256x256 cursors.
+
+Based heavily on a patch by:
+Alvaro Fernando GarcĂ­a <alvarofernandogarcia@gmail.com>
+
+
+--- ./src/backends/native/meta-cursor-renderer-native.c.orig 2014-10-02 16:29:20.000000000 +0200
++++ ./src/backends/native/meta-cursor-renderer-native.c 2014-11-03 17:38:11.528443462 +0100
+@@ -27,27 +27,16 @@
+ #include "meta-cursor-renderer-native.h"
+
+ #include <gbm.h>
+-#include <xf86drm.h>
+
+ #include "meta-cursor-private.h"
+ #include "meta-monitor-manager.h"
+
+-#ifndef DRM_CAP_CURSOR_WIDTH
+-#define DRM_CAP_CURSOR_WIDTH 0x8
+-#endif
+-#ifndef DRM_CAP_CURSOR_HEIGHT
+-#define DRM_CAP_CURSOR_HEIGHT 0x9
+-#endif
+-
+ struct _MetaCursorRendererNativePrivate
+ {
+ gboolean has_hw_cursor;
+
+ int drm_fd;
+ struct gbm_device *gbm;
+-
+- uint64_t cursor_width;
+- uint64_t cursor_height;
+ };
+ typedef struct _MetaCursorRendererNativePrivate MetaCursorRendererNativePrivate;
+
+@@ -82,13 +71,17 @@ set_crtc_cursor (MetaCursorRendererNativ
+ {
+ struct gbm_bo *bo;
+ union gbm_bo_handle handle;
++ int width, height;
+ int hot_x, hot_y;
+
+ bo = meta_cursor_reference_get_gbm_bo (cursor, &hot_x, &hot_y);
+
+ handle = gbm_bo_get_handle (bo);
++ width = gbm_bo_get_width (bo);
++ height = gbm_bo_get_height (bo);
++
+ drmModeSetCursor2 (priv->drm_fd, crtc->crtc_id, handle.u32,
+- priv->cursor_width, priv->cursor_height, hot_x, hot_y);
++ width, height, hot_x, hot_y);
+ }
+ else
+ {
+@@ -193,19 +186,6 @@ meta_cursor_renderer_native_init (MetaCu
+ CoglRenderer *cogl_renderer = cogl_display_get_renderer (cogl_context_get_display (ctx));
+ priv->drm_fd = cogl_kms_renderer_get_kms_fd (cogl_renderer);
+ priv->gbm = gbm_create_device (priv->drm_fd);
+-
+- uint64_t width, height;
+- if (drmGetCap (priv->drm_fd, DRM_CAP_CURSOR_WIDTH, &width) == 0 &&
+- drmGetCap (priv->drm_fd, DRM_CAP_CURSOR_HEIGHT, &height) == 0)
+- {
+- priv->cursor_width = width;
+- priv->cursor_height = height;
+- }
+- else
+- {
+- priv->cursor_width = 64;
+- priv->cursor_height = 64;
+- }
+ }
+ #endif
+ }
+@@ -219,16 +199,6 @@ meta_cursor_renderer_native_get_gbm_devi
+ }
+
+ void
+-meta_cursor_renderer_native_get_cursor_size (MetaCursorRendererNative *native,
+- uint64_t *width, uint64_t *height)
+-{
+- MetaCursorRendererNativePrivate *priv = meta_cursor_renderer_native_get_instance_private (native);
+-
+- *width = priv->cursor_width;
+- *height = priv->cursor_height;
+-}
+-
+-void
+ meta_cursor_renderer_native_force_update (MetaCursorRendererNative *native)
+ {
+ update_hw_cursor (native, TRUE);
+--- ./src/backends/native/meta-cursor-renderer-native.h.orig 2014-10-02 16:29:20.000000000 +0200
++++ ./src/backends/native/meta-cursor-renderer-native.h 2014-11-03 17:38:11.529443324 +0100
+@@ -50,7 +50,6 @@ struct _MetaCursorRendererNativeClass
+ GType meta_cursor_renderer_native_get_type (void) G_GNUC_CONST;
+
+ struct gbm_device * meta_cursor_renderer_native_get_gbm_device (MetaCursorRendererNative *renderer);
+-void meta_cursor_renderer_native_get_cursor_size (MetaCursorRendererNative *native, uint64_t *width, uint64_t *height);
+ void meta_cursor_renderer_native_force_update (MetaCursorRendererNative *renderer);
+
+ #endif /* META_CURSOR_RENDERER_NATIVE_H */
+--- ./src/backends/meta-cursor.c.orig 2014-10-30 11:57:01.000000000 +0100
++++ ./src/backends/meta-cursor.c 2014-11-03 17:38:11.526443521 +0100
+@@ -140,55 +140,34 @@ load_cursor_on_client (MetaCursor cursor
+ }
+
+ static void
+-get_hardware_cursor_size (uint64_t *cursor_width, uint64_t *cursor_height)
+-{
+-#ifdef HAVE_NATIVE_BACKEND
+- MetaBackend *meta_backend = meta_get_backend ();
+- MetaCursorRenderer *renderer = meta_backend_get_cursor_renderer (meta_backend);
+-
+- if (META_IS_CURSOR_RENDERER_NATIVE (renderer))
+- {
+- meta_cursor_renderer_native_get_cursor_size (META_CURSOR_RENDERER_NATIVE (renderer), cursor_width, cursor_height);
+- return;
+- }
+-#endif
+-
+- g_assert_not_reached ();
+-}
+-
+-static void
+ meta_cursor_image_load_gbm_buffer (struct gbm_device *gbm,
+ MetaCursorImage *image,
+ uint8_t *pixels,
+- uint width,
+- uint height,
++ int width,
++ int height,
+ int rowstride,
+ uint32_t gbm_format)
+ {
+- uint64_t cursor_width, cursor_height;
+- get_hardware_cursor_size (&cursor_width, &cursor_height);
+-
+- if (width > cursor_width || height > cursor_height)
++ if (width > 64 || height > 64)
+ {
+- meta_warning ("Invalid theme cursor size (must be at most %ux%u)\n",
+- (unsigned int)cursor_width, (unsigned int)cursor_height);
++ meta_warning ("Invalid theme cursor size (must be at most 64x64)\n");
+ return;
+ }
+
+ if (gbm_device_is_format_supported (gbm, gbm_format,
+- GBM_BO_USE_CURSOR | GBM_BO_USE_WRITE))
++ GBM_BO_USE_CURSOR_64X64 | GBM_BO_USE_WRITE))
+ {
+- uint8_t buf[4 * cursor_width * cursor_height];
+- uint i;
++ uint8_t buf[4 * 64 * 64];
++ int i;
+
+- image->bo = gbm_bo_create (gbm, cursor_width, cursor_height,
+- gbm_format, GBM_BO_USE_CURSOR | GBM_BO_USE_WRITE);
++ image->bo = gbm_bo_create (gbm, 64, 64,
++ gbm_format, GBM_BO_USE_CURSOR_64X64 | GBM_BO_USE_WRITE);
+
+ memset (buf, 0, sizeof(buf));
+ for (i = 0; i < height; i++)
+- memcpy (buf + i * 4 * cursor_width, pixels + i * rowstride, width * 4);
++ memcpy (buf + i * 4 * 64, pixels + i * rowstride, width * 4);
+
+- gbm_bo_write (image->bo, buf, cursor_width * cursor_height * 4);
++ gbm_bo_write (image->bo, buf, 64 * 64 * 4);
+ }
+ else
+ meta_warning ("HW cursor for format %d not supported\n", gbm_format);
+@@ -212,7 +191,7 @@ static void
+ meta_cursor_image_load_from_xcursor_image (MetaCursorImage *image,
+ XcursorImage *xc_image)
+ {
+- uint width, height, rowstride;
++ int width, height, rowstride;
+ CoglPixelFormat cogl_format;
+ uint32_t gbm_format;
+ ClutterBackend *clutter_backend;
+@@ -283,8 +262,7 @@ meta_cursor_image_load_from_buffer (Meta
+ CoglContext *cogl_context;
+ struct wl_shm_buffer *shm_buffer;
+ uint32_t gbm_format;
+- uint64_t cursor_width, cursor_height;
+- uint width, height;
++ int width, height;
+
+ image->hot_x = hot_x;
+ image->hot_y = hot_y;
+@@ -335,23 +313,22 @@ meta_cursor_image_load_from_buffer (Meta
+ }
+ else
+ {
+- if (gbm)
++ /* HW cursors must be 64x64, but 64x64 is huge, and no cursor theme actually uses
++ that, so themed cursors must be padded with transparent pixels to fill the
++ overlay. This is trivial if we have CPU access to the data, but it's not
++ possible if the buffer is in GPU memory (and possibly tiled too), so if we
++ don't get the right size, we fallback to GL.
++ */
++ if (width != 64 || height != 64)
+ {
+- /* HW cursors have a predefined size (at least 64x64), which usually is bigger than cursor theme
+- size, so themed cursors must be padded with transparent pixels to fill the
+- overlay. This is trivial if we have CPU access to the data, but it's not
+- possible if the buffer is in GPU memory (and possibly tiled too), so if we
+- don't get the right size, we fallback to GL.
+- */
+- get_hardware_cursor_size (&cursor_width, &cursor_height);
+-
+- if (width != cursor_width || height != cursor_height)
+- {
+- meta_warning ("Invalid cursor size (must be 64x64), falling back to software (GL) cursors\n");
+- return;
+- }
++ meta_warning ("Invalid cursor size (must be 64x64), falling back to software (GL) cursors\n");
++ return;
++ }
+
+- image->bo = gbm_bo_import (gbm, GBM_BO_IMPORT_WL_BUFFER, buffer, GBM_BO_USE_CURSOR);
++ if (gbm)
++ {
++ image->bo = gbm_bo_import (gbm, GBM_BO_IMPORT_WL_BUFFER,
++ buffer, GBM_BO_USE_CURSOR_64X64);
+ if (!image->bo)
+ meta_warning ("Importing HW cursor from wl_buffer failed\n");
+ }
diff --git a/x11-wm/mutter/files/patch-src_Makefile.in b/x11-wm/mutter/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..ccc06b093e2b
--- /dev/null
+++ b/x11-wm/mutter/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2014-09-29 20:29:47.729666937 +0200
++++ src/Makefile.in 2014-09-29 20:31:17.504662747 +0200
+@@ -951,7 +951,7 @@
+ @HAVE_INTROSPECTION_TRUE@ $(libmutterinclude_base_headers) \
+ @HAVE_INTROSPECTION_TRUE@ $(filter %.c,$(libmutter_la_SOURCES) $(nodist_libmutter_la_SOURCES))
+
+-@HAVE_INTROSPECTION_TRUE@@META_GIR@_SCANNERFLAGS = --warn-all --warn-error
++@HAVE_INTROSPECTION_TRUE@@META_GIR@_SCANNERFLAGS = --warn-all
+ dbus_idle_built_sources = meta-dbus-idle-monitor.c meta-dbus-idle-monitor.h
+ CLEANFILES = $(mutter_built_sources) $(typelib_DATA) $(gir_DATA) \
+ $(MUTTER_STAMP_FILES)
diff --git a/x11-wm/mutter/files/patch-src_core_main.c b/x11-wm/mutter/files/patch-src_core_main.c
deleted file mode 100644
index a248e943ac3b..000000000000
--- a/x11-wm/mutter/files/patch-src_core_main.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/core/main.c.orig 2010-02-12 12:17:38.000000000 -0500
-+++ src/core/main.c 2010-02-19 01:22:45.000000000 -0500
-@@ -59,7 +59,11 @@
-
- #include <stdlib.h>
- #include <sys/types.h>
-+#ifdef __linux__
- #include <wait.h>
-+#else
-+#include <sys/wait.h>
-+#endif
- #include <stdio.h>
- #include <string.h>
- #include <signal.h>
diff --git a/x11-wm/mutter/pkg-descr b/x11-wm/mutter/pkg-descr
index e1b5db0d2d3a..54c14b743c7e 100644
--- a/x11-wm/mutter/pkg-descr
+++ b/x11-wm/mutter/pkg-descr
@@ -3,3 +3,5 @@ designed to integrate well with the GNOME desktop. mutter lacks some
features that may be expected by traditional UNIX or other technical
users; these users may want to investigate other available window man-
agers for use with GNOME or standalone.
+
+WWW: -
diff --git a/x11-wm/mutter/pkg-plist b/x11-wm/mutter/pkg-plist
index b901e062c964..ba4e46428860 100644
--- a/x11-wm/mutter/pkg-plist
+++ b/x11-wm/mutter/pkg-plist
@@ -1,45 +1,88 @@
bin/mutter
-bin/mutter-message
-bin/mutter-theme-viewer
-bin/mutter-window-demo
-include/mutter/mutter-private/atomnames.h
-include/mutter/mutter-private/boxes.h
-include/mutter/mutter-private/common.h
-include/mutter/mutter-private/compositor-mutter.h
-include/mutter/mutter-private/compositor.h
-include/mutter/mutter-private/display.h
-include/mutter/mutter-private/errors.h
-include/mutter/mutter-private/gradient.h
-include/mutter/mutter-private/group.h
-include/mutter/mutter-private/keybindings.h
-include/mutter/mutter-private/main.h
-include/mutter/mutter-private/mutter-plugin.h
-include/mutter/mutter-private/mutter-window.h
-include/mutter/mutter-private/prefs.h
-include/mutter/mutter-private/preview-widget.h
-include/mutter/mutter-private/screen.h
-include/mutter/mutter-private/theme-parser.h
-include/mutter/mutter-private/theme.h
-include/mutter/mutter-private/types.h
-include/mutter/mutter-private/util.h
-include/mutter/mutter-private/window.h
-include/mutter/mutter-private/workspace.h
-lib/libmutter-private.a
-lib/libmutter-private.la
-lib/libmutter-private.so
-lib/libmutter-private.so.0
-lib/libmutter-private.so.0.0.0
-lib/mutter/Meta-2.31.gir
-lib/mutter/Meta-2.31.typelib
+include/mutter/meta/atomnames.h
+include/mutter/meta/barrier.h
+include/mutter/meta/boxes.h
+include/mutter/meta/common.h
+include/mutter/meta/compositor-mutter.h
+include/mutter/meta/compositor.h
+include/mutter/meta/display.h
+include/mutter/meta/errors.h
+include/mutter/meta/gradient.h
+include/mutter/meta/group.h
+include/mutter/meta/keybindings.h
+include/mutter/meta/main.h
+include/mutter/meta/meta-backend.h
+include/mutter/meta/meta-background-actor.h
+include/mutter/meta/meta-background-group.h
+include/mutter/meta/meta-background-image.h
+include/mutter/meta/meta-background.h
+include/mutter/meta/meta-cursor-tracker.h
+include/mutter/meta/meta-idle-monitor.h
+include/mutter/meta/meta-plugin.h
+include/mutter/meta/meta-shadow-factory.h
+include/mutter/meta/meta-shaped-texture.h
+include/mutter/meta/meta-version.h
+include/mutter/meta/meta-window-actor.h
+include/mutter/meta/prefs.h
+include/mutter/meta/screen.h
+include/mutter/meta/theme.h
+include/mutter/meta/types.h
+include/mutter/meta/util.h
+include/mutter/meta/window.h
+include/mutter/meta/workspace.h
+lib/libmutter.so
+lib/libmutter.so.0
+lib/libmutter.so.0.0.0
+lib/mutter/Meta-3.0.gir
+lib/mutter/Meta-3.0.typelib
lib/mutter/plugins/default.so
-libdata/pkgconfig/libmutter-private.pc
-libdata/pkgconfig/mutter-plugins.pc
-man/man1/mutter-message.1.gz
-man/man1/mutter-theme-viewer.1.gz
-man/man1/mutter-window-demo.1.gz
+libdata/pkgconfig/libmutter.pc
+libexec/mutter-restart-helper
man/man1/mutter.1.gz
+share/GConf/gsettings/mutter-schemas.convert
share/applications/mutter.desktop
-share/gnome/wm-properties/mutter-wm.desktop
+share/applications/mutter-wayland.desktop
+share/doc/meta/MetaBackgroundActor.html
+share/doc/meta/MetaBarrier.html
+share/doc/meta/MetaDisplay.html
+share/doc/meta/MetaPlugin.html
+share/doc/meta/MetaRectangle.html
+share/doc/meta/MetaScreen.html
+share/doc/meta/MetaShadowFactory.html
+share/doc/meta/MetaShapedTexture.html
+share/doc/meta/MetaWindow.html
+share/doc/meta/MetaWindowActor.html
+share/doc/meta/MetaWorkspace.html
+share/doc/meta/annotation-glossary.html
+share/doc/meta/api-index-full.html
+share/doc/meta/core-reference.html
+share/doc/meta/deprecated-api-index.html
+share/doc/meta/home.png
+share/doc/meta/index.html
+share/doc/meta/index.sgml
+share/doc/meta/left-insensitive.png
+share/doc/meta/left.png
+share/doc/meta/meta-Common.html
+share/doc/meta/meta-Errors.html
+share/doc/meta/meta-Gradients.html
+share/doc/meta/meta-Main.html
+share/doc/meta/meta-MetaCompositor.html
+share/doc/meta/meta-MetaGroup.html
+share/doc/meta/meta-MetaKeybinding.html
+share/doc/meta/meta-Preferences.html
+share/doc/meta/meta-Utility-functions.html
+share/doc/meta/meta.devhelp2
+share/doc/meta/mutter-overview.html
+share/doc/meta/object-tree.html
+share/doc/meta/right-insensitive.png
+share/doc/meta/right.png
+share/doc/meta/running-mutter.html
+share/doc/meta/style.css
+share/doc/meta/up-insensitive.png
+share/doc/meta/up.png
+share/gnome-control-center/keybindings/50-mutter-navigation.xml
+share/gnome-control-center/keybindings/50-mutter-windows.xml
+share/gnome-control-center/keybindings/50-mutter-system.xml
share/locale/am/LC_MESSAGES/mutter.mo
share/locale/ar/LC_MESSAGES/mutter.mo
share/locale/as/LC_MESSAGES/mutter.mo
@@ -62,6 +105,7 @@ share/locale/dz/LC_MESSAGES/mutter.mo
share/locale/el/LC_MESSAGES/mutter.mo
share/locale/en_CA/LC_MESSAGES/mutter.mo
share/locale/en_GB/LC_MESSAGES/mutter.mo
+share/locale/eo/LC_MESSAGES/mutter.mo
share/locale/es/LC_MESSAGES/mutter.mo
share/locale/et/LC_MESSAGES/mutter.mo
share/locale/eu/LC_MESSAGES/mutter.mo
@@ -83,6 +127,7 @@ share/locale/is/LC_MESSAGES/mutter.mo
share/locale/it/LC_MESSAGES/mutter.mo
share/locale/ja/LC_MESSAGES/mutter.mo
share/locale/ka/LC_MESSAGES/mutter.mo
+share/locale/kk/LC_MESSAGES/mutter.mo
share/locale/kn/LC_MESSAGES/mutter.mo
share/locale/ko/LC_MESSAGES/mutter.mo
share/locale/ku/LC_MESSAGES/mutter.mo
@@ -119,9 +164,11 @@ share/locale/sr@latin/LC_MESSAGES/mutter.mo
share/locale/sv/LC_MESSAGES/mutter.mo
share/locale/ta/LC_MESSAGES/mutter.mo
share/locale/te/LC_MESSAGES/mutter.mo
+share/locale/tg/LC_MESSAGES/mutter.mo
share/locale/th/LC_MESSAGES/mutter.mo
share/locale/tk/LC_MESSAGES/mutter.mo
share/locale/tr/LC_MESSAGES/mutter.mo
+share/locale/ug/LC_MESSAGES/mutter.mo
share/locale/uk/LC_MESSAGES/mutter.mo
share/locale/vi/LC_MESSAGES/mutter.mo
share/locale/wa/LC_MESSAGES/mutter.mo
@@ -130,56 +177,3 @@ share/locale/yo/LC_MESSAGES/mutter.mo
share/locale/zh_CN/LC_MESSAGES/mutter.mo
share/locale/zh_HK/LC_MESSAGES/mutter.mo
share/locale/zh_TW/LC_MESSAGES/mutter.mo
-%%DATADIR%%/icons/mutter-window-demo.png
-@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%
-@dirrm lib/mutter/plugins
-@dirrm lib/mutter
-@dirrm include/mutter/mutter-private
-@dirrm include/mutter
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/yo/LC_MESSAGES
-@dirrmtry share/locale/yo
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/nds/LC_MESSAGES
-@dirrmtry share/locale/nds
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mg/LC_MESSAGES
-@dirrmtry share/locale/mg
-@dirrmtry share/locale/mai/LC_MESSAGES
-@dirrmtry share/locale/mai
-@dirrmtry share/locale/la/LC_MESSAGES
-@dirrmtry share/locale/la
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/ig/LC_MESSAGES
-@dirrmtry share/locale/ig
-@dirrmtry share/locale/hy/LC_MESSAGES
-@dirrmtry share/locale/hy
-@dirrmtry share/locale/ha/LC_MESSAGES
-@dirrmtry share/locale/ha
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as