aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/novawm/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-24 04:56:06 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-24 04:56:06 +0000
commit5fa9212a8b0bbb4bd2225ae16b3dc55d88c4338e (patch)
tree2b19fb1443d62853847a704bb19bd74304efbc85 /x11-wm/novawm/Makefile
parenta82070940049d0deb11d719fefad6b018a1d7a76 (diff)
Add new port novawm - A window manager for X, developed with speed, size,
and style in mind PR: ports/39572 Submitted by: Alexey Dokuchaev <danfe@regency.nsu.ru>
Notes
Notes: svn path=/head/; revision=61862
Diffstat (limited to 'x11-wm/novawm/Makefile')
-rw-r--r--x11-wm/novawm/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/novawm/Makefile b/x11-wm/novawm/Makefile
new file mode 100644
index 000000000000..9459d5056b2c
--- /dev/null
+++ b/x11-wm/novawm/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: novawm
+# Date created: 20 June 2002
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= novawm
+PORTVERSION= 0.7
+CATEGORIES= x11-wm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}_alpha
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_XPM= yes
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README COPYING AUTHORS ChangeLog INSTALL TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>