aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/obconf
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2011-09-24 01:06:01 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2011-09-24 01:06:01 +0000
commit72714a886ad71d912d2b3555d1c2193fd43a4664 (patch)
tree86014df97c063f6b40ffaf23d9c85f47315e6123 /x11-wm/obconf
parent0d1b6f4bb842dbe156436f0ac05f392ebc21c322 (diff)
downloadports-72714a886ad71d912d2b3555d1c2193fd43a4664.tar.gz
ports-72714a886ad71d912d2b3555d1c2193fd43a4664.zip
Notes
Diffstat (limited to 'x11-wm/obconf')
-rw-r--r--x11-wm/obconf/Makefile2
-rw-r--r--x11-wm/obconf/files/patch-src-main.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/x11-wm/obconf/Makefile b/x11-wm/obconf/Makefile
index c5f41bcf29e9..e21836dc39db 100644
--- a/x11-wm/obconf/Makefile
+++ b/x11-wm/obconf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= obconf
PORTVERSION= 2.0.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-wm
MASTER_SITES= http://openbox.org/dist/obconf/
diff --git a/x11-wm/obconf/files/patch-src-main.c b/x11-wm/obconf/files/patch-src-main.c
new file mode 100644
index 000000000000..5c07a63f3f4b
--- /dev/null
+++ b/x11-wm/obconf/files/patch-src-main.c
@@ -0,0 +1,18 @@
+--- src/main.c.orig
++++ src/main.c
+@@ -233,11 +233,10 @@ int main(int argc, char **argv)
+ }
+
+ xmlIndentTreeOutput = 1;
+- if (!obt_xml_load_config_file(parse_i,
+- "openbox",
+- (obc_config_file ?
+- obc_config_file : "rc.xml"),
+- "openbox_config"))
++ if (!((obc_config_file &&
++ obt_xml_load_file(parse_i, obc_config_file, "openbox_config")) ||
++ obt_xml_load_config_file(parse_i, "openbox", "rc.xml",
++ "openbox_config")))
+ {
+ obconf_error(_("Failed to load an rc.xml. You have probably failed to install Openbox properly."), TRUE);
+ exit_with_error = TRUE;