aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/obpager
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-14 14:36:58 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-14 14:36:58 +0000
commit2eb9bbf5a5bfcff4c5cc9bbcd8c85d8c07591fc6 (patch)
tree5a40b7d14415a73b946e63713c7c7a797efa2e17 /x11-wm/obpager
parente4fb23b7234b9ed1deb6f3cef9185bac1b973d36 (diff)
downloadports-2eb9bbf5a5bfcff4c5cc9bbcd8c85d8c07591fc6.tar.gz
ports-2eb9bbf5a5bfcff4c5cc9bbcd8c85d8c07591fc6.zip
Notes
Diffstat (limited to 'x11-wm/obpager')
-rw-r--r--x11-wm/obpager/Makefile9
-rw-r--r--x11-wm/obpager/files/patch-src_OBPager.cc20
-rw-r--r--x11-wm/obpager/files/patch-src_OBPager.h11
3 files changed, 36 insertions, 4 deletions
diff --git a/x11-wm/obpager/Makefile b/x11-wm/obpager/Makefile
index 0ae6ddb7b91f..5e1e8372381c 100644
--- a/x11-wm/obpager/Makefile
+++ b/x11-wm/obpager/Makefile
@@ -7,22 +7,23 @@ CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
-COMMENT= A lightweight pager for netwm compatible window managers
+COMMENT= Lightweight pager for netwm compatible window managers
+
+LICENSE= GPLv2
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
+USES= gmake
USE_XORG= x11 xext
-USE_GMAKE= yes
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%CXX%%|${CXX}|g; \
s|sed|gsed|g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/x11-wm/obpager/files/patch-src_OBPager.cc b/x11-wm/obpager/files/patch-src_OBPager.cc
new file mode 100644
index 000000000000..5cedde9ee0f1
--- /dev/null
+++ b/x11-wm/obpager/files/patch-src_OBPager.cc
@@ -0,0 +1,20 @@
+--- src/OBPager.cc.orig 2014-02-14 15:35:01.000000000 +0100
++++ src/OBPager.cc 2014-02-14 15:39:12.000000000 +0100
+@@ -159,7 +159,7 @@
+ * @param displayName is the name of the display to connect to
+ */
+
+-void OBPager::connectToXServer(char *displayName)
++void OBPager::connectToXServer(const char *displayName)
+ {
+ // Connect to the user-specified desktop or whatever is in $DISPLAY?
+
+@@ -301,7 +301,7 @@
+ int maxHeight = height;
+ int minWidth = width;
+ int minHeight = height;
+- char* appName = APPLET_NAME;
++ char appName[] = APPLET_NAME;
+ unsigned long borderColour = BlackPixel(mDisplay(), mScreenNum);
+ unsigned long backgroundColour = BlackPixel(mDisplay(), mScreenNum);
+
diff --git a/x11-wm/obpager/files/patch-src_OBPager.h b/x11-wm/obpager/files/patch-src_OBPager.h
new file mode 100644
index 000000000000..1c81d47f97e0
--- /dev/null
+++ b/x11-wm/obpager/files/patch-src_OBPager.h
@@ -0,0 +1,11 @@
+--- src/OBPager.h.orig 2014-02-14 15:36:36.000000000 +0100
++++ src/OBPager.h 2014-02-14 15:37:08.000000000 +0100
+@@ -63,7 +63,7 @@
+ ~OBPager();
+
+ /// Connect to a specified X server display, or the default display
+- void connectToXServer(char *displayName = NULL);
++ void connectToXServer(const char *displayName = NULL);
+
+ /// Create and show the X window
+ void createShowWindow();