aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/openbox/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-09-20 20:01:47 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-09-20 20:01:47 +0000
commit8d59eedde92d8f281e7361c0d1045f56822d9911 (patch)
tree397e3e9e3ef1187a41986569ca47aa48e74788fc /x11-wm/openbox/Makefile
parent6b3fa393d5a4b3595b3ff1a2e904d776e19d95db (diff)
downloadports-8d59eedde92d8f281e7361c0d1045f56822d9911.tar.gz
ports-8d59eedde92d8f281e7361c0d1045f56822d9911.zip
Notes
Diffstat (limited to 'x11-wm/openbox/Makefile')
-rw-r--r--x11-wm/openbox/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index d16b3d93e4f9..df125bd95f36 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= openbox
-PORTVERSION= 3.3
+PORTVERSION= 3.3.1
CATEGORIES= x11-wm
MASTER_SITES= http://offload1.icculus.org/openbox/releases/
@@ -21,6 +21,16 @@ USE_GMAKE= yes
USE_GNOME= glib20 libxml2
USE_X_PREFIX= yes
USE_LDCONFIG= yes
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
.if !defined(WITHOUT_PANGO)
USE_GNOME+= pango