aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/openbox
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2007-06-12 05:18:37 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2007-06-12 05:18:37 +0000
commit5c5816b347ab40966f3c3e06435f79a6ad0db36b (patch)
treec9486460694be0b5f5710d04b2a08db4b50e77f5 /x11-wm/openbox
parentce9f0fa1d359351da9a9eadc5e6930dc6eb5947c (diff)
downloadports-5c5816b347ab40966f3c3e06435f79a6ad0db36b.tar.gz
ports-5c5816b347ab40966f3c3e06435f79a6ad0db36b.zip
Notes
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/Makefile13
-rw-r--r--x11-wm/openbox/distinfo6
-rw-r--r--x11-wm/openbox/files/patch-openbox-menuframe.c18
-rw-r--r--x11-wm/openbox/files/patch-render-font.c26
-rw-r--r--x11-wm/openbox/files/patch-render-gradient.c23
-rw-r--r--x11-wm/openbox/pkg-plist171
6 files changed, 111 insertions, 146 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 70e7f58a6c32..ee707116a02b 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -7,23 +7,26 @@
#
PORTNAME= openbox
-PORTVERSION= 3.3.1
-PORTREVISION= 1
+PORTVERSION= 3.4.2
CATEGORIES= x11-wm
MASTER_SITES= http://offload1.icculus.org/openbox/releases/
-MAINTAINER= redchrom@gmail.com
+MAINTAINER= novel@FreeBSD.org
COMMENT= A standards compliant, fast, light-weight, extensible window manager
LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= glib20 libxml2
-USE_X_PREFIX= yes
+USE_GNOME= glib20 libxml2 ltverhack
+USE_AUTOTOOLS= libtool:15
+USE_XLIB= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --mandir="${PREFIX}/man/"
+MAN1= openbox.1 openbox-session.1 \
+ openbox-gnome-session.1 openbox-kde-session.1
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/x11-wm/openbox/distinfo b/x11-wm/openbox/distinfo
index 1379aaf6b399..081fc5f1e6e6 100644
--- a/x11-wm/openbox/distinfo
+++ b/x11-wm/openbox/distinfo
@@ -1,3 +1,3 @@
-MD5 (openbox-3.3.1.tar.gz) = 6dc25d5fbff5d6277593b89974f950d8
-SHA256 (openbox-3.3.1.tar.gz) = a70b7bc8c28427dff350aa17882d6916b678fd12d1119e4c3ad4b86f3371f033
-SIZE (openbox-3.3.1.tar.gz) = 603402
+MD5 (openbox-3.4.2.tar.gz) = d5d52fa23fe91e1e3b53858a20d12757
+SHA256 (openbox-3.4.2.tar.gz) = 92a1f2042622474548d9c13c9057e76c621994d0593659c1a434251d545ab148
+SIZE (openbox-3.4.2.tar.gz) = 727411
diff --git a/x11-wm/openbox/files/patch-openbox-menuframe.c b/x11-wm/openbox/files/patch-openbox-menuframe.c
deleted file mode 100644
index 884096491726..000000000000
--- a/x11-wm/openbox/files/patch-openbox-menuframe.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- openbox/menuframe.c.orig Tue Sep 12 21:24:28 2006
-+++ openbox/menuframe.c Tue Sep 12 21:24:50 2006
-@@ -675,12 +675,14 @@
-
- void menu_frame_hide_all()
- {
-+ GList *it;
-+
- if (config_submenu_show_delay) {
- /* remove any submenu open requests */
- ob_main_loop_timeout_remove(ob_main_loop,
- menu_entry_frame_submenu_timeout);
- }
-- GList *it = g_list_last(menu_frame_visible);
-+ it = g_list_last(menu_frame_visible);
- if (it)
- menu_frame_hide(it->data);
- }
diff --git a/x11-wm/openbox/files/patch-render-font.c b/x11-wm/openbox/files/patch-render-font.c
deleted file mode 100644
index 9cc01386c6bf..000000000000
--- a/x11-wm/openbox/files/patch-render-font.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- render/font.c.orig Sat Aug 26 22:15:51 2006
-+++ render/font.c Tue Sep 12 21:14:46 2006
-@@ -92,6 +92,8 @@
- #ifdef USE_PANGO
- guchar *tmp_string = NULL;
- gint tmp_int;
-+ gchar *locale, *p;
-+ PangoFontMetrics *metrics;
- #endif /* USE_PANGO */
-
- if (!(pat = XftNameParse(fontstring)))
-@@ -135,13 +137,12 @@
- }
-
- /* based on gtkmain.c gtk_get_default_language() */
-- gchar *locale, *p;
- locale = g_strdup(setlocale(LC_CTYPE, NULL));
- if ((p = strchr(locale, '.')))
- *p = '\0';
- if ((p = strchr(locale, '@')))
- *p = '\0';
-- PangoFontMetrics *metrics =
-+ metrics =
- pango_context_get_metrics(context, out->pango_font_description,
- pango_language_from_string(locale));
- out->pango_ascent = pango_font_metrics_get_ascent(metrics);
diff --git a/x11-wm/openbox/files/patch-render-gradient.c b/x11-wm/openbox/files/patch-render-gradient.c
deleted file mode 100644
index 5c8f7b789b42..000000000000
--- a/x11-wm/openbox/files/patch-render-gradient.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- render/gradient.c.orig Sat Aug 26 22:15:51 2006
-+++ render/gradient.c Tue Sep 12 21:14:46 2006
-@@ -371,6 +371,9 @@
- RrPixel32 current;
- RrColor *primary_light, *secondary_light;
-
-+ VARS(y1);
-+ VARS(y3);
-+
- r = sf->primary->r;
- r += r >> 2;
- g = sf->primary->g;
-@@ -393,10 +396,8 @@
- if (b > 0xFF) b = 0xFF;
- secondary_light = RrColorNew(a->inst, r, g, b);
-
-- VARS(y1);
- SETUP(y1, primary_light, sf->primary, (h / 2) -1);
-
-- VARS(y3);
- SETUP(y3, sf->secondary, secondary_light, (h / 2) -1);
-
- for (y1 = h - 1; y1 > (h / 2) -1; --y1) { /* 0 -> h-1 */
diff --git a/x11-wm/openbox/pkg-plist b/x11-wm/openbox/pkg-plist
index bb213a40c8c7..9449758f5bc0 100644
--- a/x11-wm/openbox/pkg-plist
+++ b/x11-wm/openbox/pkg-plist
@@ -1,34 +1,37 @@
bin/gnome-panel-control
-bin/kdetrayproxy
bin/openbox
+bin/openbox-gnome-session
+bin/openbox-kde-session
+bin/openbox-session
+etc/xdg/openbox/autostart.sh
etc/xdg/openbox/menu.xml
etc/xdg/openbox/rc.xml
-include/openbox/3.3/openbox/color.h
-include/openbox/3.3/openbox/font.h
-include/openbox/3.3/openbox/geom.h
-include/openbox/3.3/openbox/gradient.h
-include/openbox/3.3/openbox/image.h
-include/openbox/3.3/openbox/instance.h
-include/openbox/3.3/openbox/mask.h
-include/openbox/3.3/openbox/parse.h
-include/openbox/3.3/openbox/render.h
-include/openbox/3.3/openbox/theme.h
-include/openbox/3.3/openbox/version.h
+include/openbox/3.4/openbox/color.h
+include/openbox/3.4/openbox/font.h
+include/openbox/3.4/openbox/geom.h
+include/openbox/3.4/openbox/gradient.h
+include/openbox/3.4/openbox/image.h
+include/openbox/3.4/openbox/instance.h
+include/openbox/3.4/openbox/mask.h
+include/openbox/3.4/openbox/parse.h
+include/openbox/3.4/openbox/render.h
+include/openbox/3.4/openbox/theme.h
+include/openbox/3.4/openbox/version.h
lib/libobparser.a
lib/libobparser.la
lib/libobparser.so
-lib/libobparser.so.4
+lib/libobparser.so.15
lib/libobrender.a
lib/libobrender.la
lib/libobrender.so
-lib/libobrender.so.4
+lib/libobrender.so.15
libdata/pkgconfig/obparser-3.0.pc
libdata/pkgconfig/obrender-3.0.pc
share/gnome/wm-properties/openbox.desktop
-%%DATADIR%%/menu.xsd
-%%DATADIR%%/rc.xsd
-%%DATADIR%%/themeupdate.py
share/pixmaps/openbox.png
+share/themes/Artwiz-boxed/openbox-3/themerc
+share/themes/Clearlooks/openbox-3/themerc
+share/themes/Clearlooks-Olive/openbox-3/themerc
share/themes/Mikachu/openbox-3/bullet.xbm
share/themes/Mikachu/openbox-3/close.xbm
share/themes/Mikachu/openbox-3/desk.xbm
@@ -38,90 +41,116 @@ share/themes/Mikachu/openbox-3/themerc
share/themes/Natura/openbox-3/close.xbm
share/themes/Natura/openbox-3/close_hover.xbm
share/themes/Natura/openbox-3/desk.xbm
+share/themes/Natura/openbox-3/desk_hover.xbm
share/themes/Natura/openbox-3/desk_toggled.xbm
share/themes/Natura/openbox-3/iconify.xbm
-share/themes/Natura/openbox-3/iconify_disabled.xbm
share/themes/Natura/openbox-3/iconify_hover.xbm
share/themes/Natura/openbox-3/max.xbm
-share/themes/Natura/openbox-3/max_disabled.xbm
share/themes/Natura/openbox-3/max_hover.xbm
share/themes/Natura/openbox-3/max_toggled.xbm
share/themes/Natura/openbox-3/shade.xbm
+share/themes/Natura/openbox-3/shade_hover.xbm
share/themes/Natura/openbox-3/themerc
-share/themes/artwiz-boxed/openbox-3/bullet.xbm
-share/themes/artwiz-boxed/openbox-3/close.xbm
-share/themes/artwiz-boxed/openbox-3/desk.xbm
-share/themes/artwiz-boxed/openbox-3/desk_toggled.xbm
-share/themes/artwiz-boxed/openbox-3/iconify.xbm
-share/themes/artwiz-boxed/openbox-3/max.xbm
-share/themes/artwiz-boxed/openbox-3/max_toggled.xbm
-share/themes/artwiz-boxed/openbox-3/themerc
-share/themes/bear2/openbox-3/close.xbm
-share/themes/bear2/openbox-3/close_pressed.xbm
-share/themes/bear2/openbox-3/desk.xbm
-share/themes/bear2/openbox-3/desk_toggled.xbm
-share/themes/bear2/openbox-3/iconify.xbm
-share/themes/bear2/openbox-3/iconify_disabled.xbm
-share/themes/bear2/openbox-3/iconify_pressed.xbm
-share/themes/bear2/openbox-3/max.xbm
-share/themes/bear2/openbox-3/max_disabled.xbm
-share/themes/bear2/openbox-3/max_pressed.xbm
-share/themes/bear2/openbox-3/max_toggled.xbm
-share/themes/bear2/openbox-3/shade.xbm
-share/themes/bear2/openbox-3/shade_pressed.xbm
-share/themes/bear2/openbox-3/themerc
-share/themes/orang/openbox-3/themerc
-share/themes/syscrash/openbox-3/bullet.xbm
-share/themes/syscrash/openbox-3/close.xbm
-share/themes/syscrash/openbox-3/close_disabled.xbm
-share/themes/syscrash/openbox-3/desk.xbm
-share/themes/syscrash/openbox-3/desk_toggled.xbm
-share/themes/syscrash/openbox-3/iconify.xbm
-share/themes/syscrash/openbox-3/max.xbm
-share/themes/syscrash/openbox-3/max_disabled.xbm
-share/themes/syscrash/openbox-3/max_pressed.xbm
-share/themes/syscrash/openbox-3/max_toggled.xbm
-share/themes/syscrash/openbox-3/shade.xbm
-share/themes/syscrash/openbox-3/themerc
+share/themes/Onyx/openbox-3/themerc
+share/themes/Onyx-Citrus/openbox-3/themerc
+share/themes/Orang/openbox-3/themerc
+share/themes/Syscrash/openbox-3/max_disabled.xbm
+share/themes/Syscrash/openbox-3/max_pressed.xbm
+share/themes/Syscrash/openbox-3/max_toggled.xbm
+share/themes/Syscrash/openbox-3/max.xbm
+share/themes/Syscrash/openbox-3/themerc
+share/themes/Bear2/openbox-3/close.xbm
+share/themes/Bear2/openbox-3/close_pressed.xbm
+share/themes/Bear2/openbox-3/desk.xbm
+share/themes/Bear2/openbox-3/desk_toggled.xbm
+share/themes/Bear2/openbox-3/iconify.xbm
+share/themes/Bear2/openbox-3/iconify_pressed.xbm
+share/themes/Bear2/openbox-3/max.xbm
+share/themes/Bear2/openbox-3/max_pressed.xbm
+share/themes/Bear2/openbox-3/max_toggled.xbm
+share/themes/Bear2/openbox-3/shade.xbm
+share/themes/Bear2/openbox-3/shade_pressed.xbm
+share/themes/Bear2/openbox-3/themerc
+share/xsessions/openbox.desktop
+share/xsessions/openbox-gnome.desktop
+share/xsessions/openbox-kde.desktop
+%%DOCSDIR%%/COMPLIANCE
+%%DOCSDIR%%/README
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/CHANGELOG
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/rc.xsd
+%%DOCSDIR%%/menu.xsd
+%%DOCSDIR%%/rc-mouse-focus.xml
+%%DOCSDIR%%/xbm/bullet.xbm
+%%DOCSDIR%%/xbm/close.xbm
+%%DOCSDIR%%/xbm/desk_toggled.xbm
+%%DOCSDIR%%/xbm/desk.xbm
+%%DOCSDIR%%/xbm/iconify.xbm
+%%DOCSDIR%%/xbm/max_toggled.xbm
+%%DOCSDIR%%/xbm/max.xbm
+%%DOCSDIR%%/xbm/shade_toggled.xbm
+%%DOCSDIR%%/xbm/shade.xbm
+%%NLS%%share/locale/ar/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/ca/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/de/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/es/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/et/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/fi/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/fr/LC_MESSAGES/openbox.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/it/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/ja/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/no/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/pl/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/pt/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/ru/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/sk/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/sv/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/openbox.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/openbox.mo
-%%NLS%%share/locale/en@quot/LC_MESSAGES/openbox.mo
-%%NLS%%share/locale/en@boldquot/LC_MESSAGES/openbox.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/openbox.mo
+%%NLS%%@dirrmtry share/locale/bn_IN/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/bn_IN
%%NLS%%@dirrmtry share/locale/en@quot/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/en@quot
%%NLS%%@dirrmtry share/locale/en@boldquot/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/en@boldquot
-@dirrm share/themes/syscrash/openbox-3
-@dirrm share/themes/syscrash
-@dirrm share/themes/orang/openbox-3
-@dirrm share/themes/orang
-@dirrm share/themes/bear2/openbox-3
-@dirrm share/themes/bear2
-@dirrm share/themes/artwiz-boxed/openbox-3
-@dirrm share/themes/artwiz-boxed
-@dirrm share/themes/Natura/openbox-3
-@dirrm share/themes/Natura
+@dirrm %%DOCSDIR%%/xbm
+@dirrm %%DOCSDIR%%
+@dirrm share/themes/Artwiz-boxed/openbox-3
+@dirrm share/themes/Artwiz-boxed
+@dirrm share/themes/Bear2/openbox-3
+@dirrm share/themes/Bear2
+@dirrm share/themes/Clearlooks/openbox-3
+@dirrm share/themes/Clearlooks
+@dirrm share/themes/Clearlooks-Olive/openbox-3
+@dirrm share/themes/Clearlooks-Olive
@dirrm share/themes/Mikachu/openbox-3
@dirrm share/themes/Mikachu
+@dirrm share/themes/Natura/openbox-3
+@dirrm share/themes/Natura
+@dirrm share/themes/Orang/openbox-3
+@dirrm share/themes/Orang
+@dirrm share/themes/Onyx/openbox-3
+@dirrm share/themes/Onyx-Citrus/openbox-3
+@dirrm share/themes/Onyx-Citrus
+@dirrm share/themes/Onyx
+@dirrm share/themes/Syscrash/openbox-3
+@dirrm share/themes/Syscrash
@dirrmtry share/themes
-@dirrm %%DATADIR%%
+@comment @dirrm %%DATADIR%%
@dirrmtry share/gnome/wm-properties
@dirrmtry share/gnome
@dirrmtry libdata/pkgconfig
-@dirrm include/openbox/3.3/openbox
-@dirrm include/openbox/3.3
+@dirrm include/openbox/3.4/openbox
+@dirrm include/openbox/3.4
@dirrm include/openbox
@dirrm etc/xdg/openbox
-@dirrmtry etc/xdg
+@dirrm etc/xdg
+@dirrmtry share/xsessions