aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pager/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-11-20 09:41:05 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-11-20 09:41:05 +0000
commit7c32e23e47467f3b3d13b3b382a4ee27bd598b08 (patch)
treecf19ad2846710b2431dd8645d6d54eaa596ac0ac /x11-wm/pager/Makefile
parent39800089b4aa10073dbea680fcb59de072aeb8d9 (diff)
downloadports-7c32e23e47467f3b3d13b3b382a4ee27bd598b08.tar.gz
ports-7c32e23e47467f3b3d13b3b382a4ee27bd598b08.zip
Notes
Diffstat (limited to 'x11-wm/pager/Makefile')
-rw-r--r--x11-wm/pager/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/pager/Makefile b/x11-wm/pager/Makefile
new file mode 100644
index 000000000000..8e7c09a8a8a8
--- /dev/null
+++ b/x11-wm/pager/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: pager
+# Date created: November 20 2002
+# Whom: Michael Ebert <ebert@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pager
+PORTVERSION= 0.4a
+CATEGORIES= x11-wm
+MASTER_SITES= http://dapfy.bei.t-online.de/sawfish/pager/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ebert@informatik.unibw-muenchen.de
+
+BUILD_DEPENDS= ${X11BASE}/bin/sawfish:${PORTSDIR}/x11-wm/sawfish
+RUN_DEPENDS= ${X11BASE}/bin/sawfish:${PORTSDIR}/x11-wm/sawfish
+
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_GNOMENG= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+SAWFISH_VERSION= `${X11BASE}/bin/sawfish --version 2>&1 | \
+ ${SED} 's/^.*version[ ]*\([0-9.]*\).*/\1/'`
+
+PLIST_SUB+= SAWFISH_VERSION="${SAWFISH_VERSION}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/gtk-config/gtk12-config/g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+# doesn't work correct with the compiled .jl file at the moment
+# ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jlc \
+# ${PREFIX}/share/sawfish/${SAWFISH_VERSION}/lisp/sawfish/wm/ext
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jl \
+ ${PREFIX}/share/sawfish/${SAWFISH_VERSION}/lisp/sawfish/wm/ext
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>