aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pekwm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 16:30:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 16:30:43 +0000
commitf20cc1052a773778240cac9a2cad6a5a7cf60848 (patch)
tree54cebba129dcec00fae9038773093bab2bb609a9 /x11-wm/pekwm
parent75e596beb82ca63bc2b571a0b269e7b61ce30a32 (diff)
downloadports-f20cc1052a773778240cac9a2cad6a5a7cf60848.tar.gz
ports-f20cc1052a773778240cac9a2cad6a5a7cf60848.zip
Notes
Diffstat (limited to 'x11-wm/pekwm')
-rw-r--r--x11-wm/pekwm/Makefile9
-rw-r--r--x11-wm/pekwm/distinfo6
-rw-r--r--x11-wm/pekwm/files/patch-Frame.cc46
-rw-r--r--x11-wm/pekwm/files/patch-data-scripts-pekwm_themeset.sh12
4 files changed, 53 insertions, 20 deletions
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
index c2735981d97c..bcf0f3788ad2 100644
--- a/x11-wm/pekwm/Makefile
+++ b/x11-wm/pekwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pekwm
-PORTVERSION= 0.1.7
+PORTVERSION= 0.1.8
PORTEPOCH= 1
CATEGORIES= x11-wm
MASTER_SITES= http://pekwm.org/projects/3/files/ \
@@ -23,17 +23,16 @@ RUN_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
USE_BZIP2= yes
USE_XORG= xft xpm x11
+USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-shape --enable-xinerama --enable-xrandr \
--enable-xft --enable-image-xpm --enable-image-jpeg \
--enable-image-png --disable-debug \
--disable-pedantic --enable-menus --enable-harbour
-CFLAGS+= -DICONV_CONST
+CFLAGS+= -DICONV_CONST -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -liconv"
MAN1= pekwm.1
MANCOMPRESSED= no
-post-configure:
- @${REINPLACE_CMD} 's|-lX11|-liconv -lX11|' ${WRKSRC}/src/Makefile
-
.include <bsd.port.mk>
diff --git a/x11-wm/pekwm/distinfo b/x11-wm/pekwm/distinfo
index 5405e500b415..f2b9280add26 100644
--- a/x11-wm/pekwm/distinfo
+++ b/x11-wm/pekwm/distinfo
@@ -1,3 +1,3 @@
-MD5 (pekwm-0.1.7.tar.bz2) = 30acfa41a5005a9f31117041ec32eb0d
-SHA256 (pekwm-0.1.7.tar.bz2) = 2216eb0c722f4aad15761a7f4eced67ea1284a00e32e03d66de4b55f8c1c9524
-SIZE (pekwm-0.1.7.tar.bz2) = 363788
+MD5 (pekwm-0.1.8.tar.bz2) = 01be60875094f57bd4009f7ed5f038fe
+SHA256 (pekwm-0.1.8.tar.bz2) = 1604d8864c7e4907150b545d302350a35c89b8578b6438661309cb4bb0362e1a
+SIZE (pekwm-0.1.8.tar.bz2) = 336414
diff --git a/x11-wm/pekwm/files/patch-Frame.cc b/x11-wm/pekwm/files/patch-Frame.cc
new file mode 100644
index 000000000000..3d52080bd864
--- /dev/null
+++ b/x11-wm/pekwm/files/patch-Frame.cc
@@ -0,0 +1,46 @@
+diff -Naur ./src/Frame.cc ../pekwm-0.1.8/src/Frame.cc
+--- ./src/Frame.cc 2008-11-20 20:20:55.000000000 +0100
++++ ../pekwm-0.1.8/src/Frame.cc 2008-11-20 20:21:20.000000000 +0100
+@@ -1990,7 +1990,7 @@
+ Frame::handleConfigureRequestGeometry(XConfigureRequestEvent *ev, Client *client)
+ {
+ // Look for fullscreen requests
+- long all_geometry = CWX|CWY|CWWidth|CWHeight;
++ const long all_geometry = CWX|CWY|CWWidth|CWHeight;
+ bool is_fullscreen = false;
+ if (Config::instance()->isFullscreenDetect()
+ && ! client->isCfgDeny(CFG_DENY_SIZE)
+@@ -2007,16 +2007,15 @@
+ }
+
+ if (! is_fullscreen) {
+- // Remove fullscreen state if client changes it size
+- if (Config::instance()->isFullscreenDetect()) {
+- setStateFullscreen(STATE_UNSET);
+- }
++ bool change_geometry = false;
+
+ if (! client->isCfgDeny(CFG_DENY_SIZE)
+ && (ev->value_mask & (CWWidth|CWHeight)) ) {
+
+ resizeChild(ev->width, ev->height);
+ _client->setShaped(setShape());
++
++ change_geometry = true;
+ }
+
+ if (! client->isCfgDeny(CFG_DENY_POSITION)
+@@ -2025,6 +2024,13 @@
+ calcGravityPosition(_client->getXSizeHints()->win_gravity,
+ ev->x, ev->y, _gm.x, _gm.y);
+ move(_gm.x, _gm.y);
++
++ change_geometry = true;
++ }
++
++ // Remove fullscreen state if client changes it size
++ if (change_geometry && Config::instance()->isFullscreenDetect()) {
++ setStateFullscreen(STATE_UNSET);
+ }
+ }
+ }
diff --git a/x11-wm/pekwm/files/patch-data-scripts-pekwm_themeset.sh b/x11-wm/pekwm/files/patch-data-scripts-pekwm_themeset.sh
deleted file mode 100644
index bd2ba708b006..000000000000
--- a/x11-wm/pekwm/files/patch-data-scripts-pekwm_themeset.sh
+++ /dev/null
@@ -1,12 +0,0 @@
---- data/scripts/pekwm_themeset.sh.in.orig 2008-08-07 01:54:14.000000000 +0200
-+++ data/scripts/pekwm_themeset.sh.in 2008-08-07 01:55:00.000000000 +0200
-@@ -46,7 +46,8 @@
- fi
-
- # Change theme
-- sed -e "s/^\([^#]*\)Theme\ =\ \"[^\"]*\"/\\1Theme\ =\ \"${theme}\"/i" "${PEKWM_CONFIG_FILE}" > "${tmp_file}"
-+ gsed -e "s/^\([^#]*\)Theme\ =\ \"[^\"]*\"/\\1Theme\ =\ \"${theme}\"/i" "${PEKWM_CONFIG_FILE}" > "${tmp_file}"
-+ cp "${PEKWM_CONFIG_FILE}" "${PEKWM_CONFIG_FILE}".bak
- mv "${tmp_file}" "${PEKWM_CONFIG_FILE}"
-
- # Reload pekwm