aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pekwm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-28 18:58:46 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-28 18:58:46 +0000
commitc94164e5c0c4195fd35ef6fd665357f3084cc889 (patch)
treefebc2d72b654fae3cd8fc7b3e07ea46fa0450e52 /x11-wm/pekwm
parentcfb3d04b479ee9cc71fa099a6a09d3023f1f4077 (diff)
downloadports-c94164e5c0c4195fd35ef6fd665357f3084cc889.tar.gz
ports-c94164e5c0c4195fd35ef6fd665357f3084cc889.zip
Notes
Diffstat (limited to 'x11-wm/pekwm')
-rw-r--r--x11-wm/pekwm/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
index 99744d090346..6e2e7e085401 100644
--- a/x11-wm/pekwm/Makefile
+++ b/x11-wm/pekwm/Makefile
@@ -32,4 +32,14 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -liconv"
MAN1= pekwm.1
MANCOMPRESSED= no
+# replace calls to obsolete libpng12 functions
+post-extract:
+ ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|; \
+ s|png_check_sig(sig, PImageLoaderPng::PNG_SIG_BYTES) !=|png_sig_cmp(sig, 0, PImageLoaderPng::PNG_SIG_BYTES) ==|' \
+ ${WRKSRC}/src/PImageLoaderPng.cc
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|libpng12|libpng14|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>