aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/qnxstyle
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-05-21 22:23:08 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-05-21 22:23:08 +0000
commit258a678bdeccb425a20f68feb0aa7b03381497a3 (patch)
treeafce4682b9fbe23dad8220014989e00bec7fb1f7 /x11-wm/qnxstyle
parent7b44b2617561836d25048e72850e1ee3a2a89cae (diff)
downloadports-258a678bdeccb425a20f68feb0aa7b03381497a3.tar.gz
ports-258a678bdeccb425a20f68feb0aa7b03381497a3.zip
Notes
Diffstat (limited to 'x11-wm/qnxstyle')
-rw-r--r--x11-wm/qnxstyle/Makefile9
-rw-r--r--x11-wm/qnxstyle/files/patch-src_Makefile.in11
2 files changed, 17 insertions, 3 deletions
diff --git a/x11-wm/qnxstyle/Makefile b/x11-wm/qnxstyle/Makefile
index ab0f1e58e7dc..4511f2062ab2 100644
--- a/x11-wm/qnxstyle/Makefile
+++ b/x11-wm/qnxstyle/Makefile
@@ -22,11 +22,14 @@ USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
PLIST_FILES= lib/kde3/plugins/styles/qnx.so \
lib/kde3/plugins/styles/qnx.la \
share/apps/kstyle/themes/qnx.themerc
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/qnxstyle/files/patch-src_Makefile.in b/x11-wm/qnxstyle/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..e4e6bc88a88b
--- /dev/null
+++ b/x11-wm/qnxstyle/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat May 22 00:01:43 2004
++++ src/Makefile.in Sat May 22 00:02:13 2004
+@@ -228,7 +228,7 @@
+ noinst_HEADERS = qnx.h
+ kde_style_LTLIBRARIES = qnx.la
+ qnx_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -lkdefx -module
+-qnx_la_LIBADD =
++qnx_la_LIBADD = $(LIBPTHREAD)
+ qnx_la_SOURCES = qnx.cpp
+ #>- qnx_la_METASOURCES = AUTO
+