aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/sapphire
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2007-09-12 01:14:32 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2007-09-12 01:14:32 +0000
commitaf72916fe4aa9c58714932737dc138e5d747a366 (patch)
treef0dfd592404bc0fec8bc646d2c1e66181b02e66b /x11-wm/sapphire
parent9c01c5b4f150351e7a1c44a4b99882c99f78e408 (diff)
downloadports-af72916fe4aa9c58714932737dc138e5d747a366.tar.gz
ports-af72916fe4aa9c58714932737dc138e5d747a366.zip
Notes
Diffstat (limited to 'x11-wm/sapphire')
-rw-r--r--x11-wm/sapphire/Makefile9
-rw-r--r--x11-wm/sapphire/distinfo6
-rw-r--r--x11-wm/sapphire/files/patch-Makefile26
-rw-r--r--x11-wm/sapphire/files/patch-image.cc70
-rw-r--r--x11-wm/sapphire/files/patch-linkedlist.hh29
5 files changed, 29 insertions, 111 deletions
diff --git a/x11-wm/sapphire/Makefile b/x11-wm/sapphire/Makefile
index c2d31008688f..e01ee5349296 100644
--- a/x11-wm/sapphire/Makefile
+++ b/x11-wm/sapphire/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sapphire
-PORTVERSION= 0.15.7
+PORTVERSION= 0.15.8
CATEGORIES= x11-wm
MASTER_SITES= SF
@@ -14,15 +14,16 @@ MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= Small window manager
USE_GMAKE= yes
-REINPLACE_ARGS= -i'' -E
+REINPLACE_ARGS= -i '' -e
USE_X_PREFIX= yes
+MAKE_ENV= CC="${CXX}"
post-extract:
post-patch:
${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/data.inst
-.for ii in data/menu/default data.inst sapphire.hh
- ${REINPLACE_CMD} "s|/usr/local|${PREFIX}|g" ${WRKSRC}/${ii}
+.for ii in data/menu/default windowmanager.cc
+ ${REINPLACE_CMD} "s|/usr|${PREFIX}|g" ${WRKSRC}/${ii}
.endfor
${CP} ${WRKSRC}/data.inst ${WRKSRC}/sapphire.inst
diff --git a/x11-wm/sapphire/distinfo b/x11-wm/sapphire/distinfo
index 58a4abb73a26..7a474c061128 100644
--- a/x11-wm/sapphire/distinfo
+++ b/x11-wm/sapphire/distinfo
@@ -1,3 +1,3 @@
-MD5 (sapphire-0.15.7.tar.gz) = 5c8a34b4c7b6e7c0dd049d7681350949
-SHA256 (sapphire-0.15.7.tar.gz) = dd6faa6205aa5dcd8b39c4d6dee0c6b7c1f3bbd910f52cd461dcf598b8890771
-SIZE (sapphire-0.15.7.tar.gz) = 58611
+MD5 (sapphire-0.15.8.tar.gz) = de99356b1524e7b9348aefa74b1fb497
+SHA256 (sapphire-0.15.8.tar.gz) = 134bf5315b694bb396d6eb70f0d17353d26b9ef8cdc0493d8dcc02c3b32bf01c
+SIZE (sapphire-0.15.8.tar.gz) = 58986
diff --git a/x11-wm/sapphire/files/patch-Makefile b/x11-wm/sapphire/files/patch-Makefile
index 6c98e94c18b1..8be0b035b5b8 100644
--- a/x11-wm/sapphire/files/patch-Makefile
+++ b/x11-wm/sapphire/files/patch-Makefile
@@ -1,15 +1,27 @@
---- Makefile.orig 2001-11-03 10:51:57.000000000 -0500
-+++ Makefile 2007-08-13 11:16:04.000000000 -0400
-@@ -3,10 +3,10 @@
+--- Makefile.orig 2001-12-31 18:14:43.000000000 -0500
++++ Makefile 2007-09-10 13:42:31.000000000 -0400
+@@ -3,11 +3,11 @@
# frankhale@yahoo.com
# 27 Oct 2001
-CC = g++
-+CC = ${CXX}
- CFLAGS = -g -O2 -Wall #-arch=686
+-CFLAGS = -g -O2 -Wall
++#CC = g++
++CFLAGS += -Wall
--prefix = /usr/X11R6
+-prefix = /usr
+-XROOT = $(prefix)/X11R6
+prefix = ${PREFIX}
- XROOT = $(prefix)
++XROOT = ${X11BASE}
DESTDIR =
INCLUDES = -I$(XROOT)/include
+ LDPATH = -L$(XROOT)/lib
+@@ -15,7 +15,7 @@
+
+ # If you change this, remember to change it in windowmanager.cc (line 34),
+ # and in data/menu/default (lines 43-47, the themes section).
+-CONFIGURATION_PATH=/usr/share/sapphire
++CONFIGURATION_PATH=${PREFIX}/share/sapphire
+
+ # DEBUG = Outputs debug information
+ DEFINES = #-DDEBUG
diff --git a/x11-wm/sapphire/files/patch-image.cc b/x11-wm/sapphire/files/patch-image.cc
index 100d9f4bc93b..a01b3f463ae4 100644
--- a/x11-wm/sapphire/files/patch-image.cc
+++ b/x11-wm/sapphire/files/patch-image.cc
@@ -1,5 +1,5 @@
---- image.cc.orig 2001-11-03 12:14:22.000000000 -0500
-+++ image.cc 2007-08-13 11:25:46.000000000 -0400
+--- image.cc.orig 2001-12-31 17:48:53.000000000 -0500
++++ image.cc 2007-09-10 13:43:45.000000000 -0400
@@ -22,7 +22,9 @@
#include "sapphire.hh"
@@ -10,69 +10,3 @@
#ifdef GradientHack
# include <math.h>
-@@ -158,12 +160,12 @@
- }
-
- if (control->dither()) {
-- short er, eg, eb, *or, *og, *ob, *nor, *nog, *nob, *por, *pog, *pob;
-+ short er, eg, eb, *or_, *og, *ob, *nor, *nog, *nob, *por, *pog, *pob;
- unsigned short *ort, *ogt, *obt;
-
-- control->getDitherBuffers(width + 2, &or, &og, &ob, &nor, &nog, &nob,
-+ control->getDitherBuffers(width + 2, &or_, &og, &ob, &nor, &nog, &nob,
- &ort, &ogt, &obt);
-- if ((! or) || (! og) || (! ob) || (! nor) || (! nog) || (! nob) ||
-+ if ((! or_) || (! og) || (! ob) || (! nor) || (! nog) || (! nob) ||
- (! ort) || (! ogt) || (! obt)) {
- fprintf(stderr,
- "BImage::renderXImage: error getting dither information\n");
-@@ -173,7 +175,7 @@
-
- x = width;
-
-- por = or;
-+ por = or_;
- pog = og;
- pob = ob;
-
-@@ -204,14 +206,14 @@
- }
-
- for (x = 0; x < width; x++) {
-- if (*(or + x) > 255) *(or + x) = 255;
-- else if (*(or + x) < 0) *(or + x) = 0;
-+ if (*(or_ + x) > 255) *(or_ + x) = 255;
-+ else if (*(or_ + x) < 0) *(or_ + x) = 0;
- if (*(og + x) > 255) *(og + x) = 255;
- else if (*(og + x) < 0) *(og + x) = 0;
- if (*(ob + x) > 255) *(ob + x) = 255;
- else if (*(ob + x) < 0) *(ob + x) = 0;
-
-- r = *(tr + *(or + x));
-+ r = *(tr + *(or_ + x));
- g = *(tg + *(og + x));
- b = *(tb + *(ob + x));
-
-@@ -273,11 +275,11 @@
- return 0;
- }
-
-- er = *(or + x) - *(ort + *(or + x));
-+ er = *(or_ + x) - *(ort + *(or_ + x));
- eg = *(og + x) - *(ogt + *(og + x));
- eb = *(ob + x) - *(obt + *(ob + x));
-
-- *(or + x + 1) += er;
-+ *(or_ + x + 1) += er;
- *(og + x + 1) += eg;
- *(ob + x + 1) += eb;
-
-@@ -293,7 +295,7 @@
- off += image->width;
- idata = (pd += image->bytes_per_line);
-
-- por = or; or = nor; nor = por;
-+ por = or_; or_ = nor; nor = por;
- pog = og; og = nog; nog = pog;
- pob = ob; ob = nob; nob = pob;
- }
diff --git a/x11-wm/sapphire/files/patch-linkedlist.hh b/x11-wm/sapphire/files/patch-linkedlist.hh
deleted file mode 100644
index 8e5dc4394e74..000000000000
--- a/x11-wm/sapphire/files/patch-linkedlist.hh
+++ /dev/null
@@ -1,29 +0,0 @@
---- linkedlist.hh.orig 2001-11-03 12:17:15.000000000 -0500
-+++ linkedlist.hh 2007-08-13 10:45:53.000000000 -0400
-@@ -42,8 +42,8 @@
- // I wanna make the next,prev, and data pointers private.
- // But I still need LinkedList and LinkedListIterator
- // to access those pointers.
-- friend _LinkedList;
-- friend _LinkedListIterator;
-+ friend class _LinkedList;
-+ friend class _LinkedListIterator;
-
- private: // Variables
-
-@@ -67,7 +67,7 @@
- Element *head, *tail, *iter;
- int elements;
-
-- friend _LinkedListIterator;
-+ friend class _LinkedListIterator;
-
- private: // Member functions
-
-@@ -160,4 +160,4 @@
- T* current() { return (T*) _LinkedListIterator::current(); }
- };
-
--#endif
-\ No newline at end of file
-+#endif