aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/scwm
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-03 01:12:14 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-03 01:12:14 +0000
commitc7910fc81e35306433adfa560c16f115bdc3133d (patch)
treeaf6c45187bfa4b2c861193cff502b3770abad056 /x11-wm/scwm
parentcc6a2b1acd0f57b3b6a0fc75954b8c7392b209e3 (diff)
downloadports-c7910fc81e35306433adfa560c16f115bdc3133d.tar.gz
ports-c7910fc81e35306433adfa560c16f115bdc3133d.zip
Notes
Diffstat (limited to 'x11-wm/scwm')
-rw-r--r--x11-wm/scwm/Makefile37
-rw-r--r--x11-wm/scwm/distinfo1
-rw-r--r--x11-wm/scwm/files/patch-aa29
-rw-r--r--x11-wm/scwm/pkg-comment1
-rw-r--r--x11-wm/scwm/pkg-descr4
-rw-r--r--x11-wm/scwm/pkg-plist48
6 files changed, 120 insertions, 0 deletions
diff --git a/x11-wm/scwm/Makefile b/x11-wm/scwm/Makefile
new file mode 100644
index 000000000000..a9c10dc82ec3
--- /dev/null
+++ b/x11-wm/scwm/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: scwm
+# Version required: 0.8a
+# Date created: 26 December 1997
+# Whom: Yukihiro Nakai <Nakai@technologist.com
+#
+# $Id$
+#
+
+DISTNAME= scwm-0.8a
+CATEGORIES= x11-wm
+MASTER_SITES= ftp://huis-clos.mit.edu/pub/scwm/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= guile.4:${PORTSDIR}/lang/guile \
+ Xpm.4:${PORTSDIR}/graphics/xpm
+RUN_DEPENDS= ${X11BASE}/include/X11/pixmaps/Animator.xpm:${PORTSDIR}/graphics/scwm-icons
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-guile-prefix=${LOCALBASE}
+#CONFIGURE_ARGS+= --enable-multibyte=yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+MAN1= scwm.1 scwmexec.1 scwmrepl.1
+
+pre-patch:
+.if defined(I18N)
+ ${CP} ${FILESDIR}/patch-ab ${PATCHDIR}
+ ${CP} ${FILESDIR}/patch-ac ${PATCHDIR}
+.endif
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/sample.scwmrc/*.scwmrc \
+ ${PREFIX}/lib/X11/scwm
+
+.include <bsd.port.mk>
diff --git a/x11-wm/scwm/distinfo b/x11-wm/scwm/distinfo
new file mode 100644
index 000000000000..112a67cc6fac
--- /dev/null
+++ b/x11-wm/scwm/distinfo
@@ -0,0 +1 @@
+MD5 (scwm-0.8a.tar.gz) = 229f594f4d6c552579ca4cef2a5b398a
diff --git a/x11-wm/scwm/files/patch-aa b/x11-wm/scwm/files/patch-aa
new file mode 100644
index 000000000000..6c4894e17f28
--- /dev/null
+++ b/x11-wm/scwm/files/patch-aa
@@ -0,0 +1,29 @@
+--- configure.orig Fri Aug 14 18:42:57 1998
++++ configure Fri Apr 2 16:08:39 1999
+@@ -80,6 +80,8 @@
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
++CFLAGS=-I/usr/local/include
++LDFLAGS=-L/usr/local/lib
+ # Maximum number of lines to put in a shell here document.
+ ac_max_here_lines=12
+
+@@ -3257,7 +3259,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lguile $GUILE_LIBS_PRE $GUILE_LIBS $LIBS"
++LIBS="-lguile -lreadline $GUILE_LIBS_PRE $GUILE_LIBS $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 3263 "configure"
+ #include "confdefs.h"
+@@ -3285,7 +3287,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- GUILE_LIBS="${GUILE_LIBS_PRE} -lguile ${GUILE_LIBS}"
++ GUILE_LIBS="${GUILE_LIBS_PRE} -lguile -lreadline ${GUILE_LIBS}"
+ else
+ echo "$ac_t""no" 1>&6
+
diff --git a/x11-wm/scwm/pkg-comment b/x11-wm/scwm/pkg-comment
new file mode 100644
index 000000000000..a38a829fcf08
--- /dev/null
+++ b/x11-wm/scwm/pkg-comment
@@ -0,0 +1 @@
+scheme configurable window manager
diff --git a/x11-wm/scwm/pkg-descr b/x11-wm/scwm/pkg-descr
new file mode 100644
index 000000000000..a3551adca515
--- /dev/null
+++ b/x11-wm/scwm/pkg-descr
@@ -0,0 +1,4 @@
+scheme configurable window manager
+
+For I18N users,
+do make install -DI18N instead of only make install.
diff --git a/x11-wm/scwm/pkg-plist b/x11-wm/scwm/pkg-plist
new file mode 100644
index 000000000000..3a672138fb07
--- /dev/null
+++ b/x11-wm/scwm/pkg-plist
@@ -0,0 +1,48 @@
+bin/scwm
+bin/scwmexec
+bin/scwmrepl
+include/scwmexec.h
+@unexec install-info --delete %D/info/scwm.info %D/info/dir
+info/scwm.info
+@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
+@exec install-info %D/info/scwm.info %D/info/dir
+lib/X11/scwm/decor.scwmrc
+lib/X11/scwm/gjb.scwmrc
+lib/X11/scwm/juhp.scwmrc
+lib/X11/scwm/robbe.scwmrc
+lib/X11/scwm/sds.scwmrc
+lib/X11/scwm/system.scwmrc
+lib/libscwmexec.a
+lib/libscwmexec.la
+lib/libscwmexec.so
+lib/libscwmexec.so.0
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+share/scwm-modules/app/scwm/auto-raise.scm
+share/scwm-modules/app/scwm/base.scm
+share/scwm-modules/app/scwm/bincomm.scm
+share/scwm-modules/app/scwm/decor.scm
+share/scwm-modules/app/scwm/doc.scm
+share/scwm-modules/app/scwm/face.scm
+share/scwm-modules/app/scwm/flux.scm
+share/scwm-modules/app/scwm/fvwm-compat.scm
+share/scwm-modules/app/scwm/fvwm-eval.scm
+share/scwm-modules/app/scwm/fvwm-module.scm
+share/scwm-modules/app/scwm/image-loaders.scm
+share/scwm-modules/app/scwm/module-types.scm
+share/scwm-modules/app/scwm/optargs.scm
+share/scwm-modules/app/scwm/prefs-menu.scm
+share/scwm-modules/app/scwm/std-menus.scm
+share/scwm-modules/app/scwm/style-options.scm
+share/scwm-modules/app/scwm/style.scm
+share/scwm-modules/app/scwm/wininfo.scm
+share/scwm-modules/app/scwm/winlist.scm
+share/scwm-modules/app/scwm/winops.scm
+share/scwm-modules/app/scwm/wmconfig-menu.scm
+share/scwm/scwm-procedures.txt
+share/scwm/scwm.sgml
+@dirrm lib/X11/scwm
+@dirrm share/scwm-modules/app/scwm
+@dirrm share/scwm-modules/app
+@dirrm share/scwm-modules
+@dirrm share/scwm