aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/skippy
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-16 16:56:43 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-16 16:56:43 +0000
commit9efd3cbc3500268b13c0d827ca02bc447614305b (patch)
tree39c2c89d7177717ed06271e20dacaf753ae74020 /x11-wm/skippy
parent8a6937c06fe5c97d6d552ddaab8baccf3faf95e3 (diff)
downloadports-9efd3cbc3500268b13c0d827ca02bc447614305b.tar.gz
ports-9efd3cbc3500268b13c0d827ca02bc447614305b.zip
Notes
Diffstat (limited to 'x11-wm/skippy')
-rw-r--r--x11-wm/skippy/Makefile33
-rw-r--r--x11-wm/skippy/distinfo2
-rw-r--r--x11-wm/skippy/files/patch-skippy.h10
-rw-r--r--x11-wm/skippy/pkg-descr9
4 files changed, 54 insertions, 0 deletions
diff --git a/x11-wm/skippy/Makefile b/x11-wm/skippy/Makefile
new file mode 100644
index 000000000000..9d6fcfcdc5bf
--- /dev/null
+++ b/x11-wm/skippy/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: skippy
+# Date created: 2004-05-15
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= skippy
+PORTVERSION= 0.4.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://thegraveyard.org/files/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= A full-screen X11 task-switcher like Apple's Expose
+
+LIB_DEPENDS= Imlib2.2:${PORTSDIR}/graphics/imlib2 \
+ Xft.2:${PORTSDIR}/x11-fonts/libXft
+
+USE_XLIB= yes
+USE_BZIP2= yes
+USE_GNOME= pkgconfig
+USE_REINPLACE= yes
+PLIST_FILES= bin/skippy
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|; \
+ s|/usr/local|${LOCALBASE}|; s|gcc|${CC}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/skippy ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11-wm/skippy/distinfo b/x11-wm/skippy/distinfo
new file mode 100644
index 000000000000..48eed6c48895
--- /dev/null
+++ b/x11-wm/skippy/distinfo
@@ -0,0 +1,2 @@
+MD5 (skippy-0.4.1.tar.bz2) = 4d0d2b05f8f1357ceb80754f52a90991
+SIZE (skippy-0.4.1.tar.bz2) = 21628
diff --git a/x11-wm/skippy/files/patch-skippy.h b/x11-wm/skippy/files/patch-skippy.h
new file mode 100644
index 000000000000..399e91f56fb8
--- /dev/null
+++ b/x11-wm/skippy/files/patch-skippy.h
@@ -0,0 +1,10 @@
+--- skippy.h.orig Sat May 15 19:33:08 2004
++++ skippy.h Sat May 15 19:33:44 2004
+@@ -20,6 +20,7 @@
+ #ifndef SKIPPY_H
+ #define SKIPPY_H
+
++#include <ft2build.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xmd.h>
+ #include <X11/Xatom.h>
diff --git a/x11-wm/skippy/pkg-descr b/x11-wm/skippy/pkg-descr
new file mode 100644
index 000000000000..12e7de54f97b
--- /dev/null
+++ b/x11-wm/skippy/pkg-descr
@@ -0,0 +1,9 @@
+Skippy is best described as a full-screen task-switcher for X11. It tries to
+provide an alternative when taskbars or regular task-switchers aren't the most
+efficient way of switching tasks (like when you have a lot of applications open)
+When activated (currently only through a hotkey), it will arrange and scale
+snapshots of all windows on the current desktop and it'll let you pick a
+window using a mouse or a keyboard. Yes, this is also what expocity and Apple's
+Expose.
+
+WWW: http://thegraveyard.org/skippy.php